OH2 to OH3 openHabian: No valid OpenPGP data found

  • Platform information:
    • Hardware: RPi
    • OS: Openhabian
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: 2.5.2
  • Issue of the topic: Tried to update to latest Openhab version, get this error
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

I’m following the openHabian upgrade instructions found at Migration to openHAB 3 | openHAB

Using the config tool, I selected the 03 option to upgrade to the openHAB Stable version. I had just previously selected 02, to upgrade the system, which completely satisfactorily.

The error for 03 is;

pi@raspberrypi:~ $ sudo openhabian-config
2021-07-31_17:10:10_EDT [openHABian] Checking for root privileges... OK
Hit:1 https://repos.influxdata.com/debian buster InRelease
Hit:2 https://packages.grafana.com/oss/deb stable InRelease
Hit:3 http://archive.raspberrypi.org/debian buster InRelease
Hit:4 http://raspbian.raspberrypi.org/raspbian buster InRelease
Err:5 https://dl.bintray.com/openhab/apt-repo2 stable InRelease
  403  Forbidden [IP: 443]
Reading package lists... Done
E: Failed to fetch
https://dl.bintray.com/openhab/apt-repo2/dists/stable/InRelease  403
Forbidden [IP: 443]
E: The repository 'https://dl.bintray.com/openhab/apt-repo2 stable
InRelease' is no longer signed.
N: Updating from such a repository can't be done securely, and is
therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user
configuration details.
2021-07-31_17:10:30_EDT [openHABian] Loading configuration file
'/etc/openhabian.conf'... OK
2021-07-31_17:10:33_EDT [openHABian] openHABian configuration tool
version: [master]v1.5-541(5158a5f)
2021-07-31_17:10:33_EDT [openHABian] Checking for changes in origin... OK

$ apt-get -y install apt-transport-https
Reading package lists... Done
Building dependency tree
Reading state information... Done
apt-transport-https is already the newest version (
The following packages were automatically installed and are no longer required:
  alsa-base gstreamer0.10-alsa gstreamer0.10-plugins-base
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libva-wayland2
  libxfce4util-bin libxfce4util-common libxfce4util7 libxfconf-0-2 pimixer
  point-rpi triggerhappy xfconf
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 390 not upgraded.
2021-07-31_17:10:48_EDT [openHABian] Installing or upgrading to latest
openHAB release (stable)...
$ wget -O openhab-key.asc
--2021-07-31 17:10:50--
Resolving bintray.com (bintray.com)...
Connecting to bintray.com (bintray.com)||:443... connected.
HTTP request sent, awaiting response... 403 Forbidden
2021-07-31 17:10:51 ERROR 403: Forbidden.

$ apt-key add openhab-key.asc
gpg: no valid OpenPGP data found.
FAILED (key)

I had found an ostensible fix at this April '20 thread, though when I put " -x" at the end of openhab.bash, packages.bash, and system.bash, then rebooted, the same error still existed.

Also added
deb JFrog stable main
to the sources.list and tried that again. No joy.

What should I try next?

Search the forum for ‘bintray sunset’.

I have found;

Effects of the sunset of Bintray - #39 by dastrix80 which is a long confusing set of exchanges, some of which seem to apply to openHabian and others which may or may not.

openHAB 2.5.x and the sunset of Bintray which recommends either doing some things to continue using 2.5 or just upgrade to OH3, the latter of which I am trying to do.

I also found a second set of instructions on how to upgrade openHabian 2.x to 3.x, and it gives very different procedure;

which is very involved and not entirely clear to me.

In one of posts noted above, you answered a question about manually removing the Bintray link with “openHABian now should offer to do that for you on start.”

openHabian config script does not do that for me. So I performed the following;

wget -qO - 'https://openhab.jfrog.io/artifactory/api/gpg/key/public' | sudo apt-key add -
sudo apt-get install apt-transport-https
echo 'deb https://openhab.jfrog.io/artifactory/openhab-linuxpkg stable main' | sudo tee /etc/apt/sources.list.d/openhab.list

I also removed Bintray from the list above.

Each time I make a change, I reboot and execute 01 and 02, to ensure all updates in those areas are performed before trying 03.

The openHabian-config file version seems stuck on Version 1.5-541, and has menu options that don’t appear in alignment with a number of recommended actions, e.g., openHAB release is menu item 41, not 42.

This last time around, the original problem is not solved and the rabbit hole appears to have grown into a subterranean cavern (at least for my skills).

I have 20 devices or so and a rather uncomplicated openHabian configuration currently, and I have backed up my current install (along with copying out the etc/openhab2 directories).

Would it just be best to start from scratch with a new openHabian install and move over (and relink) my rules?

Then you have not updated openHABian in a very long time. It should ask you on every start. If no you are possibly on the wrong branch (“stable” for OH2).

You must not do two things at the same time, upgrade openHABian AND upgrade openHAB.

For the former, easiest is always to install from scratch.
But you would need to install OH2 (rather than the default which is of course OH3), then import your OH2 config.

Don’t forget to take all usual precautions before the upgrade (config, system level backup etc etc)

Yes, I have been away from OH for rough 1 1/2 years, as I became quite frustrated with trying to keep some of my mains-powered Z-wave devices from mysteriously and randomly ceasing to report, while others of the same make and model remained active.

You must not do two things at the same time, upgrade openHABian AND upgrade openHAB.
For the former, easiest is always to install from scratch.
But you would need to install OH2 (rather than the default which is of course OH3), then import your OH2 config.

I will install from scratch then, though not sure what the “But” means. I have no idea how to import previous OH2 configs into a fresh install of OH2, and given the confusion of all the threads I have been tracking in addition to the ones above, I see little chance of success and another significant waste of weekend hours.

If however it means starting out completely fresh, then I will do so, and give OH one last try.

Use openhabian-config menu options 5X to backup before and restore on the new machine.

From the provided link;

If you need openHAB 2 support please use the stable branch of openHABian, you can switch branches at any time using menu option 01 in openhabian-config

This results in the same Bintray error, and on top of that, it turns out Backup/Restore now simply puts a 0 byte file in my backup drive

On top of that, I can no longer access Habmin or PaperUI, and devices are not responding to my OpenHAB Android app, so even my current configuration is dead in the water now.

I see no other path than to start completely from scratch with OH3 or something similar

which version of openhabian-config do you use ? Looks like it is ( still ) an older version.

yes what did you do ? The link is the official installation docs how to get OH2 installed when installing from scratch. Since you still see bintray you must have done something else.

This is what I had seen in the paragraph you had referenced;

If you need openHAB 2 support please use the stable branch of openHABian, you can switch branches at any time using menu option 01 in openhabian-config

Starting from scratch on OH2, importing from previous OH2, then upgrading to OH3 appears to be a long involved process, so I’ve considered other options.

In a very short period of time, I’ve spun up my zwave devices in Home Assistant and quickly instantiated blueprints for a number of involved rule sets and scenes. Unless something very dire happens, it appears I’ve found the HA suite that matches my level of desired interaction, having been with OH (off and on) since 1.2. I wish all here the best with their instances of OH.

It is not, I’d guess it takes an hour or so. So you dropped OH without even trying ?
Please make sure your choice isn’t based on comparing apples to oranges … starting from scratch always gives fast success in the first place with most software but it’s naive to believe it’ll go on like that. It just means you have not gotten involved enough to date to have a realistic picture of the new SW.