[OH3] New Binding - Speedtest

I had already tried another option above. Unfortunately without success. My guess is that it has something to do with the jar file. I have already read a lot on this topic, but now I can’t get any further. My only hope now rests on the fact that @ muelli1967 will get in touch and his own solution will also help me.
Thank you for your answer.

Guys, almost too long ago since I installed it so I might be out of details, but I have not set up 2 dockers, one for openHAB and one for Speedtest. instead I just stored the speedtest files from here Speedtest CLI: Internet speed test for the command line into the NAS and then did mount it like this:

The config of speedtest in openHAB looks like this:

At first start you need to go into the docker terminal, change user to openHAB and run the speedtest manually to accept the T&C´s. Then speedtest changes to ONLINE and works fine in openHAB.

I hope I captured the questions you had. As you can see I have not updated since 3.1.0_M4 due to time constrains and healthy issues, currently I am just enjoying a system that works reliable for my usecases. If there were any changes that impacts the above procedure, I missed this.

No it has nothing to do with the .jar (binding).
The binding can´t find the speedtest executable in your docker container.
See Jans answer, the speedtest executable must be placed into the openHAB docker container.

Gentlemen, thanks to your help, I made it. :+1: I knew that @muelli1967 would get me on the right track (sorry again for disturbing me on vacation). But the last hint from @Bredmich was also very important.
Finally, one more question is allowed: the entry in the exec.whitelist is important so that the values updated regularly, right?

No, the exec binding isn´t relevant for this.
The whitelist is only needed for Items that execute a commandline.
Using this speedtest binding or my approach with executeCommandLine are not connected to the exec binding or the whitelist.

Great, you never stop learning. Thanks again!


Is it actually possible to convert the output values the channels “Download Bytes” and “Upload Bytes” into Mbit?

The values of Download and Upload are already in Mbit/s.
Do you want them in MB/s?
Then you need to work with dummy items and a rule to convert Mbit/s into MB/s by dividing by 8.
200 Mbit/s divided by 8 are 25 MB/s

I think @bhomeyer made a mistake in his docs.

channel type description
download_bandwidth Number Download bandwidth in MB/s
upload_bandwidth Number Upload bandwidth in MB/s

Atleast my values are Mbit/s :slight_smile:

Hi Michael,

Thank you for your response. But this is probably a misunderstanding. I mean the channels “download_bytes (Number)” and “upload_bytes (Number)”.

I wish you a nice weekend

My speedtest binding stopped working.
When trying to start the speedtest from the commandline i´m getting the following error message:

[2021-09-01 14:56:02.919] [error] Limit reached:

<head><title>429 Too Many Requests</title></head>
<center><h1>429 Too Many Requests</h1></center>

I can´t find any information about a limit for the Ookla speedtest cli.

Any ideas?

Great binding and good work Bredmich!

Is there a way to force the server number?


Speedtest worked for me for several weeks without any problems. However, the binding has been offline for a few days and reports “Speedtest is not returning valid results”. There is also a new speedtest version: ookla-speedtest-1.1.1-linux-x86_64.tgz, but this doesn’t work either.
Could it be that I installed the wrong binding (org.openhab.binding.speedtest-3.1.0-SNAPSHOT_v05.jar)? Or is the problem somewhere else, but I consciously haven’t changed anything. What do the other users say, is there any new information?

In the meantime I have found out that the binding is online when the refresh rate is set to “Don’t test automatically”. With the other settings, online flashes briefly, then the binding goes offline again. If I also switch the test trigger item in the “Don’t test automatically” state, the binding goes offline again immediately. At the moment I have no idea what the problem is. Am I really the only one who has this problem?

I’m not having any trouble with it. The latest version of the binding is here:

I think it’s the one you’re using, but the filename you stated is slightly different. Saying that, if it worked for awhile and then stopped working, I’m doubtful that the binding is the problem. I have mine set to refresh every six hours.

You keep saying “the binding goes offline”, but I assume you mean “the thing goes offline”, since bindings don’t have states. You could try making another thing, as there shouldn’t be anything preventing you from having two of them for Speedtest. I’m curious if you get the same behaviour.

It’s right, the thing keeps going offline. I implemented your proposal, unfortunately with the same behavior.
Oh3 runs in Docker for me, so I can only work with the .jar file. I also checked the rights and made the speed test executable.
I’m still missing some more ideas …screenshot_3

I tried a little and found that the binding version 0.2 remains online, but does not output any values (NULL). In my opinion, it has to be the bond. Is it possible to create an update for openhab in Docker?

I found a solution for myself by extracting the files org.openhab.binding.speedtest-3.1.0-SNAPSHOT.jar and Speedtest from a data backup from 08/20/2021. The installation is then carried out again as described above.
However, I am unable to say exactly where the fault was to be found.
However, I still have one question: can the binding org.openhab.binding.speedtest-3.1.0-SNAPSHOT.jar also be downloaded for openhab 3.2?

Mine is also not working, did someone find a solution for?

2021-12-04 10:47:25.859 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/usr/share/openhab/addons/org.openhab.binding.speedtest-3.1.0-SNAPSHOT.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.speedtest [43]

Hello Community,

I am using the org.openhab.binding.speedtest-3.1.0-SNAPSHOT.jar v0.5 binding, which worked well under Openhap 3.1. However, since the installation of OH 3.2 it no longer works, it is constantly offline. Are there any indications as to whether something needs to be changed in the binding? Perhaps, as a user, you can make changes yourself if you get help.

Thanks in advance.