OH4 => 4.1 GUI doesn't show installed bindings

Did you already try to clear the cache?

Yes sir I do. After an update like this to 4.1.0 I clear cache always. Openhab-CLI clean cache cmd was executed.

Does it work better if you only install the official “openHAB Distribution” add-ons?
It could be third-party add-ons confuse your installation somehow.

Looks good now! Thanks for your support.
I remove all third party add-ons, stop openhab, clean-cache and restart openhab. Now all bindings are back!
To dive a little bit deeper into this issue: SmartHomeJ didn’t update automatically. You must uninstall and install manual to get the new version. Maybe the old version can interrupt openhab?! Dunno, but now it’s working.
@lfs_alp5 can you fix this also in this kind of way and confirm that openhab is working again?

1 Like

I just tried with the amazonechocontrol binding you had installed (SmartHome/J 4.0.x) on a 4.2.0-SNAPSHOT and it does not cause any issues.

I had made the update from 4.1.0-M3. There were no issues before and it start after update to 4.1.0 stable. Thereafter I cleared cash but nothing was OK. I removed two jar Bindings manually installed. Cleared cache nothing happens. After remove Amazon Binding clear cache and then all Bindings are shown as installed. Thereafter I installed Amazon Binding again and everything was fine… So dunno…

But there some guys more in this thread with this issue. Would be great to hear their findings.

Did you all have bindings in the addons folder? As .jar or as .kar? If still available, do you have the exact files?

First question confuses me a little bit. I had only two bindings in this folder. Blink and ConnectedCar. I delete both and there is no backup. Openhab backup script ignore the folder and my personal weekly backup doesn’t contain the files any more. So i can only say no… Sorry for that. And at this point, I forgotten to add them. At the moment there is only one standard file openhab addons 4.1.0.

I reinstalled OH to resolve this since I never figured out the problem. I don’t think I have any 3rd party addons installed (atleast for the time being) but will check if I do install one.

(Sorry for slow reply, haven’t had much time to look at this, just needed to get it working again asap).

1 Like

I had same issue.
The problem was I had old version of 3rd party binding installed. Tuya Binding
I uninstalled the binding thru karaf and removed the cache.
Everything works fine after restart.

1 Like

I doubt that is the issue. I have a test instance that shows the same behavior and has only distribution add-ons installed. It is more likely related to timing during start-up.

For what it’s worth, I have this same issue and I have no third party addons installed. I upgraded from 3.4 docker to 4.1.1 docker. Everything else seems to work fine.


And just like that, now it works… Timing does seem to be an issue, accessing via the addons “store” seems to work fine now after about 10 minutes post startup

1 Like

I cannot confirm a timing issue. I upgraded my openHabian Installation from 4.0 to 4.1 and restarted the whole system. I saw the missing of all bindings, except the manual installed Daikin cloud binding, some days later as I had no time to do a complete walk though the new version earlier.
After reading the first postings on this subject I did another restart and immediately looked after the bindings. This time they were all there. I did not make another restart yet, to see if there would be another change.

Can we try to pin this down to browser/client side (Main UI) code, server side (OH Rest API), or actual OH core code? I am wondering if there may be e.g. a browser cache issue.

Since the REST API returns the wrong values I assume the issue is in KarafAddonService.

I was wondering if the browser is (re)using a prior cached result from the rest api.

Don’t wonder… [rest] Add `no-cache` directive to cached REST responses by florian-h05 · Pull Request #3970 · openhab/openhab-core · GitHub
Depended on your browser there are cache issues. So just imagine you request everytime all data from rest api… that needs time. Any request to the REST API without caching will be very slow. But that isn’t the right topic here. :wink:

So that PR would not be in OH v4.1 right?


I am also experiencing this or similar issue after upgrading from 4.0.4-2 to 4.1.1-1 via the APT repositories.

All bindings/addons show as uninstalled (though they clearly are installed and working), except 1 marketplace addon (Nibe Uplink REST API Binding). I can’t seem to install any of the “missing” openHAB addons (just keeps spinning), but I was able to remove and reinstall the NIBE one.

I’ve queried the server using curl 'https://openhab/rest/addons?serviceId=karaf' -H 'accept: application/json' -H 'Authorization: Bearer ...', and all of them are marked as "installed": false.

Restarting the system or openHAB itself does not seem to change the output of this query (or the webinterface), and neither does it change over time.

I am happy to help troubleshoot!

It seems that (outdated) marketplace addons have something to do with the issue see here so could you try uninstalling your marketplace addon and see if that causes the other (non marketplace) addon to re-appear?