openHAB 2.2, Hue Emulation, Alexa and message 'Device is not responding'

I am using the Hue emulation for the first time together with openHAB 2.2. I configured my items and I was able to pair the Hue Emulation with Amazon Echo (Alexa) and controll my Philips Hue bulb with its name.

I can switch the bulb on and off by saying “Alexa switch Test on” and “Alexa switch Test off” and Alexa Respons with “OK”. When I want to set the brightness of the bulb to 50% I say “Alexa set Test to 50 percent” and Alexa sets the bulb to 50% but this time Alexa responds with “The Device Test is not responding”. Sometimes Alexa sets the brightness and responds with “The value is out of range for Device test”. Here is my item definition for the bulb:

Dimmer LichtkugelLinks_Dimmer_Alexa "Test" (gLivingroom)  [ "Lighting" ]  { channel="hue:0100:001788498eae:LichtkugelLinks:brightness" }

Could someone tell me if this is a configuration problem or a problem with the binding? There is a similiar thread here:

I have the exact same issue, but then controlling a KNX dimmer via openHAB 2.2 on a Raspberry Pi. The pairing worked, the items are discovered, Alexa’s commands get executed (on/off as well as dimming), but with dim commands Alexa complains that the value is out of range or the device is not responding. I also see the 1 offset that is reported in another thread.

This is my dimmer definition:

Dimmer KNX_DA_Bar "Bar" <light> (Lights, Kitchen) [ "Lighting" ] { knx="1/6/4,<5.001:1/6/5" }

Alexa, set Bar to 25% --> That value is out of range for device Bar (but value is set)

Alexa, set Bar to 70% --> Sorry, the device seems to be malfunctioning (but value is set)

Alexa, turn off Bar --> OK

I’ll try to reopen this tread.
I have OH 2.3 with hue emulation. Alexa skill it is not available yet in Italy, so I tried with hue emation.
All device are dicovered by Alexa, but with generic description: “Royal Philips Electronics smart device” instead of switch or light.
So, when I ask “Alexa, turn on the light in the livingroom”, she respond “The value is out of range for device livingroom”, then the light is switched ON.
But, when I ask to turn it off, she say “OK” and the light is switched off.
Anyone else exeperienced this issue or can help me to troublesoot it?
Thank you.

1 Like

Same Here. exactly the same problem …

looking at debug this is what is being captured during the ON operation :

21:09:22.914 [DEBUG] [ulation.internal.HueEmulationServlet] - sending ON to Luce_Ingresso

2018-11-29 21:09:22.925 [DEBUG] [ulation.internal.HueEmulationServlet] - GET /api/f320dd27-6e46-4a0f-91d3-0b2dae259f26/lights/29

2018-11-29 21:09:23.097 [DEBUG] [ulation.internal.HueEmulationServlet] - PUT /api/f320dd27-6e46-4a0f-91d3-0b2dae259f26/lights/29/state

2018-11-29 21:09:23.099 [DEBUG] [ulation.internal.HueEmulationServlet] - HuState [on: false bri: 254 hue: 0 sat: 0 xy: {0.0 0.0 } ct: 500 alert: none effect: none colormode: ct reachable: true

Yeah Sandro,
we are unlucky. nobody use more Hue emulation… and Alexa skill is still unavailable in Italy
we ended up in a vicious circle :cry: