openHAB 3.0 Release Candidates discussion

I have a question regarding connecting OpenHAB3 to my openhab.org. I have been running OH2 with my openhab.org for almost 2 years and no issues. I have now created a new account with myopenhab.org and connected OH3 RC2 to my openhab.org and can receive Notifications to my iOS devices as was the case with OH2. However I am not able to view the OH3 Dashboard remotely using my openhab.org, nor do my iOS OpenHAB apps allow me to see my OH3 Sitemaps when I am off my LAN. Further my OWNTracks client is unable to connect through myopenahb.org as it did when I was using OH2. my openhab.org shows that I am ONLINE, and as I said I receive Notifications, so my question is: Is this expected behavior at this point for OH3 and myopenhab.org or do I need to look closer to home and focus on my setup? I don’t want to be wasting time chasing something that is know to be an issue at this point the development of OH3.

1 Like

You need to login to
home.myopenhab.org and then click on the link to your dashboard. That‘s all.

As a second choice, you can still use BasicUI with sitemaps and this is working with iOS App and openHAB 3.

1 Like

Ok. Thanks for ur reply. I have tried login to home.myopenhab.org but I can’t get the dashboard to load nor do my iOS apps load the the basicUI. If it is working for you and others then it must be something with my setup so I will focus there.

Once you logged into home.myopenhab.org, does it indicate your openhab instance as online ?
If so, you should find a link below to show your dashboard .

first impression is yes, RC2 seems to be less RAM demanding for now (after 6 h)…

1 Like

RC2: When you create a equipment and change it from group to contact, the “Add to model” option is no longer displayed. Is this intentional? I usually need to create points to this equipment, to make door badges in location widgets visible. As a workaround I leave the equipment as group, create the points and then change the equipment to contact.

Sorry for asking a stupid question…

How to upgrade from M5 to RC2?

M5 was installed as follows (fresh install):
wget https://openhab.jfrog.io/openhab/list/openhab-linuxpkg/pool/main/3.0.0~M5/openhab_3.0.0~M5-1_all.deb
sudo apt install ./openhab_3.0.0~M5-1_all.deb

Do I just do the same with RC2 after backup and stopping the openhab service?
wget https://openhab.jfrog.io/openhab/list/openhab-linuxpkg/pool/main/3.0.0~RC2/openhab_3.0.0~RC2-1_all.deb
sudo apt install ./openhab_3.0.0~RC2-1_all.deb

… then restore the backup?
… or is there an upgrade command? (sudo apt upgrade ./openhab_3.0.0~RC2-1_all.deb)

Why did you not use the repo package (apt) install? Then you would have upgrade commands available. Currently apt knows nothing about your non-package installation.

I had troubles connecting to the repo and followed the recommendation below.
+++
Troubleshooting

If you have trouble connecting to the repo with an error that looks like:

Unknown date format Bad header data [IP: XX.XX.XX.XX 443]

then in place of the install command, you can use the file directly e.g.:

wget https://openhab.jfrog.io/openhab/list/openhab-linuxpkg/pool/main/3.0.0~S1919/openhab_3.0.0~S1919-1_all.deb
sudo apt install ./openhab_3.0.0~S1919-1_all.deb

For later versions than the example above, the list of versions can be found here 272.
+++

I was unaware of the implications of that install…

How do I best get on to RC2 and further?
Remove M5 and do a new fresh install from the repo? then restore backup?

Yes I’m ONLINE and I can receive Notifications, I see my iOS devices, can send messages, etc, but I cannot access the OH3 Dashboard. If I switch to OH2 everything works as expected. I even did a clean install of OH3 and I get the same results, so I am pretty much convinced that it is not my setup. Also the GPSTracker binding/OWNTracks iOS client works fine when connecting through my openhab.org, with OH2 but fails with OH3. I continue to get Gateway 500, 504 failures with OH3. OH2 I am able see my dashboards.

This is a fairly big deal for me as I rely on GPSTracker for part of my presence detection. The Dashboard not being available I can live with since I can VPN to server, but GPSTracker/OWNTracks not being able to connect through myopenhab.org will eliminate my ability to make OH3 my production system at this time.

Please make shure to login through

home.myopenhab.org

not

myopenhab.org

This is the important difference!

1 Like

Correct. All of my clients link to https://home.myopenhab.org. The default settings for the Cloud Connector addon in both OH2 and OH3 is https://myopenhab.org so that is what I’m using, although I attempted to use https://home.myopenhab.org as well but I didn’t see any benefit so I reverted to default.

I guess, there is still some kind of misunderstanding.
You don’t need the App on iOS devices to access the dashboard remotely.
In Safari, go to

home.myopenhab.org

and sign in, you should now see the following:

Click to access your dashboard should lead you to your openHAB

Now add it to your homescreen

Only Culprit by using it this way, you won’t have the nice icon. But this will be implemented later within the app.

If this does not work for you, then there is something wrong within your installation.

A post was split to a new topic: InfluxDB not working after upgrade to OH3

2 posts were split to a new topic: Hue binding exceptions in OH3RC2

2 posts were split to a new topic: Yio binding

Weird, normally you get the icon. It’s probably because of the basic auth you have on myopenhab.

A post was split to a new topic: Slider scaling on OH3

Yes iOS is really picky. If have my instance running behind a reverse proxy with client certificate authentication. This will also keep it from using the icon on the Home Screen. Thus, I would really like to see the main UI be integrated into the iOS app.

Thanks for taking time to respond to my issue. I understand that that I should be to access the dashboard directly from Home using a standard web browser such as Safari. However it does not work for me with OH3. It does work if I’m running OH2 however and I have been using it with OH2 for almost 2 years now. My point was that not only does direct access from Home not work, but also my iOS apps also do not work. All give me a time out 500 or 504 error. However, strangely, at least to me, is that Notifications/Messages to my iOS device from the myopenhab.org server work just fine, so some level of connection is established. As you say it may be an installation problem, or in my case a migration issue as I am running Dockers, but I tried a clean install without migrating and I saw the same problem. I will continue to evaluate and report back if I find a solution or the root cause.