openHAB 3.1 Milestone discussion

I’m no expert in sendHttpGetRequest so another one could help please?

But sendHttpGetRequest wants an url and your curl command returns a xml structure.
That could never have worked before.

I think my curl command creates a http request to my Axis device on a web server. That Axis device returns a xml structure as a response. It IS actually working now with your recommendations, but the log in openhab seems wired.

When it’s working now then I assume that the curl alone is sufficient.

Please try this:

executeCommandLine("curl", "--anyauth", "-u", "MySecretUserID:MySecretPWDWithSpecialCharacters", ""))
1 Like

By removing the sendHttpGetRequest everything is working now without any messages in the log.

@NorbertHD : Thank you very much!

OneWire Binding thorws an exeption and does not create a bridge and thing

I have a fresh Openhab 3.1M2 system on a raspberry installed with openhabian. I want to setup my OneWire sensors in Openhab utilizing the OneWire Binding. OWserver is runnding and i can see there the busmaster and the 2 temperature sensores.
After i have installed the OneWire Binding in openhab i want to add a thing manually: OW Server as Bridge. After entering the network adress of my raspberry (i tried it also with i push “Create Thing” button and get only an error message in the logfile

2021-03-09 14:10:25.476 [ERROR] [.AbstractFaultChainInitiatorObserver] - An unexpected error occurred during error handling. No further error processing will occur.

org.apache.cxf.interceptor.Fault: Could not initialize class org.openhab.binding.onewire.internal.OwBindingConstants

	at org.apache.cxf.service.invoker.AbstractInvoker.createFault( ~[bundleFile:1.0.9]
	at org.apache.cxf.service.invoker.AbstractInvoker.invoke( ~[bundleFile:1.0.9]
	at org.apache.cxf.jaxrs.JAXRSInvoker.invoke( ~[bundleFile:1.0.9]
	at org.apache.cxf.jaxrs.JAXRSInvoker.invoke( ~[bundleFile:1.0.9]
	at org.apache.cxf.interceptor.ServiceInvokerInterceptor$ ~[bundleFile:1.0.9]
	at org.apache.cxf.interceptor.ServiceInvokerInterceptor.handleMessage( ~[bundleFile:1.0.9]
	at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept( [bundleFile:1.0.9]
	at org.apache.cxf.transport.ChainInitiationObserver.onMessage( [bundleFile:1.0.9]
	at org.apache.cxf.transport.http.AbstractHTTPDestination.invoke( [bundleFile:1.0.9]

i did the same with a things-file:

Bridge onewire:owserver:busmaster [ 
    ] {
    Thing basic mysensorWW [
        ] {
                Type temperature-por-res : temperature [

result is also an error message in the log file:

2021-03-09 14:29:04.514 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'ow.things'

2021-03-09 14:29:04.557 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception: 

java.lang.NoClassDefFoundError: Could not initialize class org.openhab.binding.onewire.internal.OwBindingConstants
	at org.openhab.binding.onewire.internal.OwHandlerFactory.supportsThingType( ~[?:?]

org.openhab.core.model.thing.internal.GenericThingProvider.lambda$2( ~[?:?]
	at org.eclipse.xtext.xbase.lib.IteratorExtensions.findFirst( ~[?:?]
	at org.eclipse.xtext.xbase.lib.IterableExtensions.findFirst( ~[?:?]
	at org.openhab.core.model.thing.internal.GenericThingProvider.lambda$1( ~[?:?]
	at org.eclipse.xtext.xbase.lib.internal.FunctionDelegate.apply( ~[?:?]
	at$6.transform( ~[?:?]
	at ~[?:?]
	at$5.computeNext( ~[?:?]
	at ~[?:?]
	at ~[?:?]
	at ~[?:?]
	at ~[?:?]
	at ~[?:?]
	at org.eclipse.xtext.xbase.lib.IterableExtensions.toSet( ~[?:?]
	at org.openhab.core.model.thing.internal.GenericThingProvider.createThingsFromModel( ~[?:?]
	at org.openhab.core.model.thing.internal.GenericThingProvider.modelChanged( ~[?:?]
	at org.openhab.core.model.core.internal.ModelRepositoryImpl.notifyListeners( ~[?:?]
	at org.openhab.core.model.core.internal.ModelRepositoryImpl.addOrRefreshModel( ~[?:?]
	at org.openhab.core.model.core.internal.folder.FolderObserver.checkFile( ~[?:?]
	at org.openhab.core.model.core.internal.folder.FolderObserver.processWatchEvent( ~[?:?]
	at org.openhab.core.service.WatchQueueReader.lambda$3( ~[?:?]
	at java.util.concurrent.Executors$ ~[?:?]
	at ~[?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ ~[?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:?]
	at java.util.concurrent.ThreadPoolExecutor$ [?:?]
	at [?:?]

the log entries are in both cases starting with

Could not initialize class org.openhab.binding.onewire.internal.OwBindingConstants

in both cases no bridge / thing is create.
autodiscovery works neither.
Any idea what is the issue here?

Regarding the issue with the OneWire Binding i tried an try and error approach and finally i got it to work.
i tried clean-cache and restart openhab, delete the things-file etc., was not working
it was working after:
uninstall OneWire Binding, clean-cache and restart raspberry pi.
install OneWire Binding
restart openhab
create things-fiile with a bridge and 1 temp-sensor
restart openhab

bridge and temp-sensor from the things-file have been availble and i was able to run the scan
I have added all the things found during the scan and remove the temp-sensor from the things file (as it was the same found during the scan)
the only entry in the things-file is now the bridge and i have no glue how to replace it with a bridge in the UI.
I don’t know wether the issue is solved but at least i have a working solution for the time being.

@Kai It should be noted that 3.1.0.M2 breaks homekit support when running under docker. The items will respond at first but then all drop offline sporadically, restarting the bundle restores everything for a while until it drops off again.

There is a workaround, something to do with disabling ipv6 stack on host. However this PR resolves the issue: [homekit] make usage of mDNS configurable by yfre · Pull Request #10286 · openhab/openhab-addons · GitHub

Can you please mention this on the announcement?

Could you link to a PR that caused that regression?

PR that causes issues:

Thread that mentioned issue and workaround:

I could technically disable the IPv6 stack on host machine to resolve the issue from what others have reported but I don’t like touching the host machine config too much as I also run other services in other containers on the host.

Please let me know if you need any further details.

Thanks for the clarification. I have merged the fix, so hopefully all is good again for 3.1.0.M3.

1 Like

I’ve been having issues (not just since 3.1.0M2) when I start the VS Code editor and it connects to OH.

Somehow it creates an issue where apparently it results in a memory leak later on. I wrote a ticket on github:

I’m happy to help figure out what’s going on. I have a lot of items (textual config) and DSL rules still from OH2. Everything works quite well, but I do get this issue and have to restart OH3 reproducably every time I’m firing up VS Code to make some changes.

I struggled a lot until I finally gave up. I have also the same problem with sending email using version 3.1.0.M2. It’s all fine with Stable 3.0.1.

Anyone else have bundles fail to install when upgrading? I’m on docker so just redeploy and everything is good except none of my bundles are installed. I get a message in the log. I was moving from 3.1.0M1 to 3.1.0M2

2021-03-17 19:08:14.520 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-persistence-jdbc-mysql, openhab-misc-openhabcloud, openhab-binding-pioneeravr, openhab-binding-spotify, openhab-binding-alarmdecoder, openhab-binding-amazonechocontrol, openhab-ui-habpanel, openhab-binding-ecobee, openhab-binding-harmonyhub, openhab-binding-mqtt, openhab-persistence-rrd4j, openhab-ui-basic, openhab-binding-openweathermap, openhab-binding-http, openhab-binding-astro, openhab-binding-gpstracker, openhab-binding-samsungtv’: Error:
Error downloading mvn:org.openhab.ui.bundles/org.openhab.ui.basic/3.1.0.M2

Oops, I guess this was my mistake when doing cleanups on Artifactory last night…
Should be fixed now, could you please try again?

1 Like

Thank you - it took an extra restart after the first ‘upgrade’ startup but things are better now.

Only bundle message I got this time was as follows. The onkyo bundle seems to be working though - the things are online.

2021-03-18 10:40:49.443 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/openhab/addons/org.openhab.binding.onkyo-3.0.2-SNAPSHOT.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.onkyo [209]
Unresolved requirement: Import-Package: org.openhab.core.config.discovery.upnp

Hello @Kai,

I saw in your “openHAB 3.1 Milestone Builds” that you do not recommend to upgrade to Milestone 2. Is there already a timeline that you can share when M3 will become available?

Please apologize if I am not so familiar with the common openHAB release schedules as I am normally not chasing the latest levels. But I am planning to finally move up from OH2(.5.12) to OH3 and intended use v3.1 unless it is not recommended to upgrade directly to v3.1 for production (and maybe better using 3.0.1 instead). And my plan is to do this during the easter holidays if M3 is available in that time frame :rabbit:

Then you seem to have missed the other update: openHAB 3.1 Milestone Builds - #4 by Kai - all fine, it is safe to use.

But you are right that Milestone 3 is due right now. There was quite some activity on code this weekend and there are a few PRs that should still be merged before Milestone 3, therefore we didn’t build it yesterday. I’d hope that this Thursday or Friday might be a good moment for it - you should have it for Easter :wink: .


A post was split to a new topic: Problem upgrading to 3.1M2

Thanks @kai for the 3.1M3 release!

Regarding the release notes this is missing:

For binding [openwebnet]:

  • PR #10191 is also included in M3; this PR also solves #10242
  • PR #10397 (already in the rel notes) also closes #10298 but is not mentioned in the rel notes

Is possible to add these references in the release notes?

Thank you @Kai :clap: … now I have something to during the easter holidays :stuck_out_tongue_winking_eye: