openHAB 3.4 Milestone discussion

This topic can be used to discuss problems/experiences/questions on the openHAB 3.4 milestones.

Do you know why this new (cool) feature wasn’t mentioned in the release notes?

I just installed 3.4 M1 and it is part of it.

Hello, this webaudio feature only available with hab panel or with main UI as well?

It will work with both and when openhab-webui#1426 is merged it will also work with Basic UI.

You’ll first need to enable it in Main UI before you can use it:

1 Like

@wborn : I just tried. I first updated my default audio sink to Webaudio. Then I set the setting as you mentioned to enable the stuff in the Web browser. Finally I run the following command: audio play doorbell.mp3. Nothing is happening, I hear nothing.
Snapshot 3038.
Browser: Firefox
Of course, the same command is working with another audio sink.

I just tested this new feature. Works with Firefox on my Mac (103.0.2) but only for barking.mp3. When I tried to play the doorbell sound, nothing happened.

Same for me on Windows 10, doorbell.mp3 leads to no sound but barking.mp3 is ok.

1 Like

I added several mp3 files to the sound directory. They all worked fine. Do not know why the doorbell sound does not work.

1 Like

Probably due to a MP3 format (frequency ?) not supported by Web Audio ?

When I enable the Main UI option, I need to really restart the browser to make it work.

Both files play fine for me with Chrome on Ubuntu 22.04… however when I use Firefox the doorbell file does not play. :frowning:

I can get both files to play on Chrome on Windows 10 (after interacting with the openHAB web site)

However no luck on Firefox or on Chrome on Android.

@wborn can I see in which built this is merged?

I tested in Chrome on my Android phone and it works well with barking and doorbell.

Can you confirm which Sounds setting you used? Mine has the default Sound Allowed. Tried both HTTP and HTTPS.
The MP3 plays on the PC browser but nothing on the Android.

If you mean the PR to add Web Audio support to Basic UI… it got merged today and is now available in the latest snapshot build (#3048).

Before it will work you first need to enable Web Audio support in the Basic UI settings (and reload any Basic UI):

Sorry, I do not understand what setting you are talking about.
On my side, I only changed the openHAB server setting to select “Web Audio” as default audio sink, and I also changed the MainUI option to enable Web Audio in Main UI.

PS: for Basic UI, there is also a separate setting to enable/disable Web Audio in Basic UI (independent of Main UI setting). Web Audio in Basic UI was just merged today and so is not part of 3.4 milestone 1.

Hi
I mean the settings refered to her:

My openHAB settings are correct, since the audio is played on my PC browser. So I have no idea why I can not get it working on Android or Firefox.

Would be nice if it worked in the Andorid App too.

Sorry, I don’t find the page containing these settings !!!

A feature request should be created in the Git repo of the Android app.

I think browser dependent. And different on PC and Android. I assume you mean the actual browser settings and not the page referring to these settings (that is the GITHub article as top of thread,)

The Main UI “Web Audio enabled” setting is saved in the browser local storage, so it should be configured in each browser.