openHAB Milestone builds

I upgraded to M5 and am glad to see a working ssh/karaf newline again :wink:

Thanks! Seems to work well. I had some (not reproducable) issues due to my timers with the m4 build, is there any need to adjust some timer rules since 2.4(M4)?


1 Like

What’s the process for proposing/adding the semantic tags and/or synonyms that HABot uses. I’ve already noticed a number of locations that would be nice to have. Some that immediately come to mind…


  • Second Floor (parent=Floor)
  • Third Floor (parent=Floor)
  • Laundry Room (parent=Room)
  • Dining Room (parent=Room)
  • Family Room (parent=Room)
  • Powder Room (synonym of BathRoom)
  • Hallway (parent=Room)
  • Driveway (parent=Outside)
  • Patio (synonym of Terrace)
  • Garden (parent=Outside)
  • Porch (parent=Outside)
  • Front Porch (parent=Porch)
  • Back Porch (parent=Porch)
  • Screened Porch (parent=Porch)


  • Luminance
  • Ultraviolet
  • Seismic


  • Fan
  • Ceiling Fan (parent=Fan)


  • Heating Setpoint (parent=Setpoint)
  • Cooling Setpoint (parent=Setpoint)

Some possible options:

  • Create a dedicated thread on the forum to discuss additions?

  • Open an ESH issue.

  • Open a PR to this file?


Note that the update script now also supports the milestones , so if you are not using apt, but the zip distribution, you can easily switch between different versions.

Do I understand correctly from this sentence that upgrading to a milestone using


is not so simple as

sudo apt-get install openhab2=2.3.0-1
sudo apt-get install openhab2-addons=2.3.0-1
sudo apt-get install openhab2-addons-legacy=2.3.0-1

if it is, please tell me what I can use as versions for

  • the latest milestone
  • a specific milestone

HomeKit Integration is working for me on M5. However, when I upgraded from M4 to M5, my OH devices in Home app had lost their “Room” assignments in HomeKit. But I was easily able to reset them.

Sounds like you may need to clear pairings using Karaf and reconnect your OH install to HomeKit. Command is here.

No, if you’re using apt, switching to a specific version will always be the same in summary:

Switch to the relevant repo (i.e. stable, testing, unstable)

sudo apt-cache madison openhab2 allows you to see the list of available versions the “latest” versions are printed first e.g.

openhab2 | 2.4.0~M5-1 |..... 

Install that specific version with sudo apt install openhab2=2.4.0~M5-1

A milestone in apt is always considered newer than a snapshot regardless of their dates so moving from testing to snapshot is the only case where you would need to do the above to upgrade. Otherwise use sudo apt update && sudo apt upgrade to get the latest version.


When I do “sudo apt-cache madison openhab2”

I get the list at the below.
Why don’t I see the milestones?
What am I doing wrong?

openhab2 | 2.4.0~20181031103923-1 | unstable/main arm64 Packages
openhab2 | 2.4.0~20181031103923-1 | unstable/main armhf Packages
openhab2 | 2.4.0~20181031092947-1 | unstable/main arm64 Packages
openhab2 | 2.4.0~20181031092947-1 | unstable/main armhf Packages
openhab2 | 2.4.0~20181029224406-1 | unstable/main arm64 Packages
openhab2 | 2.4.0~20181029224406-1 | unstable/main armhf Packages
openhab2 | 2.4.0~20181029091021-1 | unstable/main arm64 Packages
openhab2 | 2.4.0~20181029091021-1 | unstable/main armhf Packages
openhab2 | 2.4.0~20181028223442-1 | unstable/main arm64 Packages
openhab2 | 2.4.0~20181028223442-1 | unstable/main armhf Packages
openhab2 | 2.4.0~20181028103424-1 | unstable/main arm64 Packages
openhab2 | 2.4.0~20181028103424-1 | unstable/main armhf Packages
openhab2 | 2.4.0~20181026171748-1 | unstable/main arm64 Packages
openhab2 | 2.4.0~20181026171748-1 | unstable/main armhf Packages
openhab2 | 2.4.0~20181022133806-1 | unstable/main arm64 Packages
openhab2 | 2.4.0~20181022133806-1 | unstable/main armhf Packages
openhab2 | 2.4.0~20181022131606-1 | unstable/main arm64 Packages
openhab2 | 2.4.0~20181022131606-1 | unstable/main armhf Packages
openhab2 | 2.4.0~20181018164807-1 | unstable/main arm64 Packages
openhab2 | 2.4.0~20181018164807-1 | unstable/main armhf Packages
openhab2 | 2.4.0~20181018154629-1 | unstable/main arm64 Packages
openhab2 | 2.4.0~20181018154629-1 | unstable/main armhf Packages
openhab2 | 2.4.0~20181015030317-1 | unstable/main arm64 Packages
openhab2 | 2.4.0~20181015030317-1 | unstable/main armhf Packages
openhab2 | 2.4.0~20181012154014-1 | unstable/main arm64 Packages
openhab2 | 2.4.0~20181012154014-1 | unstable/main armhf Packages
openhab2 | 2.4.0~20181011203025-1 | unstable/main arm64 Packages
openhab2 | 2.4.0~20181011203025-1 | unstable/main armhf Packages
openhab2 | 2.4.0~20181011142133-1 | unstable/main arm64 Packages
openhab2 | 2.4.0~20181011142133-1 | unstable/main armhf Packages
openhab2 | 2.3.0-1 | unstable/main arm64 Packages
openhab2 | 2.3.0-1 | unstable/main armhf Packages
openhab2 | 2.3.0~RC2-1 | unstable/main arm64 Packages
openhab2 | 2.3.0~RC2-1 | unstable/main armhf Packages
openhab2 | 2.3.0~RC1-1 | unstable/main arm64 Packages
openhab2 | 2.3.0~RC1-1 | unstable/main armhf Packages
openhab2 | 2.2.0-1 | unstable/main arm64 Packages
openhab2 | 2.2.0-1 | unstable/main armhf Packages
openhab2 | 2.1.0-2 | unstable/main arm64 Packages
openhab2 | 2.1.0-2 | unstable/main armhf Packages

You’re on the snapshot repository. You need to change it to the testing release using these instructions:

ah I assumed that the snapshot release would have everything, including the “officiale releases”

Only the stable releases are in every repository, including snapshot. Which is why you also see “2.2.0” and “2.3.0” there.

Milestone releases can’t be in the snapshot repository because “M1”, “M2” etc. is reported as newer than any number, which would break the functionality of apt upgrade.

1 Like

ok that worked.

What’s the expected release timeframe for 2.4 stable?

Isn’t the M5 supposed to turn up here?

that’s the old (closed) project space
the new one is:

edit: by the way, I just tested M5 on Win 10 x64 with Oracle’s JDK build 11.0.1+13-LTS and I fell on

rolling back to JDK build 1.8.0_192-b12 works fine

1 Like

Java 8 is still the only recommended version at this point in time. But testing to see if there are any other issues with using Java 11 is always welcome.

1 Like

Which issue did you run into? Was it that MaryTTS no longer worked?

this one:

I didn’t test it much… just installed a clean OH2M5 (no bindings, nothing) and after a few seconds, I got this warn in my log

The “illegal reflective access” warnings don’t look nice but shouldn’t give any issues when using Java 9, 10 or 11. The warnings are there to nag developers to stop using deprecated APIs that will be removed in some future Java version.

1 Like


I will try this test-bed setup some more and report to github with additional findings.

1 Like

You should IMHO open an ESH issue for discussion first, if the ontology changes are approved you’ll have to modify SemanticTags.csv as you figured out, then launch the groovy script (generateTagClasses here) to regenerate the type hierarchy - hopefully it will be done as part of the build in the future - and finally open a ESH PR with the changes.
If there are new tags, they should ideally be translated as well.

Remember you can always in the meantime tag the item with a more “generic” parent class (like ["Room"]) and add a synonym with metadata, i.e.

Group gStudy (gFF) ["Room"] { synonyms="Study,Office" }

Yes! This worked perfectly. Thanks!!

["Floor"]       { synonyms="Second Floor" }

["Room"]        { synonyms="Dining Room" }
["Room"]        { synonyms="Hallway" }
["Room"]        { synonyms="Powder Room" }
["Room"]        { synonyms="Laundry,Laundry Room" }
["Room"]        { synonyms="Master Bedroom" }
["Room"]        { synonyms="Utility Room" }
["Room"]        { synonyms="Family Room" }

["Outdoor"]     { synonyms="Front Porch" }
["Outdoor"]     { synonyms="Screened Porch" }
["Outdoor"]     { synonyms="Driveway" }
["Outdoor"]     { synonyms="Patio" }
1 Like