OpenHAB not saving mesaurements after daylight saving time change

All my datapoints are empty past 3:00 (time change from 2:00 -> 3:00)
Openhab is running on an RPi3 (openhabian image)

Using influxdb (persistence)

Same for me. All charts in my sitemaps doesn’t show values since 1:00 o’clock. I am using rrd4j persistence.

Did you try to restart the openhab service?

I do see the same , Rest API shows for the timeframe 2017-03-26T00:00:00.000Z to 2017-03-26T04:00:00.000Z only 61 values.
So it stopped at 01:00 Z, which is 02:00 in localtime (wintertime), at that time the switch was done to 03:00 summertime.
The actual displayed values are correct, only the saving to the database isn’t working. In my case it is a rrd4j database.

Yes restarting solved the issue but it will happen again when we change the clock back for 1 hour :frowning: And I don’t wan’t it to happen again without me knowing it :slight_smile:

Restart solved it as well. That might be worth an issue report, let us look through the already reported issues before filing a new one.

Today my rollershutters didn’t go up as usual. They are controlled by time at the weekend.

In the log file I got the following messages:

2017-03-26 03:00:00.103 [INFO ] [cheduler.ExpressionThreadPoolManager] - Expression ‘0 0 * * * ?’ has no future executions anymore
2017-03-26 03:00:00.255 [INFO ] [cheduler.ExpressionThreadPoolManager] - Expression ‘0 * * * * ?’ has no future executions anymore
2017-03-26 03:00:00.406 [INFO ] [cheduler.ExpressionThreadPoolManager] - Expression ‘0 * * * * ?’ has no future executions anymore

I assume, it is related to this.

That could be since at least @cweitkamp and me are using the rrd4j database, which needs a strategy for every minute. I would search in that direction first.
How about the setup, I’m on OH2, more precisely on Openhabian, how about the others?

I agree . Restart solves the problem at the moment. But doesn’t solve the problem at its origins. Let’s open an issue or look for an existing one.

In my live environment I am using Raspbian Jessie with OH2 installed from Stable repository.

Same here. Openhab2 on OpenHABian on Pi2.
rrd4j database stopped logging when GMT changed to BST last night.
Displayed current values are correct, just no logged data.
Restarting Openhab fixed it.
Not sure how to report this as an issue that needs fixing.

Maybe someone else can confirm the following observation (I’m using influxdb):

Items with

strategy = every10Minutes

after 3:00 had no new datapoints until I restarted openHAB.

Items with

strategy = everyUpdate

have still data points after 3:00

So it seems for me it has something to do with the internal scheduler.

Regards,

André

I’m pesisting only everyMinute and had the issue. I also assume it is the scheduler.

I’m using every 5 minute.

And no datapoints from 3:00 -> Openhab restart.

I would file the issue, but where?
It looks like it is related only to rrd4j or persistence. Would that be Eclipse Smarthome or OpenHAB Core?

Thank you.

That is a good question. I think it should be placed in the Eclipse Smarthome project.

Filed an issue on ESH

As it is also a problem with InfluxDB (as mentioned above), the issue is in the cron scheduler - I hope @kgoderis will find a fix within the next 6 months before the bug can hit us again :wink:

:blush: I guess I had a bit too much of the sun yesterday. That statement of mine should have read “…related not only…”!
Speeking for all the other posters in this thread, we do hope that @kgoderis can find a way to simulate such a time-switch on his system.

Are we all prepared for this tonight? The clock is turned back again to match wintertime. At 3 o’clock in the morning. The issue in ESH hasn’t been closed, yet. What will await us this time?

Just to give you any feedback. I faced no problems this time.

No problems here as well, the chart even shows correctly 2o’clock two times.