OpenHAB not saving mesaurements after daylight saving time change

Are we all prepared for this tonight? The clock is turned back again to match wintertime. At 3 o’clock in the morning. The issue in ESH hasn’t been closed, yet. What will await us this time?

Just to give you any feedback. I faced no problems this time.

No problems here as well, the chart even shows correctly 2o’clock two times.

Glad to hear that there was no major issues this time. My system went to a load average of 205 tonight, but this stayed like this even after fully stopping openHAB - so there’s a good chance that this wasn’t the culprit then :slight_smile:

Next shift to DST, old problem again.
It looks like the shift from DST to normal worked (as reported in Oct’17) however tonigth shifting to DST again rrd4j stopped again.
I’m running on OH1.2 (rrd4j 1.11.0)
The binding reporting the values (in my case Tankerkoenig) is confirmed working.
Checking the rrd4j with the REST API: A Persistence/Get request showed the rrdj, however the reguest for persistence/items/itemname gave a 400.

Stopping and Starting the bundle did resolve the problem.

Would be great if this issue is checked and eventually resolved.

Same problem again with rrd4j charts stopping at 2am. Also had my RPi3 cooking itself with OH 2.2 running constantly over 100% CPU usage.

Same problem here. RPI3, OH 2.2, 100% CPU…

Have to correct the statement from above, it needed at restart of
OH, the restart of the rrd4j bundle only changed the behaviour of displaying the time series ( the chart showed times up to now again but NOT actual values).

Old issue also exists with InfluxDB. (RPI3, OH2.2, InfluxDB 1.4.2)
Data from MQTT sensors is stored intermittently: (strategy = everyChange, everyMinute)

Data from Homegear ( strategy = everyChange, everyHour, everyMinute) shows set temperatures are unaffected, wall thermostat was not affected but valve position data dropped out at 3:00 AM.

However, for another wall thermostat there was no data recorded after 3PM.

I did a full re-boot to recover (did not try restarting openhab).

Dear all,

I want to share my experiences with you. The bug has been fixed three days ago (see DST bug fix in 2.3.0-SNAPSHOT and I upgraded my live environment to snapshot version #1238 on Friday directly after @Kai had announced it in the community. For me everything worked fine last night. I just checked my persistence (rrd4j), logs and system. Neither I found cut offs in my charts nor related entries in the log file. My environment runs fine w/o high cpu usage.



Thanks for this information. As I’m still on the stable release (1.2), the reason is clear.

2.2 or 1.2 ? 1.2 is very very very old !

I’m still on 2.0 here! (OpenHABian)
How do I upgrade/update it without having to set everthing up again?

Have a look at here and here.

I suffered from the time switch as well, I meant to say 2.2. Sorry for that :blush:

Nah, doesn’t help a bit!

The only thing I can do to upgrade openhab is to start from the beginning! There is no option or way to update openhabian 2.0 to a newer version without me redownloading the newest Pi image from the web and redoing everything… It just doesn’t make sense to redo all my configuration, settings… It would take way to much effort and time…

How did you come to that conclusion?

And how do you do a backup ?

Because you are on a very old build you may need to perform these steps:

Note the link to the backup script at the end …