Openhab4 will not restart


I have used openhab for years reliably. I recently upgraded to openhab4 by a clean install, restoring basic config and manually setting up mosquitto.

Since then I have had repeated problems with the system not restarting following sudo reboot. So I’ve been forced each time to flash a complete new card and start again. In most cases the rpi4 is completely unresponsive to SSH.

Today I rebooted again because the GUI wasn’t rendering properly (displayed what looks like code). This time I can log into openhabian on SSH but openhab has not started. The Tail log keeps cycling old entries from just prior to reboot and the GUI is not started.

I have tried restarting openhab from the terminal but it makes no difference. I can operate the openhabian-config and have taken a fresh config backup.

I notice when i login on SSH i get this message:

sed: can’t read /var/lib/openhab/etc/ No such file or directory

I am using RPi4 and Gigastone 16gb sd card.

I’m beginning to get frustrated! Any help gratefully received.

Quick update: i should probably open a new thread…a fresh flashed card has not come up on port 81, neither has it generated a hotspot as promised. i am using this image file: openhabian-raspios32-latest-202403151233-crc5392bc66.img.xz

You are running OH4 with a non-migrated OH 3.x config. See first question of the OH4 migration FAQ how to install OH3 and migrate from there.

thanks. i’ll re-read and come back if i can’t make progress. i have flashed the latest oh4. is there any reason why the hotspot isn’t working and it’s not coming up at all? this is before restoring any config. i have wired ethernet so shouldn’t need wifi. i edited the config file as well to add wifi credentials but still nothing. the port 81 showed log entries and then shut down but nothing was accessible after that.

Hotspot is only started when you don’t have inet connectivity. Anyone who has Ethernet does not need so should not setup Wi-Fi.
Please read the docs.

I can confirm that during my tests without ethernet (with 32bit and 64bit version) the hotspot didn’t come up.

That did not happen during my testing. Please reproduce with debugmode=maximum, and check first-boot.log to see what happens and why hotspot is not there.

This is probably totally unrelated, but I have had issues with Rpi4 restart after a controlled shutdown. The problem is I have a powered USB hub for my Zstick and I believe it provides some residual power to the RPI4, so won’t restart. Solution for me is I have to manually unplug the hub and the Rpi4 power, then just plug in the Rpi4. Doesn’t sound the same unless you have something powered like a Hub or POE connected.

Hi. I do have a z-wave UZB stick however it has not seemed to be a problem under OH3 and i can’t see why it should be under OH4. However i will try a few things out and report back. Not had time today sadly. Thank you for your input.

thanks. i did know this. however in my case it refused to come up at all on the network even when plugged to wired ethernet. hence i imagined it would default to wifi as no connectivity.

Having actually read the FAQ instructions (thank you) I confirm that I now have upgraded to 3.4.5 successfully and it seems stable. I do have an issue moving to 4 (java crash on reboot) but that seems to have been reported and solved in other threads so I will read through them in time. Also I worked out that the apparent lack of connectivity was my error as had wrong ip address reservation in the router. So I think this thread can be marked as closed and solved. As ever thank you for the support.

And finally to confirm I have successfully migrated to OH4 from 3.4.5 when I followed the instructions on this thread: Upgrade 3.4 -> 4.0.2: Java 17 and still Error installing boot features