OpenWeatherMap widget for HABPanel

habpanel
widgetgallery
Tags: #<Tag:0x00007f51eb0bfa88> #<Tag:0x00007f51eb0bf6f0>

(Ahnyerkeester) #105

I don’t and it is working. What is that?


(Walt Jones) #106

How would this file have gotten placed into the folder? Was it done with the widget import?

WJones


(Homer Sim) #107

No, I do not have this in my folder, but it is nowhere listed is it?

drwxrwx— 2 openhab openhab 4096 Feb 24 21:31 images
drwxrwx— 10 openhab openhab 4096 Feb 23 22:35 weather-icons-master


(Homer Sim) #108

grafik

This is my settings


(Walt Jones) #109

I found where the detail I missed was…

/etc/openhab2 IS the conf folder.
So you need to unpack the zip into:
/etc/openhab2/html/openweathermap

I unzipped the file locally (on PC) and moved into the samba share folder. I will give this a shot when I get home. Maybe the directions could be a little clearer (add note to unzip the files into the folder indicated?

Thanks for all of the work!


(Homer Sim) #110

I am running openhab in a docker container and the config/html file is clearly to find on a docker volume. in data volume there is a etc folder but without openhab2 folder …

Ok … did create all folders in etc but still no improvment


(Scott Karns) #111

How are you starting your OpenHAB container? You undoubtedly have several host directories that are specified as part of your docker run invocation that are mounted in the running container. The one you are after is the one that mounts at /openhab/conf in your OH container. On my system, the container start script contains the following volume (-v) option:

-v /home/openhab/oh/openhab_conf:/openhab/conf

Per @Wjones23 instructions, on my system I would unzip the ZIP archive to /home/openhab/oh/openhab_conf/html/openweathermap

The destination on your docker host system is probably different, but it is the path specified for your OH container’s /openhab/conf volume.


(Homer Sim) #112

This is it:
docker run
–name openhab
–net=host
–tty
-e OPENHAB_HTTP_PORT=8060
-e OPENHAB_HTTPS_PORT=4436
-v /etc/localtime:/etc/localtime:ro
-v /etc/timezone:/etc/timezone:ro
-v /docker/config/openhab/addons:/openhab/addons
-v /docker/config/openhab/conf:/openhab/conf
-v /docker/data/openhab/userdata:/openhab/userdata
-e LC_ALL=de_DE.utf-8
–device=/dev/ttyUSB0
–restart=always
-d
openhab/openhab:latest

and I used /docker/config/openhab/conf for installation


(Scott Karns) #113

So, from the option -v /docker/config/openhab/conf:/openhab/conf, you need to unzip the archive to /docker/config/openhab/conf/html/openweathermap


(Homer Sim) #114

that is what I did. owner and mod is also set correctly


(Scott Karns) #115

I note that you specify neither USER_ID nor GROUP_ID environment variables when you start your container. Are you sure the numeric UID and GID of the owner/group of /docker/config/openhab/conf and everything below it are the same on your host system as they are in the container?


(Homer Sim) #116

openhab user is existing in container and host and both ids are 9001 …


(Scott Karns) #117

I’m running out of ideas, but I wonder if your installed openweathermap binding is actually online. What do you get from the karaf console when you enter:

things list | grep openweathermap

On my production system, I get:

openweathermap:uvindex:api:local (Type=Thing, Status=ONLINE, Label=Local UV Index, Bridge=openweathermap:weather-api:api)
openweathermap:weather-and-forecast:api:local (Type=Thing, Status=ONLINE, Label=Local Weather and Forecast, Bridge=openweathermap:weather-api:api)
openweathermap:weather-api:api (Type=Bridge, Status=ONLINE, Label=OpenWeatherMap Account, Bridge=null)

(Walt Jones) #118

Not “per WJones”…I am a newbie. I just copied a post from earlier in this thread. See previous posts. But thanks for thinking I have a clue!:grin:


(Scott Karns) #119

I’ll just say that you managed to sort out your own problem, which makes you more than a “level-0 newbie” :sunglasses:


(Ahnyerkeester) #120

Next to one of those do you have 11%20PM ?
Need to click that to expand those things and see what they’re linked to.


(Walt Jones) #121

I guess I didn’t find my entire issue…

I copied the OWM js file into the /conf/html/openweathermap/ folder.

When I rebooted, I now see this… help please.


(Ahnyerkeester) #122

That’s not where it belongs. You might want to go through the set up steps again.


(Walt Jones) #123

What am I missing?


(Ahnyerkeester) #124

Those are the right steps. I don’t see where it says to copy the OWM js to html. Where are you seeing it?