Port /dev/ttyACM0 does not exist in Raspbian GNU/Linux 10 (buster)

  • Platform information: Raspberry pi 4 Model B Rev 1.1
    • Hardware: CPUArchitecture/RAM/storage
    • OS: what OS is used and which version Kernel = Linux 4.19.66-v7l+
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version:openHAB 2.5.0~M2-1 (Milestone Build)
  • Issue of the topic: Trying to configure zwave stick, port ttyACM0 is not listed as available
    File /dev/ttyACM0 does not exist. Configuring ttyAMA0 as the zwave controller port does not work as zwave controller (aeotec Z-Stick Gen5 model ZW090-C) is unable to get online status.

I made a fresh installation from openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img.xz

I will appreciate any comment on how to proceed to get the zwave controller working.

run this command and post output

dmesg -T | grep tty

1 Like

This topic might help you

Hi @foruny

I’m guessing you’re plugging the Aeotec Z-stick into the RPi directly? Unfortunately, the two have issues together:

I use an amazonbasics hub attached to the RPi 4 to use my Aeotec stick. /dev/ACM0 shows up after then.

1 Like

After running dmesg -c I ran dmesg -T | grep tty

No output. It seems like plugging the stick is not recognized by the system.

Plugging the zstick directly into a Pi4 will not work because the zstick dies not follow the usb specification. The port shuts down to prevent hardware damage to the Pi.
A workaround is to use a USB 2 hub between the Pi4 and the zstick.
The permanent solution is to use a usb certified device that meets the specifications.

Thank you @Benjy. I understand that there is a design flaw on the hardware of the Aeon Labs Z-Stick Gen5, not being able to pass usb certification program. Fortunately the workaround of connecting though an USB hub worked for me.


after dmesg -T | grep tty

[Wed Jun  8 17:48:48 2022] Kernel command line: coherent_pool=1M 8250.nr_uarts=0 snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1 video=HDMI-A-1:640x480M@60 smsc95xx.macaddr=E4:5F:01:79:7C:5B vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  console=ttyS0,115200 console=tty1 root=PARTUUID=91192829-02 rootfstype=ext4 fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
[Wed Jun  8 17:48:48 2022] printk: console [tty1] enabled
[Wed Jun  8 17:48:49 2022] fe201000.serial: ttyAMA0 at MMIO 0xfe201000 (irq = 34, base_baud = 0) is a PL011 rev2
[Wed Jun  8 17:48:51 2022] systemd[1]: Created slice system-getty.slice.
[Wed Jun  8 23:33:37 2022] cdc_acm 1-1.4:1.0: ttyACM0: USB ACM device
[Thu Jun  9 13:14:38 2022] cdc_acm 1-1.4:1.0: ttyACM0: USB ACM device

cant find ACM0 and AMA0 isnt working =(

what is the result of the command

ls -l /dev/serial/by-id/

its crazy, I connected an arduino UNO.

sometimes ttyACM0 is showing and the board is connected

some minutes later the board is no longer available / not found

ls: cannot access '/dev/serial/by-id/': No such file or directory

could it be that this is linked to a power supply problem.

its definitly the overheating, i always lose the uno when outdoor temperatures are 30*C +