Problem with fresh Openhab 2.5 / Zigbee / Bitronvideo Ember Dongle / Device Pairing

Hi,

today I took a second attempt to set up OpenHAB 2.5 with a new zigbee dongle. Some devices (working with CC2531 / Openhab 2.5 M2) now seem to cause problems.

The Bitronvideo dongle itself seems to work properly, pairing and adding of three Osram Smart Plugs via Paper UI was successful

System: fresh Openhab 2.5 release install on RPi 3B
Coordinator type : Ember (this one: http://www.bitronvideo.eu/index.php/produkte/smart-home-produkte/zb-funkstick/)

Description of the Problem
I failed in completing device discovery and adding of things with two Ikea Tradfri light bulbs, one Xiaomi 2-channel Relay and an Ikea Tradfri Signal Repeater.

1. Device discovery / Paper UI Inbox:

  • All devices listed above do not complete discovery, the inbox shows e.g. “Unknown ZigBee Device 00158D00033F0005”. I tried for hours!

2. Adding the devices as things (ignoring the incomplete discovery):

  • For the Xiaomi 2-channel switch (00158D00033F0005) and the Tradfri repeater ( 000D6FFFFE9A0D40), nothing happend, The devices didn’t get updated and stayed in state “UNKNOWN”. I removed these devices after some time.
  • Tradfri bulbs: After some time and putting binding and bulbs in discovery mode many times, their things got updated in multiple steps and received a “Level Control” channel. But I was not able to use this channel, as I received the following error: “Error opening device level controls”. The color channel which these also should have does not appear.

Any idea where there might be a problem? As I mentioned above, all devices worked with CC2531 / zigbee binding / openhab 2.5 M2.

I tried to produce a debug log (zip file because of file size limit, please rename to .zip) which shows the following sequence:
openhab.txt (269.2 KB)

  1. Openhab startup (and some minutes of waiting)
  2. Zigbee Binding is put into discovery mode
  3. Tradfri Bulb 14B457FFFE4CF159 is put into discovery mode --> no result, device stays “unknown zigbee device”
  4. Zigbee Binding is put into discovery mode again
  5. Tradfri Bulb 14B457FFFE4E0900 is put into discovery mode --> no result, device stays “unknown zigbee device”
  6. Zigbee Binding is put into discovery mode again
  7. Xiaomi Relay 00158D00033F0005 is put into discovery mode --> no result, device stays “unknown zigbee device”

  1. Tradfri Bulb 14B457FFFE4CF159 is added as a thing, though still listed as “Unknown Zigbee device” in the inbox
  2. Binding and bulb are put into discovery mode --> thing gets updated for the first time (still without a channel)
  3. Binding and bulb are put into discovery mode again --> thing gets updated, now with a “Level Control” channel and the error message “Error opening device level controls”

As a reference, I also have the openhab 2.5 M2 zigbee-xml-files available:
14B457FFFE4E0900.xml (68.1 KB) 00158D00033F0005.xml (157.7 KB) 14B457FFFE4CF159.xml (68.1 KB) 000D6FFFFE9A0D40.xml (60.9 KB)

Thank you!

I had a look through your log, but it’s quite difficult to correlate your actions with what is in the log. There are a lot of requests to NWK addresses that do not receive responses - I really don’t know why this is. It could be that devices were added, but are not really close enough to respond (eg they are on the edge of coverage), or it could be that they have been reset and changed their address, and then not rejoined (or rejoined, but we don’t know the updated address - or have not correlated the NWK address with the MAC address).

I see a lot of EMBER_DELIVERY_FAILED responses to commands - this means the dongle did not get a response from the device. (by a lot, I mean around 350).

I see this device apparently join the network, but it then does not respond to commands.

There are no commands that I can see in the log, so maybe the command is not being sent to the binding?

The fact that these appear quite complete means that they have communicated at some point, and they should get discovered. However, if they have been reset, then they will have changed address, and I guess the binding has not recorrelated the addresses. I don’t see any messages where devices are announcing themselves into the network

Thank you for having a look.

All devices are in the same room as the coordinator and some of them even at the exact same position where they worked with CC2531 / Openhab 2.4 and 2.5 M2 for several months. Besides, I placed the Osram plugs (which are working) at the edges of the room. --> So range should not be the reason.

I’m sorry, this was not part of the debug log, but I tried this in advance for many times. I will add a debug log showing this step.

Please note that these are NOT the xml files of Openhab 2.5 (release) - these are the files from my previous install with Openhab 2.5 M2 / CC2531 where all devices were working as expected. I’ll also add the xml files of Openhab 2.5 release install where these problems occur.

Fair enough. All I can go on is the result from the coordinator which states that the device does not respond. Maybe it has not joined the network.

The Ember dongle really has a LOT of users (not just openHAB), so I don’t anticipate problems with it in general.

I fully understand. Is there anything you would recommend me to try out?

Right now the only option I can think of is to downgrade this system to e.g. 2.5 M2 and see if things are working there - to see wheter it’s a problem of the dongle or related to system / software.

As mentioned above, here are the xml files of my 2.5 releae install where the problems occur: 000D6FFFFE9A0D40.xml (146 Bytes) 14B457FFFE4CF159.xml (69.6 KB) 14B457FFFE4E0900.xml (69.6 KB) 00158D00033F0005.xml (146 Bytes)

Unfortunately, I’m not able to produce a debug log while sending Level Control commands, as the bulbs do not even show up as online.

Not really - not unless you have a network sniffer available.

Unfortunately this doesn’t help - it shows information about the device, but not why the device is not communicating.

When you change between M2 and 2.5 RELEASE, what are you doing? Why do you need to rediscover the devices? Shouldn’t they continue to work (there isn’t exactly a lot of difference between them).

This system is a fresh Openhabian 2.5 release installation - I did not upgrade from 2.5 M2! I’m sorry if this hasn’t been clear. I also did not import any configuration files. I tried to add device by device by resetting each of the devices / putting them in discovery mode.

That’s why I’m so surprised that things are not working! I actually bought an Ember dongle as I read that it is well tested and reliable.

There should be very little difference between these two versions, so I don’t really understand why it is not working. We use this dongle extensively for commercial systems, and are currently in the final stages of formally certifying a ZigBee system with the Alliance with this chipset inside.

The libraries in the binding are quite old now and I’m in the process of updating to the latest version. Hopefully I’ll have that done today or tomorrow and then it might be worth trying again as it cleans up a few issues that may be contributing.

Could this be a firmware issue of the dongle? Or is there no required version as e.g. for the Telegesis dongle?

I’ll be glad to try this once it is ready.

Probably not - unless it’s very very old it won’t really matter. I think quite a few people are using this dongle without problems.

Hi,

I think I ran into the same or at least a very similar problem:

I was using OpenHab 2.4 with the following devices for about a year now:

  • Bitronvideo ZigBee dongle (listed as BV 2010/10, Ember EM35x NCP in “Things”)
  • 2 tint color+white light bulbs

I had no issues at all with OpenHabian 1.4 and OpenHab 2.4. The devices even kept working after updating to OpenHab 2.5. A couple of days ago, I decided to install OpenHabian 1.5 and OpenHab 2.5 from scratch (for no good reason actually … :-|)

So I needed to pair the two light bulbs again. I did a reset and put the ZigBee dongle and the bulbs into discovery mode. The devices only show up as “Unknown ZigBee Device XXXXXXXXXXXXXXXX”. Pairing never completes. I made like 30 attempts.

Usually, no channel shows up. Sometimes, I got a channel called “dimmer”, but it did nothing. Only once, the device showed up with its correct name and channel:

  • Name: MLIZBTExtendedColor
  • Channel 1: “Color Temperature”
  • Channel 2: “Color”

Nevertheless, the lamps also didn’t signal pairing success (usually by flashing a couple of times) and I wasn’t able to control the lamps via OpenHab afterwards.

I did not capture any logs yet, but I can do so if you could provide some clear instructions.

Best,
Christian

As I already said, I very much doubt this, but I guess I should have asked what version you have? It will be displayed in the log on startup and should also be in the thing properties.

Are the instructions provided in the binding documentation unclear? If so, I’ll try and improve this, but please provide feedback on what you think is not clear.

Thanks.

1 Like

I forgot to mention that I made a disk image of my previous OpenHabian 1.4/OpenHab 2.5 installation before attempting the clean OpenHabian 1.5/OpenHab 2.5 install.

I reverted back to that image and it’s the same there: No successful pairing with OpenHab 2.5 and the BV dongle. So this issue seems to happen on fresh installs as well as on upgraded ones.

I’ll post my openhab.log in a minute.

That binding and the one from the new installation are identical, assuming you meant that 2.5 Stable was installed on both systems.

Here’s the OpenHab 2.5 log: openhab.log (768.5 KB)

I removed all the ZigBee things, including the dongle, and went through the discovery process again two times, both times adding the “Unknown ZigBee Device 00158D0001FE0393” as a thing.

On the seconds attempt, I noticed that the device was recognized as “online” and had two channels attached (Color Temperature and Color), but again, the lamp itself didn’t confirm the successful pairing and also didn’t respond to changes to the Color/Color Temperature via OpenHab.

To clarify:

First system:

  • originally OpenHabian 1.4 + OpenHab 2.4
  • pairing of devices was done via OpenHab 2.4 about a year ago
  • upgrade to Openhab 2.5
  • already paired ZigBee devices still working
  • after resetting the ZigBee devices and deleting them from OpenHab, I was not able to pair them again

Second system:

  • originally OpenHabian 1.5 + OpenHabe 2.5
  • pairing never succeeded

Currently this is running an old version of the libraries so I won’t really look at this until I’ve updated the binding to the newest version. There are some conflicts between repositories that are causing problems with this, so until this is resolved I can’t do anything.

Hopefully I’ll get the binding updated in the next few days.

I checked both but could not find a version information.
The startup log shows a lot of configuration information about the dongle (and some strange “unsupported cluster” messages), but as far as I can tell no version information: openhab_log_startup.txt (137.4 KB)

Paper UI only shows two properties: usb_product_id": “35636.0”, and “usb_vendor_id”: “4292.0” (coordinator_jsondb.txt (5.2 KB) )

Is there another way to check the firmware? Or did I miss it in the startup log?

It will definitely be in the startup log - it’s almost the first thing that is logged when the EZSP layer starts. It will be something like 6.3.4.5.

Are the serial parameters set the same as the old system? That could cause communication issues.