Qubino Mini Dimmer ZMNHHD no Channels


I am switching over from Domoticz to OH.
Just before the weekend crashed the software on my Raspberry Pi with Domoticz, so that was the perfect moment to make the change.

Now the system is running, i found some troubbles with the “new” Qubino Mini Dimmer ZMNHHD.
It is found by OH, but even after multiple times resetting, removing, etc, OH will not show the channels of the ZMNHHD. (the same problem in Domoticz)

I got Openhabian running on:

  • Raspberry Pi3b
  • Aeotec Z-Stick Gen 5
  • openjdk version “1.8.0_222”
  • OpenJDK Runtime Environment (Zulu8.40.0.178-CA-linux_aarch32hf) (build 1.8.0_222-b178)
  • OpenJDK Client VM (Zulu8.40.0.178-CA-linux_aarch32hf) (build 25.222-b178, mixed mode, Evaluation)

Made my SD card with Etcher
Put it in yhe pi and wait for about dinnertime
Than i followed the further instructions on https://www.youtube.com/watch?v=5R9Oc8xINGU (BK Hobby)

I hope someone can help me out, because the old version of the qubino dimmers are not longer available.

Are you using an SD card in the Pi? If so maybe it’s corrupted so if you have a new card try using it to install OH. Also what binding are you using?

Hi H102,

Thanks fot your reply.
I am binding with an Aeotec Z-Stick Generation 5.
It is a new sd card.
(Samsung 32G)
Domoticz crashed because my own fault by removing things from the Raspbian OS

Here’s the list of supported Qubino devices:

You can reach out to @chris or @sihui for more info on adding your device.

Please provide the xml file from your userdata zwave folder:

Disregard. There seem to be some parts missing in the github repo, we need to ping Chris.

@chris, this device looks okay in the database but the configuration parameters (and probably more) are missing on github:


1 Like

Thanks @sihui

1 Like

But i can’t imagine that i am the only one to have this problem.

It is quite possible that in the stable release you are using the database export did not work.
Other users may use an older or newer zwave binding version where the database export went well.

1 Like

True me too :grinning:. Glad @sihui found it this time


I read something about three different Java platforms.
Zulu would be the recommended one.
Do you know why OpenJDK is installed on my system? I thought Openhabian was especialy for Openhab -noobs like me…
(btw, i realy would like to get it work with my Google home devices. so maybe using an other java platform would be better)

What does java -version give you?

java -version
openjdk version "1.8.0_242"
OpenJDK Runtime Environment (Zulu (build 1.8.0_242-b20)
OpenJDK 64-Bit Server VM (Zulu (build 25.242-b20, mixed mode)

Works great, follow the docs:

All Zulu Community builds of OpenJDK are free to download and use without restrictions.

(Shame on me)

It looks ok to me. Based on the thing ID, the link you’ve provided is not the same for the database and github. The database has a name of minidimmer which means this is the correct thin definition -:

Upps, sorry :innocent:

1 Like

Hmm to bad so it stays unresolved why this device isn’t showing options voor config params and association groups in openhab (ZMNHHD Qubino Mini Dimmer missing association groups,channels , configuration options but works).

I tried to add/remove (also on controller itself ) a few times but the result is always the same.
Device is recognized but no options available to configure it (in habmin of paperui) .

Sorry if I’ve missed it, but have you provided information on your device? Either the XML file, or at least the parameters showing the device type, id and version?


So the issue is caused by there being two devices in the database with the same IDs -:

This can happen when the database gets updated, and is fixed when I do a complete database export (which I only do a few times a year - normally a month or two before a major release). In this case, a new device was added (1188) which was then deleted, but it still exists in GH.

I’ve now deleted this in GH and it should resolve this issue in the next update.