Qubino Shutter ZMNHCD configuration

Tags: #<Tag:0x00007faee5cf2510> #<Tag:0x00007faee5cf23d0> #<Tag:0x00007faee5cf2268>

Dear reader

In the following lines I describe the steps to go through to achieve a working rollershutter configuration with Qubino (Goap) Flush Shutter devices in.

Definition:
Shutter mode - Shutter is either UP or DOWN
Venention blinds - Shutter is UP / Down or partially down with lamellas tilt or not

If you have no lammellas but would like to control the position of the shutter, you will also need venetian blind mode. This is due to the fact, that percentage in shutter mode is only reported for 0 or 100%. At least to current knowledge.

Starting:
The configuration of venetian blind mode is the most complex and needs time. If you have already included the ZMNHCDx device into openHAB you read the description part.

ZMNHCD1_Inclusion

It sounds easy but it might result in head scratching. During my experience with OH 2.5.0 Milestone build it was not possible in all cases to exclude the choosen device correctly or include it again.

With the basic device recognition and default configuration, as it comes from the salespoint you would find a node xml file as follows.
network_df4ec3d7__node_6.xml (16.0 KB)
You can search through the file and will not find <endpointId>2<endpointId>in it.

This endpointId 2 is needed to get venetian blinds (lamellas) working correctly. So follow the steps from the description, but I would suggest to copy the original node file away before start. Keep in mind that, after the new inclusion the device gets a new NODE ID.

After successful 2nd inclusion the node file looks as follows:
network_df4ec3d7__node_10.xml (26.5 KB)

You immediately realize here that the file size is different. And when you search through the file you will luckily find endpointId 2 present.

Continuing with Item definition:

shutter.items :

Rollershutter SLR_shutter   "Sleeping Room Shutter [%d %%]"             (TopFloor) { channel="zwave:device:2f18a74d:node12:blinds_control"}
Rollershutter CSR1_shutter  "Children Sleeping Room Shutter1 [%d %%]"   (UpperFloor) { channel="zwave:device:2f18a74d:node11:blinds_control" }
Rollershutter CSR2_shutter  "Children Sleeping Room Shutter2 [%d %%]"   (UpperFloor) { channel="zwave:device:2f18a74d:node10:blinds_control" }

The %d delivers back the percentage value from the device. As you can see in the following picture.

home.sitemap excerpt:

	Frame label="Shutters" {
		Default item=SLR_shutter
		Default item=CSR1_shutter
		Default item=CSR2_shutter
	}

BasicUI:

Also the Icons in BasicUI reflect the position by percentage more ore less accurate.
With this the principal setup is completed.

Slats angle control:
In order to control the slats one needs to add a separate item into the items config and the sitemap.
As you already can see the screen looks different from the one i posted above.
note: The bitmap used for the slats is not common, but created by myself.


I’ll take only the first one in the picture to document the config details.

Items:
Dimmer SLR_sh_slats "Blendenwickel [%d %%]" <slats> (SlatsWS,TopFloor) { channel="zwave:device:2f18a74d:node12:blinds_control2" }

The slats angle is controlled through endpointId2. But OH does not tell you what entpoindId2 effectively is. So after some trials and support from Goap guys I managed to identify it as: “blind_control2”. The slats are working as otherwise described in the way as dimmer does, this is why you add a dimmer item in the config for it.

Sitemap:
Slider item=SLR_sh_slats minValue=50 maxValue=100 step=5

When the slats are are open i.e in horizon flat. they report 50% no matter if the percentage is inverted or not. When they are fully closed they are either 0% or 100% depending what setting you prefer. My ones are set to inverted so fully closed would be 100%. That is why I defined minValue and maxValue in that way. The value for step I’ve just set for try.

Conclusion:
It works nice so far. But the reporting back to the controller (especially percentage) is for some reason not always optimal. i.e on the screenshot you see 31% and 50% while they are closed 100% in reality.

I hope this helps others! Anybody who’s interested in and have questions please send me a PM or address me in a public thread.

Stefan

4 Likes

Thank you very much for your detailed explanation. I got my ZMNHCD working thanks to your tutorial (however, I had to do the inclusion/exclusion part several times and ultimately had to resort to using the zensys-tools to get exclusion without resetting the configuration), but still can’t figure out how to correctly do the slats tilting. I’m looking forward to hearing how you managed to get that working.

Welcome Marc

Glad to hear that the first part worked. I’m just updateing the slats control part now.

Cheers
Stefan

Hi Stefan,

thanks a lot for your guide! I stuck at the point where I have to exclude the Qubino without to reset it. Everytime when I exclude the device via HABmin and include it again, it is reset to factory default.
I exclude the device by pushing L1 5 times after disconnecting/connecting it from power supply. But when I understand the manual from Qubino right, you start exclusion AND reset the device by pushing L1 five times.

So can you give me a hint how to exclude it wihou restting it?

Julian

Dear Julian

Welcome back on the forum and thanks for asking.

Yes pushing 5 times will always result in a factory reset as described in Qubino user manual.
You only need 3 times push to exclude (same as include)

Cheers
Stefan

That works perfect, thank you very much!!

You’re welcome! I’m glad to hear it works.

Hey Stefan

First of all, I’m really new to the whole openHAB thing and honestly, I’m also not really into Linux.
So I think you did a really great job with your expenation here, but for me it’s still on a too high level. shame
But nevertheless, I would really like to get this to work on my system.

If it would be possible, could you explain, how I can modify the “node” file?
Another question was about the really amazing interface you use, I’m asking myself how I can get that one. I only had one in the widget folder in PaperUI?

I guess this are really stupid question for someone with a knowlage like you have, but I thought, may you could explain it in a few words?

I really appreciate your time and help.

Kind regards from Switzerland.

So, what happened to your non working manual switches (question from the German forum), @Neophyte?

Dear Marco

What you need to know and understand has nothing to do with Linux.

The “node” files are created by openHAB’s ZWave binding automatically!!
Nothing to be done here!!

The Process is:

  1. Include the device to ZWave network
  2. Configure the parameter through PaperUI or habmin
  3. Exclude the defice from the The Zwave network
  4. Re-include it and it should get a new Node Number **

** Another option is to have separate ZWave controller, that you use just for the config operations above. So after the exclusion of the ZWave config controller you include it to your main controller.

The interface I use is BasicUI in dark mode, which is not really amazing but rather simple.

Marco: No question is stupid. As long as you learn from the answer and improve your knowledge.

Good Morning Gentleman

Thank you for the quick reply! :slight_smile:

@sihui : I solved that one, this was a stupid mistake from my side, just a cable on the wrong spot on the switches :see_no_evil:

@smhaller: Thank you so much for your effort!
The problem was, somehow I was not able to exclude the device anymore. And I think if I delet it, I will lose the configuration anyway. I’m not sure what you mean about the “separate ZWave controller”? I’m using an Aerotec ZWave USB-Stick…

@Neophyte
I have two controllers.
One USB stick from zwave.me which is my main controller
One Razberry board from the same company attached to another computer

So I’ve configured my shutter devices with the second one. i.e. Steps 1 to 3
After that I included it to the main controller (first one), the shutter device keeps its mode (shutter or venetian blind) after exclusion, that’s why it is possible to do so.

Ah I see. Thank you for the explanation.
Then I guess I will also have to get another Z-wave controller.
Do I also need a specific software to include, configure and exclude it then? Could you recommend something?

I have a huge problem with the Qubino Roller Shutter in Openhab.
I connected it and defined everything. If i let the shutter go down, after is full down it shows, the value 0 and the icon for full open. If i let go the shutter full up, it shows the value 100 and the icon full close.
The value is not updated by moving, just after finished or after i stop. pls help.

Hi Roland

If you have 0 instead of 100 and Vice versa. Set the corresponding Item to be inverted (within PaperUI).

In your Setup i assume that the qubinos are Not Set to be venetian blind Mode. ONLY venetian blind mode reports Perlentage while rolling Up or down.

Cheers Stefan

Currently in Spain

Hi Stefan,

Thanks for the fast answer.

Is it possible to do this in the .items file too?

Regards,

Roland

No.
But it is easy to do, just change the checkmark in the blinds_control channel:

grafik