[Reopend] Z-Wave Binding not working + Fibaro Wallplug FGWP102 shows as unknown device


I have bought a Fibaro Wallplug and I’m unable to get it working.
In paper UI I have the following values and it shows unknown device:
zwave_deviceid 4099
zwave_devicetype 1538
zwave_manufacturer 271

What can I do to get it included. I already tried multiple times to exclude and include it again. Waited one night if it gets included after some time but it will stay like this.

Does anyone have any idea what I can do to solve the problem?

I was able to solve the problem by upgrading the z-wave binding to milestone build according the way described in the FAQ.

EDIT: Something is still wrong. The Thing shows the correct device and I can link all items, but they never change values. I’m also not able to switch the plug on or off.

In the Z-Wave Network Monitort in HAB Min the node is not conected to the rest.

Here are the properties of the wallplug:

Does anyone has an idea what is wrong?

EDIT2: I now realized that I don’t get any values from any z-wave device. I have changed the binding back to stable and am still unable to get it working again. Any Ideas how to get z-wave working again?

Here is a debug log from an action

05-May-2019 11:53:02.722 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 5: Command received zwave:device:bf84e623:node5:thermostat_mode --> 1 [DecimalType]
05-May-2019 11:53:02.724 [DEBUG] [tocol.commandclass.ZWaveThermostatModeCommandClass] - NODE 5: setValueMessage 1, modeType empty false
05-May-2019 11:53:02.726 [DEBUG] [tocol.commandclass.ZWaveThermostatModeCommandClass] - NODE 5: Creating new message for application command THERMOSTAT_MODE_SET
05-May-2019 11:53:02.728 [DEBUG] [.openhab.binding.zwave.internal.protocol.ZWaveNode] - NODE 5: SECURITY NOT required on COMMAND_CLASS_THERMOSTAT_MODE
05-May-2019 11:53:02.729 [DEBUG] [.openhab.binding.zwave.internal.protocol.ZWaveNode] - NODE 5: Command Class COMMAND_CLASS_THERMOSTAT_MODE is NOT required to be secured
05-May-2019 11:53:02.731 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - NODE 5: Bump transaction 84 priority from Set to Immediate
05-May-2019 11:53:02.733 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - NODE 5: Adding to device queue
05-May-2019 11:53:02.735 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - NODE 5: Added 84 to queue - size 4
05-May-2019 11:53:02.738 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.
05-May-2019 11:53:02.742 [DEBUG] [nhab.binding.zwave.internal.protocol.SerialMessage] - Assembled message buffer = 01 0A 00 13 05 03 40 01 01 25 0F 8A 
05-May-2019 11:53:02.745 [DEBUG] [g.openhab.binding.zwave.handler.ZWaveSerialHandler] - NODE 5: Sending REQUEST Message = 01 0A 00 13 05 03 40 01 01 25 0F 8A 
05-May-2019 11:53:02.750 [DEBUG] [g.openhab.binding.zwave.handler.ZWaveSerialHandler] - Message SENT
05-May-2019 11:53:02.752 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage started: TID 84: [WAIT_RESPONSE] priority=Immediate, requiresResponse=true, callback: 15
05-May-2019 11:53:02.755 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 5: Polling intialised at 86400 seconds - start in 1500 milliseconds.
05-May-2019 11:53:04.255 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 5: Polling...
05-May-2019 11:53:04.257 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 5: Polling deferred until initialisation complete
05-May-2019 11:53:04.755 [DEBUG] [ocol.ZWaveTransactionManager$ZWaveTransactionTimer] - NODE 5: TID 84: Timeout at state WAIT_RESPONSE. 3 retries remaining.
05-May-2019 11:53:04.763 [DEBUG] [ocol.ZWaveTransactionManager$ZWaveTransactionTimer] - Aborting Transaction!
05-May-2019 11:53:04.764 [DEBUG] [b.binding.zwave.internal.protocol.ZWaveTransaction] - TID 84: Transaction ABORTED
05-May-2019 11:53:04.767 [DEBUG] [nhab.binding.zwave.internal.protocol.SerialMessage] - Assembled message buffer = 01 03 00 16 EA 
05-May-2019 11:53:04.769 [DEBUG] [g.openhab.binding.zwave.handler.ZWaveSerialHandler] - NODE 255: Sending REQUEST Message = 01 03 00 16 EA 
05-May-2019 11:53:04.771 [DEBUG] [g.openhab.binding.zwave.handler.ZWaveSerialHandler] - Message SENT
05-May-2019 11:53:04.774 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 1 out at start. Holdoff false.
05-May-2019 11:53:16.767 [DEBUG] [ocol.ZWaveTransactionManager$ZWaveTransactionTimer] - NODE 5: TID 84: Timeout at state ABORTED. 3 retries remaining.
05-May-2019 11:53:16.769 [DEBUG] [ocol.ZWaveTransactionManager$ZWaveTransactionTimer] - TID 84: Transaction is current transaction, so clearing!!!!!
05-May-2019 11:53:16.770 [DEBUG] [b.binding.zwave.internal.protocol.ZWaveTransaction] - TID 84: Transaction CANCELLED
05-May-2019 11:53:16.772 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 5: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
05-May-2019 11:53:16.775 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - NODE 5: notifyTransactionResponse TID:84 CANCELLED
05-May-2019 11:53:16.782 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.

Her is a full logfile zwave.log (668.0 KB). But I’m unable to find a solution how to fix the problem.

I have updated now to this version of the z-wave binding: https://community.openhab.org/t/openhab-milestone-builds/50359/280

Unfortunatly still nothing works. Does anyone has an idea how to get any version of the binding working again or what I can do to get some information what is going wrong and how to fix it?

Here is a new version of the logfiles of the z-wave binding in debug mode
zwave.log (225.8 KB)


It looks like newer zwave snapshot don’t work with older openHAB2 cores (like the 2.5M1 or even 2.4) because of the massive changes to the core in the last few weeks…
First try to restart the binding through karaf, this did help some users.
Also make sure you have only one binding installed (also through karaf) and next thing is to check all your associations if set correctly to the controller.
Last thing to do: upgrade everything to the latest openHAB2 snapshot, it looks like all the changes have been merged and they may be usable again.

Also take a look into your openhab.log if you can find any of those error messages which were posted the last days in this forum.

Thanks for the answer.
I have tried allready all the steps above except to upgrade the whole system.

Is there a save way to downgrade to the stable binding again? I have deletet the .jar file in addon folder, restartet and installed the stable binding throught paper UI. But it still does not work again.

What is the best way to upgrade to the milestone build and convort back to stable later?

In the openhab.log I only find this error:

2019-05-06 10:12:42.778 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: {}
io.socket.engineio.client.EngineIOException: xhr poll error
	at io.socket.engineio.client.Transport.onError(Transport.java:71) [236:org.openhab.io.openhabcloud:2.4.0]
	at io.socket.engineio.client.transports.PollingXHR.access$100(PollingXHR.java:19) [236:org.openhab.io.openhabcloud:2.4.0]
	at io.socket.engineio.client.transports.PollingXHR$6$1.run(PollingXHR.java:124) [236:org.openhab.io.openhabcloud:2.4.0]
	at io.socket.thread.EventThread$2.run(EventThread.java:80) [236:org.openhab.io.openhabcloud:2.4.0]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
	at java.lang.Thread.run(Thread.java:748) [?:?]
Caused by: java.io.IOException: 400
	at io.socket.engineio.client.transports.PollingXHR$Request$1.run(PollingXHR.java:218) ~[?:?]
	... 1 more

But I think it is not really related to the problem.

If you are on a recent snapshot, try

Are your devices unknown? You need to use a recent zwave snapshot.

If you don’t get anything from the binding, is it active? Check through karaf. Also make sure you only have one zwave binding installed…

Did you try cleaning the cache?

How did you install openHAB? Manually, repo, openHABian???
There are many ways how to do the upgrading and downgrading. For the Milestones you need to switch to the testing repo (if on a repo install), for the stable you need to switch to the stable repo:

You need to provide more information, I can’t list the whole docs section :sunglasses:

Always make sure to have a backup before changing anything: