Request for Database to be updated

I tried to add in a Honeywell T6 Pro Z-Wave Thermostat. When I did I got the following as the suggested label “Z-Wave Node 013 (0039:0011:0008:1.3)” According to the “Informaition” for the thing it states…

  • This device has not been fully discovered by the binding. There are a few possible reasons for this -:
    • The device is not in the database. If the device attributes show that this device has a valid manufacturer ID, device ID and type, then this is likely the case (eg. you see a label like “Z-Wave node 1 (0082:6015:020D::2.0)”). Even if the device appears to be in the database, some manufacturers use multiple sets of references for different regions or versions, and your device references may not be in the database. In either case, the database must be updated and you should raise an issue to get this addressed.
    • The device initialisation is not complete. Once the device is included into the network, the binding must interrogate it to find out what type of device it is. One part of this process is to get the manufacturer information required to identify the device, and until this is done, the device will remain unknown. For mains powered devices, this will occur quickly, however for battery devices the device must be woken up a number of times to allow the discovery phase to complete. This must be performed with the device close to the controller.

So according to this piece of information some database needs to be updated. Where should I direct this issue? I have the controller fairly close to the device, but so far no update to its status. That is no channels are showing up.

The device appears to be in the DB, so it is one of two

  1. as a battery device it takes many wake ups to fully initialize. Was this added with a C wire (powered) or battery?
  2. The DB shows an update on 12-21. When a device in the DB is modified it disappears from the binding until it is approved. This can happen quickly or take a few days depending on the maintainers schedule. What version of OH are you on? It might be missing in OH3.2


Yes, I am on 3.2. Any idea if it has been approved And are new databases only sent out with new versions (that is say 3.4?) Or can I update the dB on my present version?

If you are using the binding that comes with OH3.2, the answer is yes. However, if you uninstall that binding and add a newer one into the addons folder, it will usually work (unless there has been a breaking change). Have you done what I have just suggested before? There is a dependency (openhab-transport-serial) that may have to be added in the karaf console (Installing from the UI takes care of this, but not with an addons zwave jar. The latest binding is here.


I just want to make sure, when I uninstall the binding, will it cause all of the devices tied to my z-wave to be deleted? Or will they just goo to some off-line/uninitialized state that adding back in the binding will fix? I just don’t want to break anything… at least unnecessarily. I’ve now waited a couple of hours and the channels have not updated (it is a battery, not a C-line connection).

No worries about your devices.

I did a little more investigation, and your device was removed 12-18-21 and back by 12-20-21. My recollection is that 3.2 was issued around 12-15, so the device should be there, but it was close. Let’s make sure the battery initiation is not the issue, before messing with an add-on binding.

Do you have five lines on the UI page
Five Lines of configured node

and/or an XML with the node number in the openhab-userdata/zwave folder?

Just waiting will not work (usually), you will need to actively press the wake button per the manual for waking. Go for every ten seconds.

The other more definitive way is to set the binding to Debug (in the karaf console) while pressing the button and then use the log viewer here on the file (it could be big).


So I do have those 5 lines in my UI.
I’m not sure what you mean by press the wake button, I’ve looked through the Honeywell manual and I cannot find this. However if the parameters for the device in the OH UI it does have a “Device Polling” setting, which I set way down (to like 60, but I can also try 10). Would this be equivalent?

I’m starting to have deja vu all over again. It looks like from these posts here and here you will need to use a newer binding. I should have remembered this.

It is not the initialization if you have the 5 lines.


So from these posts it appears that deleting and reinstalling the Z-Wave binding did not work, rather the latest 3.3 binding needs to be picked up and installed. Is that your understanding also?

I don’t understand this comment.

Yes see my second post.


My first comment was just that I tried uninstalling the Z-wave binding and then reinstalling via the UI. via addons–>bindings, then remove. Then install. This did not work. But what you said previously seemed to indicate that this should work.

The solution that worked for me was:

  1. remove the existing z-wave binding via the UI
  2. from the Karaf executed: feature:install openhab-transport-serial
  3. dropped the z-wave snapshot jar file into the add-on folder
  4. waited a minute.

Everything then worked fine.

1 Like

Sorry for any confusion. The only uninstall that needs to be done is using the UI before you add the snapshot binding in the Addons Folder. You don’t want two zwave bindings trying to run (if that is even possible).

Here is my situation

edit: took so long to write this and you have it working in the meantime. Good job

Yeah, a couple of issues now… (sorry for taking so long to write this).

  1. Although all the channels now show up under the Honeywell T6 thing, some of them are not actually working (they did in 3.0.2). Such as the “thermostat mode” which does not go off of Null.
  2. Over all the openhab has now gone unstable. A number of times all of a sudden all of the lights, and thermostat have gone on/off with no rule being executed and no user input (like in the middle of the night). So anyone else using this snapshot, please use it carefully.

With a new thing and new device, a channel will show Null until it gets an update. Thermostat mode will usually only be updated seasonally. I’d suggest doing a “refresh” on the item and see if it populates.

if you are talking about Zwave items, the binding has changed very little in the last couple of years. Here I would try setting the binding to Debug and using the Zwave viewer to see if there are clues. Also there was a post about zwave debugging here.