Setpoint for Heating value not updated in BasicUI?

Hi there,

I’m currently implementing the setpoint feature for our heating.
It seems to work fine, I can set a certain (allowed) temperature range, but the value is not updated in the Basic UI until I reload.

This is one of my items:

Number Heating_Studio_Target_Value "Studio Sollwert [%.1f °C]" <temperature> (Heating) {knx="1/2/12+<1/2/2"}

where 1/2/12 is the address for setting the absolute temperature and 1/2/2 the current target temperature.
The according sitemap looks as follows:

Setpoint item=Heating_Studio_Target_Value step=0.5 minValue=15 maxValue=25

When I click to increase the value, the displayed value remains the same, while the system received updates (openhab console and Basic UI marked in yellow):

I also tried to implement a rule which posts an update to the item (which did not work):

rule "postupdate (WARNING: wrong code)"
  Item Heating_Studio_Target_Value changed

and also added the items address itself as listening address for the item:

Number Heating_Studio_Target_Value "Studio Sollwert [%.1f °C]" <temperature> (Heating) {knx="1/2/12+<1/2/2+1/2/12"}

Edit: The displayed value is correct after a page refresh!

Do you have any further ideas? Thank you very much in advance!


I have the same problem here. It always increase the values without any logic. Also the iOS app have the same behaviour. I have used min=18 and max=24 step=0.5 and then the setpoint set it to 40.

For me, the sitemap element is working fine, but just does not update on click :frowning:

I have a similar problem (or the same). I posted in:

At the moment: I don’t have trouble if I do not define labels and so on for the item definition and for the sitemap definition and restart openhab after modifications.

Most important thing for me was: realizing that somehow openhab2 does not forget “wrong” definitions and reboots of openhab then lead to the correct behaviour. In that sense it works fine for me now, but still not in the basicui in the myopenhab cloud. Still have to reload there to get the correct value.

Which version of OH2 do you use? Beta or latest snapshot?

Have you tried different browser? And have you tried the ClassicUI to see if it works there?

The problem with the BasicUI not refreshing values has existed, but was fixed several months ago. For me, it’s working without problems (I am using the latest snapshot version). The only difference is that I am using a zwave device, not a KNX device. But this shouldn’t make a difference, since the BasicUI is not aware of the device.

In fact, you should not need a rule to get this going. This has to work automatically.

I’m currently using the latest snapshot (openhab2-online [2.0.0~20170101125906]). In case I use the classicUI, the whole page gets reloaded in case I press the button for increasing/decreasing the values.

And with different browser?

Could you please make a try and create a sitemap only with this item? No frames, no groups, just the naked item. And then test if the behavior is still the same?

I know there was a long…really long…discussion in the according github issue regarding this automatic refresh of the BasicUI. And after a lot of tweaking and changing code finally everybody who participated said: Ok, it’s working now.

If you have a reproducible scenario now where it does not work, you have to open a new issue and maybe reference to the old issue.

Using the following scenario works like expected/desired:


Number testnumber


sitemap test label="test" {

  Frame label="test" {
        Setpoint item=testnumber step=0.5 minValue=15 maxValue=25

I can click and the value changes:


After 1st click:

After 2nd click:

And when you expand your testnumber definition? (Group, Label, icon, knx-channel-binding). When does it stop to work?

It stopped after reloading the items definition after adding some information to the item. I just restarted openHAB and it seems to work for both, the test case and the original problem!

It seems that dynamic reloading of the items definition does not work correctly for the setpoint sitemap items, as already mentioned by @fanick . Is there any known bug like this?


I got the same problem with openhab2-offline 2.0.0~b5. No Update of the SetPoint items label. Even in the ClassicUI I didn’t get it working. I use exactly the same item definiton as the thread starter @robin.muellerbady but my sitemap looks like this:

Setpoint item=Temp_SOLL_EG_Buero label="Soll-Temperatur [%.1f]" step=0.1 icon="temperature"

Is there any progress at this issue? For me a show stopper for migration to OH2. :cry:


Did you try to restart openhab?

> sudo systemctl restart openhab2.service

For me, dynamic loading of components does not work, e.g., in case you update your *.sitemap or *.items file, you need to restart openhab again :frowning:

I started OH2 today the first time and it’s still not working (as the days before). :cry:
For me, even after a openhab (re)start the setpoint doesn’t show/get the value.

The “same” problem means: The setpoint gets updated internally, but it is not displayed by the UI. You have to refresh the page to get the new value displayed? Or doesn’t it get changed at all?

Just to make sure it’s an UI related issue and not a technical issue of the device/configuration.

Hi Stefan, I can’t get the value displayed at all! In the events.log I can see the value update from the KNX bus (which looks correct for me). But the setpoint is never updated. Even If I refresh the page.

Can you provide a full example with the sitemap and items definition? What is the minValue and maxValue in your setpoint? I don’t know if it is a mandatory field.

Yeah. item and sitemap-definitions would be nice. Also the part from the events.log and openhab.log during the seconds when you change the setpoint on your (knx-based) thermostat.

This doesn’t seem to be a problem of the UI (like the thread-starter had), but a problem of the binding/the configuration.

Probably it would be the best idea to start a new thread for your issue, just for keeping separate things separate.


I’ve created a new topic:

Coming back to the original topic. I’m observing the same thing. Sometimes - after dynamic reloading of the sitemap - Setpoint items in the UI are not updating anymore. You have to refresh the entire page to get the new value.
A restart of openhab seems to fix the issue.

It also doesn’t happen all the time. Sometimes dynamic sitemap reloading works. Perhaps some kind of race condition?

Happy to provide further debug information if necessary.