[SOLVED] Bticino F454 setup?

  • Platform information:
    • Hardware: Synology 1813+ with 4gb of ram
    • OS: debian docker image
    • Java Runtime Environment: default
    • openHAB version: 2.5.0

I’ve setup Openhab initially in 2.4.0, just upgraded in 2.5.0 without any issues.

I currently have Philips hue (16 lamps), a beamer and an AV configured.

I’m now trying to interface OpenHab with the Bticino F454 bus that control the
Roller Shutter of my flat (+ the lights and other stuff, but I’m mainly interested in the blinds).

My purpose is to be able to trigger the blind closing or opening with google home.

I’ve added this binding :

And configured the services/bticino.cfg file.

# Host and port of the default OpenWeb bticino IF
# OpenWeb gateway IP address / Hostname

# OpenWeb gateway Port (optional, defaults to 20000)

# OpenWebNet gateway password (optional, defaults to 12345)

I’ve checked connectivity using the MyHome configuration software and I’m able to connect and discover the things.

Now the binding configuration part is really cryptic.

I’ve no idea on how to proceed.

I guess, I should add the following in the items folder :

Rollershutter RollUpShutter_1 "Roller-up shutter 1" (Living, RollerUpShutters) {bticino="if=webserver;who=2;what=0;where=46"}
Rollershutter RollUpShutter_2 "Roller-up shutter 2" (Living, RollerUpShutters) {bticino="if=webserver;who=2;what=0;where=47"}

But I’ve no idea the 46 & 47 values come from, or if I should put something else than 0, in the what?
Do I need to setup something on the other files ?

There’s just sample configuration without explanation, what was the physical setup behind and what they want to achieve.

Also, once I’ve edited the configuration.
Should I restart openhab or do something so that it’s taken into account?
Will I see something in the Paper UI about this binding, because currently I don’t see anything.

Any help would be appreciated :slight_smile:

After installing the binding, in PaperUI > Configuration > Bindings it doesn’t show the binding?

Have you checked via the console to see if it’s listed and active?

Nope, it’s not listed.
But as it’s file based configuration, I would have imagined that it requires a full setup to work.

How do I do that?

In the binding, it’s marked as installed :

From command line sudo openhab-cli console enter your password. Then type bundle:list to show all binding and dependencies.

I’m using the docker image, so I guess I must connect to the docker instance first.

Would like to help but I have not tried OH with Docker … yet.:wink:

Instructions found here: https://hub.docker.com/r/openhab/openhab/

docker exec -it openhab bash

then type default password :

Then I’m connected,
I typed
And I can see the following:

218 │ Active │  80 │ 1.14.0                  │ openHAB BTicino
1 Like

That binding is a version 1 … is there a newer version out?

Well, I only see this version when I’m looking for bticino in the bindings section

Just checked and looks like there is no version 2 binding.

Since installing the binding have you restarted OH?

Yes, because i’ve upgraded to 2.5.0 and the basic configuration was already made and correct.

I feel it’s the configuration of the binding that is incomplete, but the documentation is really not enough to understand how to configure a basic setup

I do not use this binding but add the file you have above, watch the logs and experiment a bit. Wish I could help more.:expressionless:

Where can I see the logs of this binding ?

If you have frantail log viewer installed you can use a browser. I’m not sure if you have openhabian-config tool with Docker but you can install frontail from there or maybe via the console.

I gotta start learning more about OH and docker.:upside_down_face:

1 Like

in the OSGi console, I’ve used :


And I got the logs.

I can see :

18:32:49.635 [WARN ] [isciani.connector.MyHomeJavaConnector] - Monitor connection problem. Attempting retry 2.
18:34:47.698 [WARN ] [isciani.connector.MyHomeJavaConnector] - Monitor connection problem. Attempting retry 1.

However, there’s no stacktrace or details about the connection error.
it’s not very helpful :frowning:

Bad coding :

public String readMonitoring() throws InterruptedException {
    String result = null;
    int retry = 0;
    do {
        try {
            result = receiveMonitorOPEN(monitorSk);
        } catch (IOException e) {
            try {
            } catch (IOException e1) {
            logger.warn("Monitor connection problem. Attempting retry {}.", retry);
            try {
            } catch (IOException e1) {
    } while (result == null);

    return result;

You can also set the log level for the binding to DEBUG or TRACE to get more info. Use the console for this.

our responses crossed, but they don’t log the stacktrace in the code.

hi thomas,

long time ago i tried to install this binding and had big problems because it always stopped to work after a short time.

perhaps have a look at this new binding for bticino here:

and here:

sad to say this binding started very well but now is hardly going on. heating has a bug, and cen only works very basic. because of that i had to code a (very dirty) small python programm that monitors the bus and let me be able to listen and send every command direct to the f454.

best stefan

1 Like