[SOLVED] Heatit z-trm2 anyone tried it in OH2?

I couldn’t really tell because all my z-trm2s are v2.6, but what I do know is that:

  • even for v2.6 chris had to add the P-setting as a channel ‘manually’ (not quite sure how he does that)
  • for the one device were I use the P-setting, it is working fine. Also reflects changes done on the device.
  • as for pre 2.6 support: if you read the 2.6 doc carefully (seems to have been pulled from the ThermoFloor WEB site, possible pending their SW Z-Wave certification) it states: P setting is not supported over Z-Wave.
    This could have been the case before, but luckily not the case for v2.6

I think you will be best off register and posting an issue on the Thermo-Floor support portal. (in Norwegian)

Thanks @chris and @OMR for such swift answers!

If indeed my TF016 with v1.8 can’t change the P setting over Z-wave, I guess an option is to upgrade the software, if possible. (As I understand it, I have to get a specific cable and I guess I have to have an electrician also to open the thermostat cover…).

Quite frustrating with a lack of such basic operation on a thermostat.

Do you think that a manual insertion of a new channel in the XML as stated above would be possible? I am new to this, so I am worried that I might damage the unit…

As I said, try the support portal or try a thread that is not z-trm2 related.
AFAIK z-trm2 started out on FW v2.6, it does not support that special update cable as it is OTA update only.
I have checked on the PCB, the contacts are not there.

The previous versions have been around for many years, so try to connect with others using those.

Hello all,

It says this topic is solved, but I don’t see the solution.

How can I change the setpoint for ECO mode?

Parameter 11, or do you need it as a channel?

As a channel.

I haven’t checked if the new HeatIt-termostat behaves differently than the old one, but the 1st gen one behaved more as one would expect when in ECO mode. So that’s all I’ve been using up until now and therefore also what I want to be able to set in my heating schedule.

Hmm ,are you using a mix of 1. gen and 2. gen?

Yes, gen 1 for five which I bought last winter, gen 2 for one that I purchased more recently.

IC, I have 2. gen only and never used ECO mode so far, but I agree. Having a channel for Parameter 11 would be nice.
So what you are saying is that such a channel is in place in the binding/database for 1. gen, but not for 2. gen?
If so, we should ask @chris to add it for 2. gen as well. (It’s the database entry I created Chris).
Here: Heatit ZTRM 2

Hello again. It seems I forgot this thread.

In the gen 2 there is no channel for setpoint for eco mode (which is what I’m using).

@chris : could you add a channel for energy saving setpoint for Heatit Z-TRM 2 Floor thermostat?


Quickest response ever! Thanks.

When will it be available?

I will do a binding update later today/tonight, so it will definitely be available tomorrow morning.

I added and deleted the thing yesterday, but I didn’t see a new channel.

It also looks a little strange in the database (Energy saving is not with the other thermostat_setpoints, byt under configuration):

That’s correct - it’s implemented as a configuration for some reason that only the manufacturer can comment on.

I also did not see a new channel after deleting and re-discovering/adding the thing.

In other words there are still only two channels for config-params (p setting, 12 and display brightness 20).

Should I be able to find a third one for Energy Saving Mode Setpoint after deleting and re-adding the thing?

The database is definitely updated in Github -:

Are you really sure you have the latest version? If so, please tell me the database reference for your device (listed in the properties) so I can be sure we updated the correct entry as there are quite a few for this device now.

I will check as soon as I get home from work.

How do I check whether or not I have the latest version?
Is there another way of obtaining the latest version than to delete the thing and then add the thing again?

Do a list of the bindings that are installed using Karaf.

You need to actually update the binding as well - have you done that? I noted that above you also said -:

You need to update to the latest snapshot first - if you haven’t done this, then you will just get the same definition as you had previously.

1 Like

Haha, yeah, I knew I’d missed one crucial step. I upgraded just now and the channel is there. Thanks!

1 Like