[SOLVED] Heatit z-trm2 anyone tried it in OH2?

Please can someone supply the XML file that the binding creates for this device so I can see what setpoints the device says is supports.

Are you saying that these two setpoints don’t do anything - so even if the device reports that they are supported, they really aren’t?

What does this do? It will work differently to other setpoints so it’s a bit of a shame they used a parameter to do this…

Chris didn’t forget (I think) -:

It seems to be there?

Here …

Frankly I haven’t played around with them, but noticed today that the binding logged an error on startup for the Furnace setpoint:

2018-08-31 19:42:26.823 [WARN ] [.ZWaveThermostatSetpointCommandClass] - Reached max tries to init the setpont Furnace, this will be our last attempt
2018-08-31 20:01:24.071 [WARN ] [.ZWaveThermostatSetpointCommandClass] - Reached max tries to init the setpont Furnace, this will be our last attempt

Ehh, doc says it is the setpoint for the ECO mode, param11. Doc

Well, no channel for it in either PaperUi or Habmin. Psetting is OK.

We should also consider more descriptive names for the 3 temp. sensors on the device:

Number:Temperature HVAC7tempAir (hvac) { channel = “zwave:device:f180343d:node97:sensor_temperature2” }
Number:Temperature HVAC7tempExt (hvac) { channel = “zwave:device:f180343d:node97:sensor_temperature3” }
Number:Temperature HVAC7tempFloor (hvac) { channel = “zwave:device:f180343d:node97:sensor_temperature4” }

In order to avoid a possible red face, I deleted a thermostat and re-added it with the 27.Aug dev binding.
No display brightness channel I’m afraid.

For the COOLING part,
One place in the manual, under Parameter 1 - Value 2 - Description has the following text: “Cool mode (not implemented)”

Still it looks like this part is working.
If you update the Cooling_setpoint (parameter 13) , - Display is updated correctly.
This also work as an item/channel.
If termostat temperature is above your setpoint it turns the relay on, and act opposite of the Heatmode.

In what mode? Cooling mode?
You could use that instead of ECO mode, but then you lose the ability to switch between the two (COmfort/ECO) with the middle-button on the thermostat.

Cooling mode yes. - Can not be used instead of ECO mode as this tries to reach the temperature the “other way”. - If floor/room temperature is lower than the setpoint for cooling mode it wont turn on the relayport. If floor/Room temperature is HIGHER than the setpoint for cooling it tries to turn ON the realyport to reach a lower temperature.
So it works the opposite way than the ECO/HEATING.

I checked github, and it doesn’t appear to be in the XML, but it was definately added to the database 3 weeks ago. I guess it didn’t get re-exported (although the database says it was!).

Then I just don’t understand why we should bother with the Furnace & Cooling set points at all?
At the end of the day, there is only one relay in there, connected to heating elements.

The function is on the device, and it should be up to the user to choose that he can do to it. Why bother removing it then? - And it is working today. (Talking about the cooler)

For the other part, Furnance. My lack of english thought this was for the Ecomode and since it does not seem to be correct it is nothing I need to fix.

If it is easy to add a channel, Ecomode _ Setpoint - that would be great - but nothing I will die for - so I will stop yelling about it from here.

This P setting is confusing me. I have the HeatIt v1.8, but cannot find how to change the P setting (when using the P sensor).

It seems to me that this is only added to the later v2.6, but as this is quite basic functionality I find it hard to believe.

Right now the only way I can manage to change it through OpenHAB is through the configuration parameters in HABmin. But it seems that this is not updated if I manually change it on the thermostat itself.

So my question to this forum - is it true that P setting can’t be changed in v1.8? And if so, is it possible to tweak it to get it done?

I snooped in the config-file of the v2.6, I observed the following under channels - is it possible to manually add this in my current config-file for my version?

      <channel id="config_decimal_param12" typeId="config_decimal">
        <label>P Setting</label>
          <property name="binding:*:DecimalType">CONFIGURATION;parameter=12</property>

The only difference I saw in the config-section was that the parameter name was “config_12_1” in the new version, as opposed to “config_12_2” in my current. Also, there is added a description-element.

Maybe @chris could help with this? :wink:

1.8 seems to have a 2 byte word set for parameter 12, where the other versions this seems to be 1 byte. I’m not sure what it should be - we could see from a logfile, but it’s quite possible this is an error in the database.

Maybe @OMR knows - he seems to be the resident expert on this device :wink: .

I couldn’t really tell because all my z-trm2s are v2.6, but what I do know is that:

  • even for v2.6 chris had to add the P-setting as a channel ‘manually’ (not quite sure how he does that)
  • for the one device were I use the P-setting, it is working fine. Also reflects changes done on the device.
  • as for pre 2.6 support: if you read the 2.6 doc carefully (seems to have been pulled from the ThermoFloor WEB site, possible pending their SW Z-Wave certification) it states: P setting is not supported over Z-Wave.
    This could have been the case before, but luckily not the case for v2.6

I think you will be best off register and posting an issue on the Thermo-Floor support portal. (in Norwegian)

Thanks @chris and @OMR for such swift answers!

If indeed my TF016 with v1.8 can’t change the P setting over Z-wave, I guess an option is to upgrade the software, if possible. (As I understand it, I have to get a specific cable and I guess I have to have an electrician also to open the thermostat cover…).

Quite frustrating with a lack of such basic operation on a thermostat.

Do you think that a manual insertion of a new channel in the XML as stated above would be possible? I am new to this, so I am worried that I might damage the unit…

As I said, try the support portal or try a thread that is not z-trm2 related.
AFAIK z-trm2 started out on FW v2.6, it does not support that special update cable as it is OTA update only.
I have checked on the PCB, the contacts are not there.

The previous versions have been around for many years, so try to connect with others using those.

Hello all,

It says this topic is solved, but I don’t see the solution.

How can I change the setpoint for ECO mode?

Parameter 11, or do you need it as a channel?

As a channel.

I haven’t checked if the new HeatIt-termostat behaves differently than the old one, but the 1st gen one behaved more as one would expect when in ECO mode. So that’s all I’ve been using up until now and therefore also what I want to be able to set in my heating schedule.

Hmm ,are you using a mix of 1. gen and 2. gen?

Yes, gen 1 for five which I bought last winter, gen 2 for one that I purchased more recently.

IC, I have 2. gen only and never used ECO mode so far, but I agree. Having a channel for Parameter 11 would be nice.
So what you are saying is that such a channel is in place in the binding/database for 1. gen, but not for 2. gen?
If so, we should ask @chris to add it for 2. gen as well. (It’s the database entry I created Chris).
Here: Heatit ZTRM 2