[SOLVED] Heatit z-trm2 anyone tried it in OH2?

Should be included - the database was updated at the time I created.

I will test it. Could be a few days though …

Looking good:


1 Like

Looks like thermo-floor is OK with OTA update.
They sent me this file:Z-Therm2_EU_2_11.otz

@chris, time to try a OTA?

Hi Ole

I have the ztrm2 and i talked to heait a couple of days ago, they will publish firmware files soon. You only have the otz file, you need the bootloader also. I bought the sw cable that sells on elektroimportøren. As this was the easiet method to update them. Just take the zwave module out, and plug it into the computer and update firmware & bootloader.

Im thinking of changing gateways. Regarding z-therm2. (I dont have a floor sensor). So i need to the included room sensor in ztherm2 or use P mode. The internal sensor is garbage, and i want to use a multisensor 6 in the same room as ztherm2. Can openhab get data from that sensor and turn ztherm2 on and off based on that from that device? Then i need to set ztherm2 in P mode. Also what does the Parameter 12 do, does it specifiy how long it will be on before turning on, i see you use both value 2 and 5. Just curious what they do.

I was just thinking doing a rule that if temp < 20 degree -> turn on ztherm2. but only if people are home.
if no people are (at work or night mode) then if temp < 18 degrees -> turn on zhterm2. Else turn off

Im not so familiar with openhab so i dont know if they have home/night/away modes or if its easy to setup.

Have you actually done this?
The product manager over at Multireg says that you cannot use that plug with the z-trm2.
I also checked and it seems to be no connectors on the PCB, but there are 6 holes in the black cover.
Read more here.

The P setting for P mode, param12, made a channel by Chris resently in the development version of the z-wave binding, makes the z-trm2 work just as a power-regulator with settings 0-10, where 0 is always off, and 10 always on, and the rest is on/off dutycycles. 5 is 50%on 50%off.
One of my z-trm2 is placed in another room than the actual floor-heating I’m controlling, and I have also put a Multisensor 6 in the actual room and are planning on setting the P setting using a rule reading the Multisensor 6 temperature. I have not started on that rule yet, but it should be quite simple using the expire binding and check the temperature every 2-3 hrs or so.

Now the reason I want to use the P mode instead of direct on/off control, is that if OH goes down for some reason, the floor heating will not be stuck on ON, as that will turn my basement into a sauna :slight_smile:

As for your question of direct association between the z-trm2 and the ms6, I simply don’t know. Haven’t played with any kind of associations other than Lifeline.

No i havnt actually just read on “hjemmeautomasjon.no” that people did this trough homeseer or z-way with the provided .otz file you also had, but they have problems because the bootloader wasnt updated. If this is true i need to cancel my order to elektroimportøren.

Maybe i misread and people did the fw update on the old z-trm1. Will check and call heatit on monday

Sorry about that

Don’t be sorry, be proud :slight_smile:

I too have had a support case with Thermo-floor, and they say they will provide all info on heatit.com when ready.
As I understand it, it will involve som PC software using a spare Z-Wave stick. This is also how Aeotec is doing it. I also heard that the 2.9 version was flaky. 2.11 I don’t know anything about, but I think they’re having certification issues. In the mean time, I’m quite happy with 2.6 that I’m currently on.

Hehe ok im proud.

Well i was going to pick up an aeotec z-stick tomorrow to start testing openHAB, since i want to leave Futurehome since i want something a bit more advanced. Got lots to learn, really like FH’s states of home, away, sleep so hopefully i can recreate it inside openHAB. And if that z-stick is all i need to update ztherm2 then i guess i can spend the money saved from cancelling the sw cable on a rpi :smiley:

I also heard that 2.9 was flaky, heating didnt turn off etc. And yes i also heard they will be uploading documents and files when they are ready, which was soon™. Heatit doesnt have the best track record to deliver on time, but lets hope they do this time.

Lastly, I dont have a actual reason to update, i mean they work fine, but you know, great to have the latest. I know some Homeseer folks had better association after updating with just the 2.11 otz file. So theres that. Guess we’ll just have to wait and see

OK, I would recommend installing the 2.4.0 snapshot and the Z-Wave development binding. A dedicated HW platform running Ubuntu is also not wrong. I went with a small Asus PC with a x86 architecture CPU.

cool, ill start tomorrow, testing with my PC the next week, and then decide if its something for me and what hardware i want run it on :slight_smile: thanks


Just installed a few Heatit z-trm2. Using snapshot, 2.4.0.
I am not able to adjust the ECO Setpoint. Heat and Cool setpoint works. Others with the same?, or is it a firmware, binding issue?

Number heatit1setPoint  "Set Temp [%.1f C]" <temperature> (GF_Living,hvac)                { channel = "zwave:device:bbc11ae4:node9:thermostat_setpoint_heating" }
Number heatit1FurnancesetPoint  "Set Temp [%.1f C]" <temperature> (GF_Living,hvac)        { channel = "zwave:device:bbc11ae4:node9:thermostat_setpoint_furnace" }
Number heatit1CoolSetPoint  "Set Temp [%.1f C]" <temperature> (GF_Living,hvac)            { channel = "zwave:device:bbc11ae4:node9:thermostat_setpoint_cooling" }

sitemap myHeat label="myHeat" {

    Frame label="Demo" {
       Setpoint item=heatit1CoolSetPoint label="LivingRoom  Cool[%.1f C]" minValue=15.0 maxValue=30 step=0.5       
       Setpoint item=heatit1setPoint label="LivingRoom [%.1f C]" minValue=15.0 maxValue=30 step=0.5	
       Setpoint item=heatit1FurnancesetPoint label="LivingRoom  ECO[%.1f C]" minValue=15.0 maxValue=30 step=0.5	

       Switch item=heatit1Mode label="Heat Mode" mappings=[0="Off", 1="Normal",2="cooling", 11="ECO"]
       Text item=heatit1Mode      

I don’t think that is made a channel.
You can set it in Device Configuration, and turn it on/off via the Thermostat mode channel.

If you really want to control this, @chris can make it a channel in the binding.
He did that for Psetting param12.

1 Like

Hum, I thought the "channel = “zwave:device:bbc11ae4:node9:thermostat_setpoint_furnace”
was for setting the ECO - setpoint.

The, channel = “zwave:device:bbc11ae4:node9:thermostat_setpoint_heating” } and channel = “zwave:device:bbc11ae4:node9:thermostat_setpoint_cooling” is working as expected.

Any ideas that the Furnance is used for?

1 Like

The z-trm2 Doc says that Cooling is not supported.
I just unlink the Furnace and Cooling setpoints and forget about them.

The strange thing is that setpoints for cooling is actually working. If you set any temperature there, and changes the Mode to Cooling, the Setvalue is shown in the display. - I know Cooling is described in the manual “Not Implemented”, but it will be in a later firmware. It seams to work today. It turns on the Relay to power a cooler if that is installed instead of “heating”.

ECO-mode is supported on the device itself,. For me it looks like the “:thermostat_setpoint_furnace” " is here for the eco-setpoint, and something is not working while posting to this channel, or wrong labels?

I can “rule” this “eco-mode” away if I don’t want to use the eco mode. But I want to use it to build logic around then a user (wife) manualy choose the eco-mode on the device and sets a new eco-temperature there.

Turned logging to debug.

Here is what happens then setpoint is correct on HeatingModesetpoint (CO)

[ssage.ApplicationCommandMessageClass] - NODE 9: Incoming command class THERMOSTAT_SETPOINT
[.ZWaveThermostatSetpointCommandClass] - NODE 9: Received Thermostat Setpoint Request
[.ZWaveThermostatSetpointCommandClass] - NODE 9: Thermostat Setpoint report Scale = 0
[.ZWaveThermostatSetpointCommandClass] - NODE 9: Thermostat Setpoint Value = 15.5
[.ZWaveThermostatSetpointCommandClass] - NODE 9: Thermostat Setpoint Report, Type Heating (1), value = 15.5
[ve.internal.protocol.ZWaveController] - Notifying event listeners: ZWaveThermostatSetpointValueEvent.

Here is debug for the Eco-Setpoint,
As you see instead of the “15.5” value is sent - it uses : 0E+1

[ssage.ApplicationCommandMessageClass] - NODE 9: Incoming command class THERMOSTAT_SETPOINT
[.ZWaveThermostatSetpointCommandClass] - NODE 9: Received Thermostat Setpoint Request
[.ZWaveThermostatSetpointCommandClass] - NODE 9: Thermostat Setpoint report Scale = 0
[.ZWaveThermostatSetpointCommandClass] - NODE 9: Thermostat Setpoint Value = 0E+1
[.ZWaveThermostatSetpointCommandClass] - NODE 9: Unknown Setpoint Type = 0, ignoring report.

Any ways to update this to the binding?

Cooling Setpoint aka param13 is not the same as param11 the Powersaving ECO setpoint.

Not sure that you say here, or responds to - but agree that param 11 and 13 is not the same and changes two different things.

Trying to understand it, I thought that params is “mapped” to channels in the z-wave database. Is there a way to change or update this Endpoint - furnance to Economy ?

 <channel id="thermostat_setpoint_furnace" typeId="thermostat_setpoint">
        <label>Setpoint (furnace)</label>
          <property name="binding:*:DecimalType">THERMOSTAT_SETPOINT;type=FURNACE</property>

@chris will have to compile that into the binding, just as he did for parm12, Psetting.

I would suggest removing the Furnace & Cooling setpoints and introduce an ECO setpoint->param11
Yes, and the display brightness Chris forgot the last time around :slight_smile: X

1 Like