[SOLVED] Home Energy Meter HEM G3 AEON Labs GEN5 ZW095 do not report automatically

EDIT: The below is incorrect - it was the way that I had configured grafana to display the data which caused it to fill null values with previous data. Sorry!

Hi all,
So firstly, the reporting is now working but it has confused the hell out of me.

Here’s what I don’t understand:
I’m watching the openhab debug log via karaf (openhab-cli console -> log:tail (running under “error” mode)) and from here I can see various item values coming into openhab and I can what devices are checking in and how often. An example is below showing some HEM values with some snmp traffic, etc.

2018-09-19 22:29:06.551 [vent.ItemStateChangedEvent] - zwave_device_c7937d7e_node11_meter_kwh changed from 5.402 to 5.42
2018-09-19 22:29:06.599 [vent.ItemStateChangedEvent] - zwave_device_c7937d7e_node11_meter_voltage changed from 232.099 to 230.871
2018-09-19 22:29:06.644 [vent.ItemStateChangedEvent] - zwave_device_c7937d7e_node11_meter_current1 changed from 0.775 to 0.79
2018-09-19 22:29:06.645 [vent.ItemStateChangedEvent] - HEM_current1 changed from 0.775 to 0.79
2018-09-19 22:29:06.692 [vent.ItemStateChangedEvent] - zwave_device_c7937d7e_node11_meter_watts1 changed from 85.576 to 85.792
2018-09-19 22:29:06.693 [vent.ItemStateChangedEvent] - HEM_watts1 changed from 85.576 to 85.792
2018-09-19 22:29:06.735 [vent.ItemStateChangedEvent] - zwave_device_c7937d7e_node11_meter_kwh1 changed from 5.402 to 5.42
2018-09-19 22:29:06.736 [vent.ItemStateChangedEvent] - HEM_kwh1 changed from 5.402 to 5.42
2018-09-19 22:29:06.780 [vent.ItemStateChangedEvent] - zwave_device_c7937d7e_node11_meter_voltage1 changed from 232.099 to 230.871
2018-09-19 22:29:06.781 [vent.ItemStateChangedEvent] - HEM_voltage1 changed from 232.099 to 230.871
2018-09-19 22:29:30.529 [vent.ItemStateChangedEvent] - snmp_pfsense_lan_ifInOctets changed from 2218749951 to 2219227125
2018-09-19 22:29:30.535 [vent.ItemStateChangedEvent] - snmp_pfsense_wan_ifInOctets changed from 3395994461 to 3396028384
2018-09-19 22:29:30.540 [vent.ItemStateChangedEvent] - snmp_pfsense_lan_ifOutOctets changed from 4105562541 to 4105807751
2018-09-19 22:29:30.543 [vent.ItemStateChangedEvent] - snmp_pfsense_wan_ifOutOctets changed from 3395994461 to 3396028384

As of earlier this evening, I noticed that I started to get 60-second based updates in my Grafana tables, these had been 10 min updates before this. So I was initially delighted, but then I looked back at the karaf console to see why I missed the 60-second updates from the HEM - but I don’t see any updates at 60-second intervals!

I was under the impression that all changes to all things were verbosely printed to the log, but is this not correct?
If not, other than looking at the individual tables in influxdb, where should I be seeing the incoming data at an item level?

Let me know if this isn’t clear.

You are seeing all of the item changes and updates. You’ll also find them in the events.log file.

Scott, sorry you are correct. I had setup grafana to “fill (previous)” and it made it look like it had received data points where it had not.
I continue my search for a fix to the lack of updates from the HEM.

Any news on that?

I am trying to get reporting working as well (EU 3 phase, 3 Sensor version) using
openhab 2.4 and the latest zwave binding.
I can get polled reports every 10 minutes with valid data but do no get automatic reports.

If I set the association group, settings for group 2 or 3 do not get stored. Settings for group 1 are stored.

What is the right way to set this up?

  1. set the report groups, e.g. 101 = 592128
  2. set interval for group 1, e.g. 111: 25
  3. set association: only main controller ticked?
    [4) set automatic reporting on power threshold ]

I think that 4 is optional, setting 1-3 should give me a (non polled) report every 25s, right?

I did not push the button on the device to store the config (?) yet. This is not mentioned in any manual
I could find. Is that really the key to get this working?

looks like I’m straggling with same problem (though I wonder how you Simon got to 10minute reports … I am getting only every 30min automatic reports).
Upgraded HEM fw to latest 1.4 version (from 2018-jan), but did not help.
Association group 1 appears to be pre-set to the Controller node, but can not change anything for G2 and G3.

Or are we hijacking a solved thread and shall open new/our own one? :slight_smile:

@fishpepper I just got it working following the steps that Aeon support engineer suggestes.

Through Zensys tools (the same that’s used when doing firmware upgrade for aeon devices) … go to Command Class tab, select

and set NodeID to 01 for all three Grouping identifiers (01,02,03).

Working like a charm. Can get 1second updates or whatever you want. Amazing! :slight_smile:


@Austris_V thank you very much. Your hints helped me to set up my home energy meter gen 5 with the zensys tools. Thus now I get unsolicited updates.

This did not work with either HABmin or PaperUI. I have tried exclusion, re-inclusion, various combinations of the settings.

You need to click on “Node info” inside the Z-Wave Controller software to be able to access the command classes, including COMMAND_CLASS_ASSOCIATION_V1. After that it is possible to send commands changing the association groups.

1 Like

This is marked fixed, but since I got here via a google search, I’ll add my 2 cents: after associating with the controller I was getting only wattage updates every 5 seconds. I read the “extended” manual at https://doc.eedomus.com/files/Instructions%20-%20Aeon%20Labs%20Home%20Energy%20Meter%20Gen5.pdf which is more detailed than what came in the box with the device. Under “Advanced functions” it talks about the values to set the reporting flags to. I wanted the kWh, current, voltage, and wattage from the whole HEM and I don’t care about values off the individual clamps, so I want a value of 1+2+4+8 = 15.

Using Habmin, I put that value in “101: Report Group 1” and also changed “111: Interval to send out reports of group 1” to 5 (which is measured in seconds). Now I’m getting kWh, current, voltage, and watts reported every 5 seconds.


Hi, can you send me too document from aeotec guy? Thanks.

Hi, I have tried to send these commands without success. The screendumo is cropped so I am not sure if I set the values correctly. I have not figured out how to pass multiple grouping identifiers in the same association_set command. Or am I supposed to sent the command once per group (1-3)?

Currently when I reboot my Raspberry and look ant the HEM thing I only see a. X icon in association group 1. Groups 2-3 remain empty. I only get values when it polls every 10 minute…

Hello everyone,
I am facing the same issue and going to test the “zensys” tools once I find them.
However my workaround right now is to send refresh to one of the items and all will refresh

rule "rulename"
    Time cron "0 0/1 * 1/1 * ? *"
    sendCommand(HomeEnergyMeter_ElectricMeterWatts, "REFRESH")

Hope it helps


Many thanks! This was important.

And OMG, what a journey to configure this fucking device.

Zwave is horrible from an usability perspective… even if so powerful.

Thanks anyway


No, it is not zwave in general, it is specific to this device:

Please don’t blame zwave if the Aetoec engineers have to be blamed.

I’m having the same problem. May I have fron you the documentation to configure the HEM with ZENSYS tools?

Thanks in advance.

This is unlikely to work since the binding will reconfigure the associations.

Please use the latest binding if you aren’t already. If you still have problems, then provide a debug log showing what is happening when associations are configured.

This was the only way I could get the GEN5 HEM to submit reports. I actually edited ‘COMMAND_CLASS_ASSOCIATION_V1’ and ‘COMMAND_CLASS_ASSOCIATION_V2’ and it seemed editing V2 was what finally got the Node1<–>Node(my HEM) to show/stick.

I had tried everything recommended in any posts on the topic e.g. in no particular order (because none of this worked anyways but I was systematic at the time): remove from openhab, exclude from zstick, add through paperui, add through habmin, edit associations through habmin, reset device using manufacturer procedure, moved the zstick directly next to the HEM, and so on. I could not get the associations to stick at all. Polling the device showed it was functioning and taking good readings.

Part of my trouble was we have just moved and I could not locate the power adapter for my windows laptop to use Zensys. I struggled with this for too long. As soon as I found the adapter and made the link in Zensys I was good to go.

Very happy with the device and the capabilities Openhab gives over smartthings for the data the HEM provides. Thanks for your post, @Austris_V.

Thanks for your comment. I’m using OH 2.4.

Is this what you call “the latest binding”?

If not, can you please tell me how to get the jar file for the latest binding? I’ve looked for it but I have not seen where to get it from.

Thanks Cris.

No - 2.4 is 6 months old now. I’d suggest to use 2.5, but at the moment there are a lot of changes ongoing in the overall system, so I’m not sure you will be able to simply take the latest binding and run it in an older system.

The latest binding is always available here -:


Hello @chris,
I have buy an Home Energy Meter and I have upgrade my openhab at version 2.5M2. The system can read the data from this devices but only if I add the rule with refresh…It is normal this works mode? I expect the device to send data every time set up to 111 parameter (in my case 5 seconds).
Best regards

There are several in the database, you need to tell us which one or we can’t help: