[SOLVED] Inovelli LZW42 zwave RGB bulb

Hi OH Community,

I’ve installed a new LZW42 zwave bulb running today’s zwave binding snapshot. The dimmer and white color channel work great, but when trying to change the RGB setting on the bulb from the color picker in the sitemap, the logs show:

 [WARN ] [nternal.converter.ZWaveColorConverter] - NODE 46: Unknown color mode null.

Based on some forum hunting, this seems to indicate the Color Control channel is missing “colorMode=RGB” from the configuration (noted here and here)

Following the solutions from those threads, I worked with @Chris to get access the DB and updated the item to add “colorMode=RGB” to the channel config. However, even after the fix, updating to the latest snapshot, reloading the binding, and clearing the cache, the same error message is popping up and I still can’t change colors on the bulb. I even edited my own local copy of the xml file and rolled my own jar to ensure to change was applied, but no luck. Am I missing something else that needs to be changed in the device DB?

Any suggestions? Thanks!

DB page: https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1165

Light Description: https://products.z-wavealliance.org/products/3613

Light Manual + Specs: https://products.z-wavealliance.org/ProductManual/File?folder=&filename=product_documents/3613/LZW42%20Manual.pdf

The database change was merged into the binding 9 hours ago, the latest snapshot was created about 9 hours ago.
Maybe the changes are not yet in the snapshot binding.
I would try again tomorrow (or extract the binding files and check the xml files if the change is there)

Don’t forget to delete the Thing and readd it.

LOL. that was it! Thanks!

Can’t believe I missed that LAST step…