[SOLVED] My.OpenHAB OffLine

Hi, I’ve installed openhab on rasping with apt, and configured the persistence following the instruction in the wiki.
but when I go to mymy.openhab.org panel I see the “offline” tag in the menù.

I have opened the 8080 port on the router forwarded to the local IP of the RPI2.



I tryed:

The reply is:
“openHAB is offline”

Wrong way, no need to open ports on your router!

Read here regarding security settings for my.openhab.org.

I set the security params but the result is the same:
“openHAB is offline”

in openhab.cfg:


In the openhab.log have only that for the persistence:

[INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'my.openhab.persist'

@sihui l Do you have a sample configuration that works?

How can I start openhab in more detailed debug mode with the apt packages?

I have set OpenHab in debug mode and I found that he search for myopenhab.persistence file and mine is named my.openhab.persistence so I renamed the file, but I didn’t solve the problem.

In the log I see that message:

2015-10-06 18:27:33.697 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl] - store(zPlug_1_Power), state = 0
2015-10-06 18:27:33.703 [DEBUG] [.myopenhab.internal.MyOHClient] - No connection, Item update is not sent

So the add ons try to sent to the service some information but the connection. Can you help me? There is some problem in my network connection? how to Debug?

@sihui I have controlled the configuration end the uuid / secret in the account and on the static folder of openhab and is the same.

Sorry, didn’t see your edits, post wasn’t flagged as “new” …

Sure, but it is almost the same than you have:


And the file is named myopenhab.persist, NOT myopenhab.persistence.

Sorry, no idea …

Edit: Are you sure your router is in the 192.168.254.x range? Maybe you changed it to that, because I have never seen a default IP adress in that range …

The IP is right because some years ago I have some VPN and I set an IP with that class to prevent conflicts :stuck_out_tongue:

The file is renamed correctly .persist :smile:

Mmm I try to set the lan with the new IP for my last chance. I will update you ass soon as possible.



@sihui sorry no success… :frowning:

I think that was securely network problem, so i write a mail to my@openhab.org to obtain support :confused:

1 Like

could you please scan through your openhab.log and try to find something about myopenhab … you should find information about creating connections and stuff. In case you don’t find anything please restart openHAB with debug logging (use start_debug.xxx)

The fact you openHAB is offline means that it can’t connect to my.openHAB cloud. The most probable problem is that you’ve set wrong UUID and Secret in your my.openHAB account - double check it.
Also, as @teichsta mentioned, please check your openHAB logs in debug mode - there should be some information on what’s the problem is.

Hi @teichsta and hi @belovictor
I doubled checked the uuid and the secret and is right on both platform, I try to disable all the binding and left only the my.openhab persistence to analyze the specific logs.


Ok, will wait for your logs then

@belovictor @teichsta thi si the log with Debug Enabled:

17:38:19.670 [DEBUG] [.m.i.MyOpenHABServiceActivator:28   ] - MyOpenHAB service has been started.
17:38:19.705 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:284  ] - setEventPublisher
17:38:19.712 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:119  ] - my.openHAB service activated
17:38:19.819 [DEBUG] [.p.internal.PersistenceManager:147  ] - Initializing myopenhab persistence service.
17:38:20.092 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:102  ] - config is null
17:38:20.101 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:160  ] - UUID file found at '/usr/share/openhab/webapps/static/uuid' with content '...............................'
17:38:20.109 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:212  ] - Secret file already exists at '/usr/share/openhab/webapps/static/secret' with content '...............................'
17:38:20.114 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:104  ] - UUID = ..............................., secret = ...............................
17:38:20.224 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:160  ] - UUID file found at '/usr/share/openhab/webapps/static/uuid' with content '4ac4ee92-4826-4bc2-86a3-5524127730b2'
17:38:20.231 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:212  ] - Secret file already exists at '/usr/share/openhab/webapps/static/secret' with content 'FWGzN5jNw866655hVmaV'
17:38:20.317 [DEBUG] [o.o.i.m.i.MyOpenHABServiceImpl:146  ] - Version file found at '/usr/share/openhab/webapps/static/version' with content '1.7.1'
17:38:20.676 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:38:20.805 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:38:27.109 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:38:27.126 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:38:30.336 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:38:30.428 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:38:35.006 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:38:35.023 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:38:40.322 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:38:40.339 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:38:45.638 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:38:45.655 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:38:50.975 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:38:50.992 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:38:56.315 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:38:56.332 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:39:01.654 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:39:01.671 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:39:06.978 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:39:06.994 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:39:12.299 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:39:12.316 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:39:17.617 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:39:17.635 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:39:22.982 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:39:23.000 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:39:28.484 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:39:28.501 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:39:33.803 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:39:33.821 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:39:39.118 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:39:39.135 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:39:44.514 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:39:44.531 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:39:49.835 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:39:49.853 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:39:55.151 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:39:55.168 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS
17:40:00.507 [DEBUG] [.myopenhab.internal.MyOHClient:145  ] - Manager.EVENT_TRANSPORT
17:40:00.524 [DEBUG] [.myopenhab.internal.MyOHClient:150  ] - Transport.EVENT_REQUEST_HEADERS  

This is my persist file:

Strategies {
    default = everyChange
Items {
    * : strategy = everyChange

Ok, this looks much like an SSL problem I’ve seen with one of our users.
Can you please describe your setup in details? machine, OS, java version?

Yes of course:

Raspberri PI 2 + Raspian NetInstall (Jessie) + openjdk-8-jre-headless + openhab installed via apt packages

I strongly recommend to replace openjdk with oracle java.

@belovictor ok I purge openjdk and install oracle Java 8

So after that I’ll give you feedback

@belovictor Great is a Java problem! Great!

Thank you very much! I put [SOLVED] in the thread

Might want to edit your post. You forgot to delete all of the uuid and secrets. Look a few lines down from your …