[SOLVED] New UZB dongle, Z-Wave PC controller immediately exits (or crashes) with no error message

Tags: #<Tag:0x00007f6169c69518>

How do you obtain this ZWave PC COntroller software?

I had to create an account, now it says no rights. I thought it was free?

I had the same problems. But you can download it from the link above. See here in post 11.

1 Like

I agree about the account – it wasn’t able to download it from their site either (although others have). I don’t remember exactly where I found it on the web, but I actually posted a direct link to it in post #10, right before the first picture. :slight_smile:

1 Like

Thanks guys

1 Like

Cool stuff ! Nice reminder to create such backups. I own a Z-Stick Gen 5, let’s see if it goes quicker with that.

So doing sound processing is easier? :slight_smile:

1 Like

Ha! Small world :smiley:

For me it is, for sure :slight_smile:

Hey, I have to show you something.

All one click away :stuck_out_tongue_winking_eye:

3 Likes

@dastrix80 @leif

For all who have a Silabs account and like complicated things, follow these steps:

Login to Silabs. Then click on this link.

Or click through: Silabs » Products » Development Tools » Software » Z-Wave » Embedded SDK

  1. Download “Z-wave SDK 6.81”
  2. Accept license agreement in next window
  3. after download (step 1.) --> download “PC Controller 5.30
  4. once you’ve downloaded it you will get a “shared link” to “PC Controller 5.38


5. maybe you have to wait a little while until “SDK 6.81.05 Active” is shown…

5 Likes

Thank you! That is very helpful. How did you manage to find that?
With that I will forgive your snarky comment from before. :slight_smile:

While 5.38 is the current version it can also be downloaded here

1 Like

That was a long journey… :wink: Actually by accident. I was looking for something else on the Silabs site. :grinning:

1 Like

Haha, that’s really amazing :slight_smile: Even an 8200 in there. All sockets controlled by Z-Wave? Any plans for an Omnia 11 or BreakAway One binding in openHAB? :slight_smile:

Just installed it, setup a new ZStick and paired a Aeotec device. All instant! This tool will be very handy. I assume I can just take my production zstick that is causing some grief and try and switch nodes on/off with it that are part of the network.

2 Likes

Actually not Z-Wave! I did buy a large amount (50 or so) Neo CoolCam Z-Wave plugs that I planned to use for this… and then I realized the wiring would be a mess, plus I was still on Fibaro so the UI would have been a mess too. So, instead I did it with web relays! Four 8-channel web relays (of the ZMWEB variety) each in its own custom enclosure with eight 220v power jacks. I was looking for photos from when I built them (or rather, when my housekeeper’s daughter built them, after I built a prototype and then taught her to solder!) but for some reason couldn’t find the pictures.

All my NF-based things (BreakawayOne, Omnia.9) can already easily be controlled from openHAB by HTTP requests :). Not much to gain from a binding, i think?

Nice going! Yes, you can absolutely use your production ZStick with it, that’s exactly what I meant.

1 Like

Dang, looks like I misjudged you. You are helpful.

Here, I put together my Z-Way RPi system again and got the screenshots you were looking for.

I’m not downgrading my stick for you :). But the version I’m running, the latest to my knowledge, is 5.36.

2 Likes

Hey everyone thank you for these tips. I’m BEYOND frustrated with UZB and trying to get it to work with PC Controller.

I had the same issue with the PC Controller crashing when it detected UZB. So I read the topic and decided to try an upgrade the firmware in hopes that it will fix the crash. I soon realized that z-wave.me no longer supports the Windows version and the on the website it outdated and no longer works to update the firmware. So I learnt how to install Lubuntu and downloaded and installed v.3.0.0 of the z-way software. However when I try to upgrade the firmware from Expert -> Network -> Controller Info -> Firmware Update, it shows me that it can update the bootloader from 5.25 to 40196 but then when I try to update it it gives me an error Unable to update data. /ZWave.zway/ZMEBootloaderUpgrade

I was wondering if anyone had any tips on how to update the firmware on the UZB to get it to work with PC Controller or if I can use an older version of the firmware which works with PC Controller.

What does not work with the original firmware?
My UZB is four years old, never been updated, works without any issues.

Same symptoms as the first post from @leif
I start PC Controller, it detects the UBZ and then the program exits (or crashes, no errors, just disappears). My stick appears to be running 5.25

No. I meant what did not work in regards of openHAB.

I wasn’t trying anything with openHAB, just trying to get PC Controller from zwave to work and I came across this topic. Apologize if it’s off product but this is the only reference I could find to the issue while searching for a solution. Anyways I finally solved it and will post an update if it helps anyone with the same situations.

1 Like