[SOLVED] New UZB dongle, Z-Wave PC controller immediately exits (or crashes) with no error message


So, after my successful migration to openHAB with a UZB dongle, and having learned to use the Z-Wave PC Controller (5.38) software for z-wave network maintenance, I thought it would be good to have a backup of the hardware.

So, I ordered another three UZB’s. They arrived yesterday.


So far so good. Next order of business: Backup the NVM of the Primary controller, restore to the Secondary controller, then use the Secondary controller, putting the Primary in a safe place.

Imagine my surprise when Z-Wave PC Controller immediately exits as soon as it talks to the secondary dongle! I tried repeatedly, same problem.

Tried again with the tertiary, same issue. Even tried plugging them in at the same time so that the tertiary got a different com port number… Didn’t help.

All of them use the same UZB driver from the Z-Wave PC controller package.

The Primary one does have a Z-Way license installed which I paid for, tried, and decided it wasn’t worth the time. So, I bought the other three without the Z-Way license. The Z-Wave PC controller app is from Silicon Labs themselves, not z-wave.me, so I can’t imagine that would have anything to do with it, right?

They could also be different revisions. I’m not sure how to check.

Why can’t anything be easy… seriously.

Any suggestions for how to proceed?

Edit: After some googling I found [this](https://forums.homeseer.com/forum/lighting-primary-technology-plug-ins/lighting-primary-technology-discussion/z-wave-homeseer/1296360-please-bring-uzb-restore-back). Apparently the Aeotec "Z-Stick" Gen5 Backup Software is able to backup from, and restore to the UZB. So, I tried it. At first, it looked like it did NOT go well. I saved the EEPROM of the primary UZB, and wrote it back to the secondary UZB. Then unplugged and re-plugged the freshly written UZB. At that point I got the "Unknown USB device or USB device has malfunctioned" popup from windows. I tried three times. Scared the shit out of me. The fourth time it was again detected as a UZB. Really?

Z-Wave PC controller still does not want to anything to do with it, it just exits.
openHAB thinks it’s fine, the z-wave controller is shown as online, and paperUI shows all my Z-Wave devices are online… but NOTHING works. HABmin shows that no devices are actually responding to ping.

The Z-Wave log is full of:

2019-07-02 08:07:17.151 [ERROR] [ing.zwave.handler.ZWaveSerialHandler] - Got I/O exception Input/output error in writeArray during sending. exiting thread.

…and then I discovered that the new device was actually /dev/ttyACM1

And when I changed the Z-Wave binding to use /dev/ttyACM1, it started working.
My secondary UZB stick is now running the network, controlling my lights, and the lights are nonethewiser!!

So, that’s a big success. But, I am still absolutely dependent on the Z-Wave PC Controller app to perform maintenance tasks that the Z-Wave binding cannot yet do. I still need that to run.

The Z-Wave PC Controller app (from silicon labs) still exits immediately as soon as it tries to communicate with the secondary UZB.
It still works fine with the primary UZB, and it also works fine with an Aeotec Gen 5 Z-Stick that I also own.

Any ideas? Anyone? :slight_smile:

I am not sure if I could be of help, but a few weeks ago I thought it would be good to update my Razberry.
I installed Z-way, stopped OH and performed a lot of firmware updates via Z-Way.
Z-Way offers a lot of Z-Wave services but not sure if it can backup and restore settings as this was not my intention.
Maybe you can solve your troubles via Z-Way.

Thanks for taking the time to respond, Chris!

So, probably not. I didn’t have a good impression of Z-Way at all when I bought and tried it several months ago. Being a windows user, I of course downloaded the latest version of Z-Way for Windows, and attempted to apply the license key. It failed, for no apparent reason. I tried repeatedly – it just didn’t work. Tried other computers – still wouldn’t work. Finally I noticed there’s a newer version for Raspberry Pi so I got one of those out of the drawer. Still wouldn’t work! I can’t remember the error but it seemed like the key had already been used.
I ended up having to register on a support forum to ask a question (there were no e-mail addresses to be found) and there I did get help from the author, who reset the key, and then I successfully applied it through 2.3.8 on the raspberry pi. But this means that Z-Way for windows 2.3.3 had just eaten the key I had paid for. It used it without applying it to the dongle!

Just now, I looked at z-wave.me again… and what do you know – 2.3.3 is still the latest version for windows to this day… and not a word of warning on the web site. That’s not good enough. When actual money is charged for it, you need to do better than that.

Hell, the openHAB community is doing way better than that, just out of the goodness of our hearts.

So, I’ve paid for Z-Way once, and I don’t use it regularly so it should be enough… but no, it’s charged per dongle. I don’t particularly feel like paying for it another three times.

The Z-Wave PC controller software from SiLabs, on the other hand, is great! If only it wouldn’t immediately crash on three out of my five dongles.

Hello Leif
I guess the key is necessary only if you want to use their cloud service.
I installed Z-Way without on my RPi, skipping the log on and had seemingly access to all services.

I do not know the behavior of OH on Windows, but have you stopped OH?
I guess it is running as service?
OH captures the stick and your SiLabs tool could crash caused by this.

But I am not familiar with OH on Windows so would be better to wait for help from a Windows user.
I read in your post /dev/tty so I assumed you are on Linux …


If Z-Way is at all useful without a key then I will be happy to try it. I understood the key was needed to do anything at all.

Sorry for the misunderstanding – I am running openHAB on a raspberry pi on linux, and I’m getting more comfortable with linux by the day. I tried Z-Way many months ago, long before I started using openHAB.

The “Z-Wave PC controller” is a windows app, so when I need to do a maintenance operation (like exclude a Z-wave device, which has never worked for me with the binding) then I have to stop OH on the raspberry pi, unplug the dongle from the pi, plug the dongle into my workstation (which runs windows), and then run “Z-Wave PC controller”. It runs perfectly with my first UZB dongle, so I bought three more. It doesn’t work with either of the three new ones.

I never tried to use OH and Z-Way together on the same raspberry pi. Of course I would stop OH first :).

This is home automation. If you wanted easy you picked the wrong hobby. :wink:

Is there anyplace that Z-Wave PC Controller app might be writing out logs?

Can you kick it off from CMD or PowerShell and see if it’s writing out something to standard out before it exits?

Without more information from the app I think we would all be just shooting in the dark.

Watch out for this. I bet you unplugged the USB while openHAB was still running, right? What happens is the Zwave binding gets a lock on the device. When you unplug the USB device the binding retains that lock preventing the file /dev/ttyACM0 from being reclaimed. When you plug it back in it sees that /dev/ttyACM0 is in use so it adds this “new” device as /dev/ttyACM1.

When you reboot your machine, the device will show back up at /dev/ttyACM0.

In the future, either stop openHAB before unplugging it, or restart openHAB before plugging it back in. Or you can just restart the zwave bundle in Karaf. Both will free the lock and the file so the device shows back up in the same place when you plug it back in.

There are tutorials on the forum for creating a symlink for USB serial devices like this so the device will be linked to, for example /dev/zwave no matter which /dev/tty* the physical device shows up on. But I run in Docker and symlinks can’t be mounted into the container so I don’t have experience with this.

Hmmm, if you indeed did stop openHAB, perhaps something else is going on. What ever it is a reboot should clear it.

Do you happen to have any other USB devices plugged in?

1 Like

I’ve asked exactly that in the SiLabs forum. I got one response so far – not a helpful one.

Good thinking wrt console output… no luck, but good thinking nonetheless. I also tried to run it under windbg and saw that it’s throwing a CLR exception, typical of .NET applications but I couldn’t glean any more information than that. It’s definitely crashing, though. Perhaps it’s just a newer, unsupported firmware version in the newer UZB dongles?

The only other USB device is the SSD.

I’m still running my production setup on the primary controller – I don’t have a way of managing the Z-Wave network other than the Z-Wave PC Controller, so I can’t use the secondary controller yet.

LOL! You speak truth!

People talk about home automation being in its infancy, as if it will ever be a mainstream thing. I don’t think there’s a way in hell it can ever be, because most people don’t think like us. The average person simply doesn’t have the ideas like “wouldn’t it be nice to have a single button to turn off all my outside devices when I go inside”… They simply walk around and do it manually, and anything else is unnecessarily complicated and confusing. I think it will be always be a niche thing. Time may prove me wrong.

That said, I wasn’t looking for easy, but it would be nice if it didn’t fight me tooth and nail every. single. step. of the way.

You were right, Chris! Thank you so much.

Z-Way does not require a license key to do a firmware upgrade. After updating to the latest firmware, Z-Wave PC controller runs just fine!

You do not need a Z-Way license to use it to upgrade the firmware of a UZB stick!


Network - Controller Info - Firmware Update.

Enter “all” when asked for “access token”.

Make sure you don’t upgrade to “Bridge” firmware, stick with the normal type!

Posting this for people who find this thread in the future. Good luck! :slight_smile:


Very interesting topic :slight_smile:

I also have an UZB stick. But I thought so far that you can not backup the stick. I was thinking wrong!

Just to be sure and if I understood everything correctly, here are again your steps:

  • You installed an unlicensed Z-Way (2.3.8) on a Linux machine, because only an outdated version (2.3.3) is available for Windows OS.

  • You installed “Z-Wave PC Controller 5.38” on a Windows machine.

  • To copy a NVM backup (NVM = non-volatile memory) from the primary controller to the secondary controller, you did the following:

    • stopp Openhab
    • upgrade all controllers to the latest firmware version with Z-Way.
    • open Z-Way --> http://YourIP:8083/expert
    • –> Network --> Controller Info --> Firmware Update
    • enter “all” when asked for “access token”. Don’t upgrade to “Bridge” firmware.
  • NVM backup with “Z-Wave PC Controller 5.38”.

  • Restore it to the second, third, etc. controller

Now a few questions: Did you save your backup as .zip or .hex?

Did you once try to restore your backup to the same controller again?

If you have only one controller (like me), is it absolutely necessary to update to the latest firmware?
(I could imagine that “backup --> restore” to different controllers with different firmware would fail, so better having two controllers with exactly the same firmware…; So I’d better buy another controller.)

Would you like to post a few screenshots here? Thanks a lot! :slight_smile:

1 Like

You got it exactly right, those are the exact steps.

The backup is HEX inside a ZIP file. It only takes a few seconds and the ZIP is 8 KB. This is very different from Aeotec’s app (see the original post in this thread) which saves a 512 KB BIN file and takes three minutes.

In fact, I was suspicious whether the NVM backup had done anything at all because it happened so quickly… so I restored it to the Tertiary UZB stick, which I had never used with Aeotec’ s app.
That tertiary stick is running my z-wave network now! So, it does work. I’m glad I bought three backups though and not just one.

I never tried restoring the backup to the same controller actually. I can do that, no problem. Will update this post shortly.

Even if you only have one controller, if your controller happens to have a version which the Z-Wave PC Controller application chokes on and crashes, you will definitely need to update. If you are worried about the firmware upgrade, you can do the following:

  • Order a new UZB now (let’s call it secondary)
  • When the secondary it arrives, back up your primary UZB with the Aeotec app
  • Restore backup to the secondary UZB
  • Start openHAB with the secondary UZB and verify that it works

Then you can safely update the primary one with Z-Way because you already have a working backup.
I don’t know of any risk of using the Aeotec app but I have exactly one data point – i used it once and it worked that time.

I will do the back-up/restore and screenshots now, otherwise it will never get done. I wal going to do it on my primary (since the tertiary is running the network) but then I realized it’s probably not good for network health to have two cloned controllers running at the same time!

So I will stop openHAB and then I may as well do it on tertiary, and leave primary alone.

This is the Z-Wave PC controller 5.38 in the unconnected state.
New link 2022: Z-Wave PC controller 5.38

Hit the cog wheel in the top right and hit Refresh. If you don’t see your Z-Wave USB stick, you may need to apply the ZW050x USB VCP PC Driver (part of the zip file) to your Z-Wave USB stick in device manager to have it recognized. If you see the COM port, all you have to do is to highlight it in the list and press OK. Hopefully you’ll see the following screen. You may have to try a couple of times.

This is the Z-Wave PC Controller ready for duty. This is as bare metal as Z-Wave gets for most users. In “Network Management” you can include and exclude devices, turn lights on and off etc, but you better have your node IDs written down because they will not be named in this app.
I’ve used this to exclude failed devices, or even to exclude functioning devices when the Z-Wave binding had trouble doing it for me.

For backing up, what you need is NVM Backup and Restore.

Select the location and the file name and press OK. Remember to hit Backup too!
Also, note that a backup is of no use if you can’t find it when you need it, so e-mail it to yourself, put it in your dropbox, do whatever you usually do with precious digital goods. :slight_smile:

Restoring is done the same way except you pick the file into the restore slot and press restore instead.

When it’s done, it’ll say “NVM Restrore(sic) finished” and just sit there with a sliding progress bar. I waited for a couple of minutes, then I got bored of waiting, closed the app and disconnected the dongle.
That’s about it.

Here is a screen shot of the network management tool for posterity.

THANK YOU to Silicon Labs for releasing such a powerful tool free of charge!


That wouldn’t show up as a /dev/tty* so that can’t be it.

You can take a small consolation in the fact that your posts and struggles are helping the community tremendously and are greatly appreciated!

1 Like


One last question: Which “firmware version” do you use actually? Is 5.32 or 5.37 the latest? See here… (or is it not published on zwave.me site?)

EDIT: Maybe you could also provide such a screenshot (with content :wink: ):

Is it possible to provide your firmware versions (as a file version): e.g. 5.32.zip or .hex

It’s not published on the site. I can’t remember the number at the moment but in Z-Way, on the Firmware Update page, there’s a box labeled “access token”. Enter “all” and you will see all available versions.
Please note that you may have to update more than once to get to the latest version! Make sure you don’t upgrade to “Bridge” firmware, stick with the normal type.


Z-wave.me does not seem to be too specific about their release notes or information or documentation… :rofl:

See also please my (hopefully) last request here.

I can’t provide screenshots of the firmware update process because I didn’t take any, so I don’t have any. I did my firmware updates yesterday, today I’m doing something else :).

But I see the firmware update button right there in your screenshot. What are you having problems with?

I’m not at home (atm), so no controller is connected (and then no updates are shown!). And it’s the “Z-Way on Windows” (=2.3.3) version. I don’t have a Linux system running atm. Before I make all the effort with a completely new Linux installation, I wanted to take a look at everything and try it in theory. Maybe it’s possible to use the “Z-Way Windows version (2.3.3)” and put the missing firmware updates in a specific folder to upload them.

It’s NOT possible to use Z-Way for Windows. It’s out of date, and will probably ruin your stick with impunity. If you don’t have a raspberry pi to run it on, I’d skip updating. Anyway, with a raspberry pi you don’t have to make a completely new windows installation, you just download an SD card image that someone else has already made, like Raspbian. :slight_smile:


@leif Ok. I’ll try either Linux or something very different. I’ll inform you then. Thanks :slight_smile:

I see, it seems to be too difficult to open Z-Way again, and doing steps 1-3?