[SOLVED] OH3 HOMEKIT BUG?: openhab Bridge only discoverable as accessory and 0 items created for HomeKit?

Hi all,

I have an issue with Homekit after migration to OH3, zero items get created in Homekit as well as I can only add the openhab homekit bridge as an accessory not as a bridge.
Migrated from OH2.5 to OH3 , currently running 3.1.0-Snapshot Build 2101

I think proper flushing of homekit.json was done as well as making sure the mac adress is handled properly, hence I am leaning towards a bug in OH? Or did anybody else had this issue lately and I am missing something?


1 Like

@hschulze86 are you referring to my post OH3 MainUI: How to register (and exclude) items for Google Assistant and Amazon Alexa? ? I would be really happy to start investigating this as no one responded so far…

No, like stated above it is about the homekit issue with 0 created items although correctly implemented before but since OH3 migration does not work anymore.

for individual issues open your own thread as reminded a couple of times already on the thread

And do not ever ping people let alone developers. Thank you for following the posting rules

How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

Log shows the following:

==> /var/log/openhab/openhab.log <== 2020-12-27 15:58:10.234 [INFO ] [mekit.internal.HomekitChangeListener] - Created 0 HomeKit items.


I can confirm after hours of troubleshooting with correct MAC adress and multiple deinstall of homekit and flushing of homekit.config as well as homekit.json that the behaviour stays the same: The openhab bridge is in the homekit app an accessory and nothing more.
Also still 0 items created still.

Flushed after deinstall:


Can someone with OH3 please comment if they have running homekit installation?
Running on openhabian 3.1.0-SNAPSHOT - Build #2101

I had the same issue with homekit. The problem was the kind of tag.

instead of [Lighting] use {homekit=“Lighting”}

Thank you, I have read left right and center but did not get this. But does that mean that a normal switch is not supported anymore in homekit from openhab?

Solution in this post. If you used deprecated in your .items files, 0 items will be created in homekit in the logs as well leave the openhab homekit bridge completely unsupported in the app.

Solution is to use { homekit=“Switchable” }

I’ve finally got one working on OH3 3.1 as a trial with a handful of devices. The Home app seems to responsive to the binding. Only issue I have is that whenever I add a device (via Homekit metadata), No new devices show up in the Home app. I have to remove the OH accessory in Home app and add the openhab accessory all over again (after clearpairings and restarting the homekit bundle via console), which is a pain. Hopefully others are having better luck.

I still don’t get where I need to include {homekit=“Lighting”}
Do I include that in lamps.items?

In version 2.5.4 I had in my lamps.items:
Switch office_whitemode "White Mode: Office" {channel="milight:rgbwwled:F0FE6B62C62A:office:3:ledwhitemode"}

I tried to include it in my lamps.items:

Switch office_whitemode "White Mode: Office" {homekit="Lighting"} {channel="milight:rgbwwled:F0FE6B62C62A:office:3:ledwhitemode"}

I tried to create a separate line:
Switch office_whitemode "White Mode: Office" {channel="milight:rgbwwled:F0FE6B62C62A:office:3:ledwhitemode"}

Switch office_whitemode "White Mode: Office" {homekit="Lighting"}

None of it is working… Initially at least it recognized it in HomeKit, but now not even that…

Put those hands together.

Switch office_whitemode "White Mode: Office" {channel="milight:rgbwwled:F0FE6B62C62A:office:3:ledwhitemode", homekit="Lighting"}

Thanks Russ. It still doesn’t work, but I think I have another problem with Links between Things and Items ((unknown) Invalid Link). Somehow I have the feeling that openHAB 3, deals different with Items than 2.5.4 as I copied the code from 2.5.4. to 3.0. But that’s for a different topic/thread.

If you’re using MainUI, then you have to attach the items to the new channels that OH3 has defined for them, which may be different from OH2. If you’re using .things files, then I imagine it would continue to work in OH3.

But how is it done when you use the [“Lighting”] style tags for you semantic model. So can’t you use the tags at all? Since I already had the tags in place for the semantic model, and I’m now adding the homekit=“Lighting” tags, and only OpenHAB itself shows up as an accesory (OH 3.0.2)

If you’re using .items files, peplace the tags with metadata, per the Homekit documentation.

If you’re using the UI to define items, click “metadata” and select “Apply homekit”.

The combination wasn’t the issue with homekit in the end, so you can combine tags and metadata. But be aware that the tags are used for multiple things now, since you can use them to make up the semantic model as well.

I don’t know about Homekit, but tags were deprecated for Google Assistant and recently removed to reduce confusion. I would imagine the same thing eventually happening with Homekit (and Alexa if it hasn’t already been done).