[SOLVED] OpenHAB 2.5 RC 1 Critical Issues

I will but now I’m trying to reproduce the problem on my test system with some meaningful log.

1 Like


1 Like

I didn’t created a new issue because someone already created one.
Added my own logs there:


reported issue in eBUS 2.0 thread


I would have expected the issue to be filed here.

Not sure if this is new “feature” or an unintended consequence of recent changes, but it seems that every time I use PaperUI to add or delete a Thing or Item, an OpenHAB System restart is initiated. This did not seem happen prior to 2.5.0M6. I am running OpenHAB in Docker. Did I miss something along the way?

UPDATE: This issues seems to have resolved. I rolled back to 2.5.0M5, deleted the cache and tmp directories, updated to 2.5.0RC1 and restarted the docker 2 twice. Since doing this I have not noticed any restarts when I add Things or Items using PaperUI. I believe this glitch is real, but was easily resolved at least for now.

I love music and nice sounds, but headteacher’s tone is not for a community of volunteers.

1 Like

I see the same behaviour. I have a TRACE log, but doesn’t see anything suspicious.
It is only subscriptions, publish works fine as somebody alread has written.

If needed I would be happy to test any changes, just give me the jar file :slight_smile:

See the GitHub issue


Who actually decides what is a critical issue?

For me, for example, it is critical if the “nightly zwave heal” does not work. Or if my Philips Hue dimmer and Tap switches events will not work.

They are still NOT SOLVED since 2.5.0.M1 or 2.5.0.M2.

See here:

Z-Wave heal:

Philips Hue (Dimmer and Tap Switches):

Do you seriously want to tell people that a stable release somehow works, but you better should disable the nightly zwave heal. And all your Hue Dimmer Switches and expensive Tap Switches will not work? Well then…

In the documentation, it is promoted or proclaimed that this works, actually since 18th January 2019 (Hue) and since mid-May 2019 (Zwave heal) they do no longer work. Then please change the documentation. Thank you very much.


I am absolutely on Celaeno1 side.

My primary device to control everything in the house are the cheap philips hue dimmer switches. If they are not going to work i won’t be able to migrate to 2.5. However as i am not capable of contributing code to the project. I tried to make clear that i got the same issue on this forum as well as on github.

I can understand the decision of cweitkamp who did the last change in the hue binding and doesn’t use the dimmer switches anymore, as it is his free time that he is contributing to this project.

However my conclusion for this is to move to another meta smart home controller like hass.io or nodered which still supports my hardware as i won’t have any other choice than that.

If there is anything else except for contributing code what i can do i am absolutely willing to pay 50€ to get the support of the dimmer switches back, however i don’t think that this won’t be a acceptable price as the development will take more than half an hour for the contributor.



1 Like

my Philips Hue dimmer and Tap switches events will not work.

Sorry if this is maybe a stupid question, but did anybody ever file a bug report about this?
Looking at https://github.com/openhab/openhab2-addons/issues?utf8=✓&q=is%3Aissue+is%3Aopen+hue+dimmer, I cannot see anything related…

I can understand the decision of cweitkamp who did the last change in the hue binding and doesn’t use the dimmer switches anymore

You mean @cweitkamp broke the code and decided to not fix it, because the feature isn’t relevant for him? From all I know about his work over the past years, I cannot believe this…



Please read this:

I very well appreciate all the work of Christoph. Thanks a lot. :slight_smile: But unfortunately above is true.

One issue is filed here:

Which is unrelated to the hue binding itself and which does not seem to be reproducible…
But there’s no issue entered over all these months about the hue binding?

27 posts were split to a new topic: Handling and responsibilities in bug tracking

The MQTT problem seems to got sorted out by us with the help of @J-N-K. He will also create a PR for it.


Strange, i have this issue since M6 (still existing in RC1), i need to go back to M5 to get mqtt updates again.

MQTT Not working.
Just to help those with this issue it has been opened on github here

and here.

I have reverted back for the moment with

sudo apt install openhab2=2.5.0~M6-1

cleared the cache and restarted.

@David_deMarco Does that mean that the fix is not working for you?

Have not applied the fix as could not find clear info on how to apply it. Happy to apply and test if you can point me in the right direction. Confirm stable on M6 (I’ll update the post above)