[Solved] Openhab 'disappears' after a reboot

i have a very odd problem and don’ t really know where to start solving it.
Had a good working openhabian install
I shut down my openhabian raspberry for some maintenance (used sudo shut down now)
start it up again, all seems OK, I can log into it, Grafana is reachable on port 3000, but openhab does not start, no activity on port 8080 (can’t connect), phone app doesnt show anything.
sudo systemctl start openhab2.service
and / or
sudo systemctl start openhab2
dont solve it.

Hmm, so I download a new openhab image, make a complete fresh install on a new sd card. Great, thats working, let me do a reboot (sudo reboot now)
Same problem, openhab seems to have disappeared, I can ssh to the raspberry, again Grafana is working normally, but no openhab activity, port 8080 ‘can’ t connect’

Ok so I buy a new SD card, same excercise: fresh install, works, I do a reboot, openhab gone.

i do see that after a restart my /etc/openhab2/services/addons.cfg does not contain any bindings or interfaces, but even if I add those manually again, openhab just refuses to start

Anybody any idea what is going on here?

Does sudo systemctl status openhab2.service give any hint?
I’d guess that some config is wrong such as a serial device name, making OH refuse to start.
Check openhab.log. If that does not show edit /var/lib/openhab2/etc/org.ops4j.pax.logging.cfg so you get more output at earlier startup stages.

Markus, Thanks… I didnt know that command.

Anyway I just did a new install again, that for now seems stable.

Big difference with previous problematic installs:
I did not install the WiFiLed binding

perhaps I should try to install that again and see what happens…but I have been at it for several hours already :slight_smile:

That surprises me as previously I had it installed and working, but I do recall that I earlier had some problems with it when I upgraded to 2.3

Anyway… I am a bit careful yet to say that it is ‘solved’ I will see how it holds for now

I think I found the problem, it was not the WiFiLed binding, it was oracle java.
Normally openhabian comes with openjdk java, but as I had some trouble connecting to myopenhab, i installed oracle Java.
in hind sight that is when my problems started. If I set oracle java as default… Openhab will not start after a reboot, if I set the previous openJDK java as default again, the problem seems solved.
I tried your status call when I had a failure, but other than that it said it wouldnt start it didnt give me any clues on why not. There was no clear ‘exit’ code

Now ofcourse I have to find another way to get my ‘myopenhab’ online :slight_smile:
Thank you for your help, eventhough it didnt give me the solution, i learned some extra commands, very useful


Have you tried Azul Zulu 8 java?

yes, that is working now.Apparently it just took a bit longer for myopenhab to kick in

1 Like