[SOLVED] "Plugin execution not covered by lifecycle configuration" errors after clean Eclipse install

I wanted to start by saying I love OpenHAB and have been using it for my home setup for years now. It really came a long way!
I finally got around to start working on my OpenHAB binding. I have had some trouble with Eclipse and dependencies, so I decided to do a fresh Eclipse install as described here: https://www.openhab.org/v2.2/docs/developer/development/ide.html

As I want to work on a binding, I installed both OpenHAB Development and OpenHAB Add-Ons. After a successful install, all the “first run” tasks seemed to run without problems. However, almost all projects in OH2 Add-Ons throw an error in their pom.xml: “Plugin execution not covered by lifecycle configuration: org.apache.maven.plugins:maven-dependency-plugin:2.8:unpack-dependencies (execution: embed-dependencies, phase: process-sources)”

Running Help > Perform Setup Tasks and Project > Clean … > Clean all projects did not help.

As I am not experienced with maven, I don’t know how to proceed. Any hint would be appreciated!

I know there were major build system changes between 2.5M1 and 2.5M2 I doubt 2.2 docs are current.

I would start looking here.

Great you want to build your own binding. The link you pointed to is indeed the old documentation. There is new documentation, but it’s not completely up-to-date. You can find it here: https://www.openhab.org/docs/developer/#setup-the-development-environment

However. I wrote a migration guide that also contains the steps you need for developing a new binding:

The relevant steps are:

  • Step 2
  • Step 3: If you have no original code to copy, git clone your github fork to the git directory.
  • Step 5: To create the basis for your new binding
  • Step 9
  • Step 10
  • Step 11
  • Step 12: This is about pushing your changes back to github. Instead of what is described:
    First make a branch git checkout -b <your branch>
    and than git push. The first time it will show an error message and the command you should use because your branch isn’t tracked. Copy and run the shown command. The next time you can, after committing your code use git push or your favorite git gui.
1 Like

Very concise too :wink:


Thanks for the feedback! To my surprise, Eclipse actually solved my problem for me. I hovered over one of the problematic pom.xml’s errors and clicked the suggested solution (I don’t remember what it was called EDIT: “Discover new m2e connectors”), which brought me here:

After installing, accepting the license, and restarting Eclipse, I got a runtime error (“Executing […] jar:jar goal”, not enough heap space).
After restarting Eclipse again, everything magically worked.

Again, thanks for your help, I hope this helps someone else, too!

1 Like