[SOLVED] Shelly1 wiring with 2-way switching (hotel switch)

Tags: #<Tag:0x00007faed7f99380> #<Tag:0x00007faed7f991a0> #<Tag:0x00007faed7f99038>

Hi,

I couldn’t really find a good schema how to wire a 2-way switch to a shelly1.
Who can help me out?

This is a real easy overview how to wire a single switch:

This is my lamp on the 1st floor:

This is my switch on the ground floor:

And this is the switch on the 1st floor where the Shelly should come:

I’m living in the Netherlands so this are the wires:
Blue = Neutral
Brown = Phases
Green/Yellow = Ground
Black = Lamp/Switch

Hello,

Be very careful with 110/220V AC. IT CAN KILL YOU.
mains voltage should be done by a professional electrician.

Now that the disclaimer is out of the way:
here you go:

Don‘t forget to set the switch mode to „Edge“, see here

1 Like

Thanks, will look into it tomorrow when there is daylight in the house.
But for what wondering already, if I take the blue wire from the first floor, it is now connected from there to my lamp, so if I put it in the Shelly, should I use a welding clamp to connect it to the shelly as well to the lamp?

Thanks for the tip, will do that :wink:

I don’t know if the pictures were clear enough but the is the drawing of the switching method, is the earlier drawing still correct then?

Yes it is

Well, apparently the room behind the switch on the first floor isn’t enough to fit a Shelly behind.
So I decided to install the shelly above the lamp, the welding box is also above the lamp self.

I followed this schema what was designed for a hotel swtich:

This is my setup how the switching is working, the lines behind the switches only go through the mount box were the switch is installed in:

This is how I installed it now:

I thought I understand how it worked and that this was the right way but the light wont power on, even though the switch is on, it is flashed with tasmota and connected to my router.
The sehlly is powered on so I can reach his IP address, when I toggle it in the web page, the light also wont turn on.
I also discovered when the light switch is off on the ground floor, you can’t toggle it on the first floor, but if it is set to on, then you can toggle it…

I’m really cracking my head on it, but can’t figure out what to do, who can help me out?

I tried this wiring but it didn’t turn on the light, it is powered on becasue it is connected to the wifi but whatever I switch, it wont light up…

Any idea what goes wrong, if someone knows the solutions to install it in the ceiling box, that’s also fine :wink:

Looks to me that you have wired it correctly in both cases.
Maybe tasmota isn’t right? But with that I can’t help.

You were right, the wiring in both cases were correct, I feel a little stupid but the problem was in the tasmota software…

In the configuration you can change what kind of device it is, when I choose Shelly1 it worked instantly :wink:

Thanks for the help, all above schema’s can be used by other as example.