[SOLVED] Upgrade to OH2.5/MS4 over a existing OH2.4 - possible?

I have a working current OH2.4 with me. Unfortunately, I can not incorporate a (brand new) Roller Shutter 3 with this version - this is probably only in the ZWAVE binding for OH2.5 available (see https://community.openhab.org/t/roller-shutter-3-not-findable/85269/3).

The manual updating of the ZWAVE binding is - in my opinion - not quite trivial for endusers: (see: Zigbee and Z-Wave manual install script).

So my idea was to do a backup and upgrade the entire OH system to 2.5 / milestone 4. … BUT: as far as I can see I there is now way to upgrade an executable OH in the stable version to 2.5 … or I see that wrong?

Thank you, Regards


You can upgrade just the Z-Wave binding rather easily with the script. If you choose, you can upgrade your Stable 2.4 version to the Testing 2.5 Milestone 4 but you need to change what repository your system uses.
If you are using openHABian, it is quite easy. What OS are you using?

You can update your installation, you just need to add the repository that you’d like to use and then run the OH upgrade script. I recommend this, since there have been so many changes since 2.4 and 2.5 stable is close to release.

If you choose to update just the binding, I suggest not using the script to do a manual install. Just run this in the console and the dependencies will be taken care of for you, which is better than a manual install where the dependencies need to be manually resolved.

bundle:update https://openhab.jfrog.io/openhab/online-repo-snapshot/2.5/org/openhab/addons/bundles/org.openhab.binding.zwave/2.5.0-SNAPSHOT/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar
1 Like

The script author knows what he is talking about.

ajajaj - seems i am not even clever enough so handle the karal console … i’ve just startet with openhab-cli console … then typed “help” and now im caught in a loop :frowning: … what do i have to type to get out …?

logout or CTRL-D


can’t get out: after STRG-D i see this:

O… your in the help… CTRL-C or q

1 Like

puuh - yepp … CTRL-C works … thanks!:star_struck:

1 Like

… oh, oh, … don’t work:

What do you see whne you run this in the console?

list -s |grep zwave

If you have manually installed the zwave binding, you need to delete the jar from addons. If you have never installed the zwave binding, you need to run bundle:install instead of bundle:update.

Although, I may understand this better… that message may be due to the version change. Uninstall the zwave binding…

bundle:uninstall org.openhab.binding.zwave

Then run…

bundle:install https://openhab.jfrog.io/openhab/online-repo-snapshot/2.5/org/openhab/addons/bundles/org.openhab.binding.zwave/2.5.0-SNAPSHOT/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar

i see this:

… and … i’ve installed the zwave-Binding via paperUI … should i uninstall by paperUI? Will my Things still there after uninstal?

Thanks for the late night support :first_quarter_moon_with_face:

Only 6:45PM for me :wink:

Yes, uninstall the zwave binding that you have (through Paper UI or the console) and then run bundle:install. Your Things will be there when you install it again. But ALWAYS do a backup before making changes!

1 Like

okay … uninstalled via paperUI … then startet the “Bundle: install …” … after a few seconds i had the prompt again:

… and after a reload of the Bindings in the paperUI nothing changed:

… maybe i make mistakes cause it’s 1:00am here :frowning:

You won’t see the binding in Paper UI. Did your zwave Things go online? Look under Configuration> Things. How about…

list -s | grep zwave
1 Like

Mmmh Things are not online:


Is the binding active? Have you restarted OH? Do you have a controller Thing and is it configured properly? What do you see in the openhab.log after setting zwave to debug?

If this is all too complicated, upgrade your OH to 2.5M4 or wait for 2.5 stable.


EDIT: complete instructions please see down below, in this post.

I’m sure, that dependency “com.thoughtworks.xstream” is missing. You also have to install this.

bundle:install http://central.maven.org/maven2/org/apache/servicemix/bundles/org.apache.servicemix.bundles.xstream/1.4.7_1/org.apache.servicemix.bundles.xstream-1.4.7_1.jar

then you have to start both newly installed bundles: (in your case (zwave = 237) and “xstream” probably has ID: 238

You can check this with bundle:list and then search for the ID in left column.
Then do:

bundle:start 238
bundle:start 237


EDIT: complete instructions please see down below, in this post.

No. You do not need to manually install dependencies if you use bundle:install (or bundle:update). When installed in this way, Karaf resolves the dependencies for you, just like when you install through Paper UI.

I’ve tried out 15 min ago. And dependency was NOT installed.

After I’ve installed zwave binding (with your command), I had to start with bundle:start 209

And then following error occurs:

Error executing command: Error executing command on bundles:
        Error starting bundle 209: Could not resolve module: org.openhab.binding.zwave [209]
  Unresolved requirement: Import-Package: com.thoughtworks.xstream; version="[1.4.0,2.0.0)"