Sonoff Zigbee 3.0 USB Dongle Plus -- consensus on installation and use

I have read the various threads on the Sonoff Zigbee 3.0 USB Plus Dongle.

and my head is spinning with zigbee or other binding, usb cable extension, firmware update or not ;-(

Can I ask a summary question on this hardware, which from what I have understood is a solid zigbee hub, that can be plugged in directly into an openhab on rasbpi installation.

  • Should the firmware be upgraded or is the pre-installed firmware appropriate for use with an existing openhab binding?

  • Which binding should be used? zigbee, zigbee2mqtt, other?

  • What are the concrete installation steps which need to be done? [I tried the automatic scan for a bridge and the manual addition of the CC2531EMK Coordinator to no avail]

thanks for your help.

I have this dongle running with stock firmware, but that depends on what firmware is “stock” for you.

I’m using zigbee2mqtt and you would require the following setup:

One-time:

  1. Install mosquito or any other mqtt server
  2. Install openhab mqtt binding & Create mqtt bridge thing
  3. Install zigbee2mqtt

For each device:

  1. Pair zigbee device via zigbee2mqtt with your network
  2. Create generic mqtt thing in openhab for each zigbee device

Hello Matze,

Thanks for the structure :wink:

I have (I think successfully) completed one-time tasks 1.,2.,3.

Please do not shout at me for asking the stupid question:

How do I do ?

  1. Pair zigbee device via zigbee2mqtt with your network

Set zigbee2mqtt into pairing mode

And then put your ZigBee device into pairing mode (that’s device specific, most time done by a reset of the device)

I would recommend to use the z2m frontend, what can be enabled in the config file

OK, getting there. I have now successfully done 1.2.3 and 1.2 for 2 devices.

I have installed zigbeetomqtt on the same raspberry as openhabian, but manually assigned port 8081, as 8080 was - obviously - already taken by openhab runtime.

The problem I’m having now, is that when I close the putty session with which I have started the zigbee2mqtt service, it shuts down the service altogether, so i cannot access openhabian:8081 anymore and openhab doesn’t see the sensors any longer.

I can restart it and that works … but after a while, it just goes offline like that.

any help, here?

You need to run z2m as a service, then it will continue to run even when the terminal is closed.

That’s also described in the z2m installation documentation

As mentioned, you need to run zigbee2mqtt as a service (daemon in the documentation.)

Yes it does ship with the right type of firmware but an older version so while it will work out-of-the-box it is still highly recommended that you update the firmware as latest will always contain more bug-fixes.

You can currently only use it with Zigbee2MQTT as the Zigbee binding does not yet support CC2652, see: https://community.openhab.org/t/discussion-about-texas-instruments-z-stack-3-0-and-cc2652-and-cc1352-zigbee-coordinator-adapters-with-openhab-zigbee-binding/129385

There is no automatic scan as the Zigbee radio is a serial device so regardless of Zigbee implementation you will always need to manually config it use to device path of the serial port that it has been assigned.

I’m new to OH. Purchased some Sonoff outlets, temp/humidity sensors and a couple of Sonoff Zigbee 3.0 USB Dongle Plus. I upgraded the firmware on one unit via Sonoff’s website instructions, and after reading they should work out of the box, left the other as it was delivered. Neither have worked. I have managed to get a Nortek HUSBZB-1 hitting “online” status on zwave, mqtt, and Ember Coordinator in one of the iterations I’ve tried… but it’s not supported by z2m as of today and zigbee’s where I’m aiming.

My question is what settings are working for the Zigbee Ember Coordinator after establishing the MQTT Broker (online) and a zigbee2mqtt running? I’m on openhabian release 3.2 running on pi4 with the Sonoff ZIgbee 3.0 USB Dongle Plus. I’ve tried a lot of variations and can’t seem to get it online with this dongle. Steady “Unkown” and flashing comm errors have resulted from the many combinations I’ve tried.

Another question: I’m using the advice: “remove the non functioning coordinator - restart - add new coordinator”. Will restarting openhabian using systemctl be sufficient to be certain new settings are getting applied?

Thanks for your assistance!

Just to check, because this passage is confusing me: you are aware that

  • your ZigBee coordinator communicates with zigbee2mqtt only
  • zigbee2mqtt communicates with your MQTT broker.
  • openHAB communicates with your MQTT broker.

So your ZigBee coordinator never communicates directly with openHAB, and there is no configuration of your ZigBee coordinator in openHAB.

If this is a question about how to configure zigbee2mqtt with your coordinator then you may have more luck requesting help from the zigbee2mqtt project.

Thank you for your response, apologies for lacking clarity. I am asking what others are using to configure the Ember Coordinator to work with the Sonoff Zigbee dongle in Openhab 3.2 release. Since this thread seems appropriate I thought I’d ask… Sorry. I’ll look elsewhere.

Thanks.