The Eclipse Setup of Openhab

i can’t install eclipse setup, i selected all needed tasks, but still there is an error, can someone help me.
i am new Beginner in Openhab. Thanks

What module/artifact reference is stated after the last error line ?
ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: artificial_root 1.0.0.v1658422062.....
Perhaps that requirement is no longer needed and can be removed from your setup file. I can remember (old eclipse smarthome ide) somewhere in the past, this was happened before.

hallo peter ,
thanks for the Answer, it´s (ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: artificial_root 1.0.0.v1658591478264 requires ‘org.eclipse.equinox.p2.iu; org.eclipse.mylyn.java_feature.feature.group 0.0.0’ but it could not be found)

Well. I guess you need assistance from the ones that knows how to define a setup far better then me.

At first glance, It appears also to me, that your set-up (check xml files) may be out of sync.

It’s a namespace=‘org.eclipse.equinox.p2.iu’ (installable unit) issue that’s likely referenced in virtually every module op openHAB.
Perhaps you are using the wrong target-arechitecture (things like x86, x32, x64 etc.etc.)

Try to search for that specific error message (and likely get tons of hits).

Just a question

If you’re new to openHAB, would it not be easier to follow the latest installation instructions, rather than going down the Eclipse route?

(Unless you have very specific reasons)

hallo MDAR,
thanks for your Answer.
you are right, but i shlould in my Graduation Paper to create a new Binding, und the Code sholud written in java,

Indeed, as all bindings are.

I could be wrong, but I don’t think you need the Eclipse version of openHAB to do that.

I’m little more than an end user, but my understanding is that the openHAB foundation moved away from Eclipse some years ago, prior to openHAB 3 (I’m very prepared at this point to be corrected)

Nope, preferred IDE (what OP wants to setup) is still Eclipse. That has nothing todo with the retired Eclipse smarthome project you have in mind.

3 Likes

You probably refer to the build system. This was based on Eclipse/maven and was replaced with bnd/maven. But this is independent of the usage of the Eclipse ide, which is still the preferred ide.

2 Likes