Update from 2.4 to 2.5 Zigbee TRADFRI Signal Repeater - No supported clusters found

after the update from 2.4 to 2.5 stable the Zigbee has some problems. The Repeater (IKEA TRADFRI Signal Repeater) which are running well under 2.4 is not working with 2.5.
I get the message:
2019-12-27 16:11:35.996 [hingStatusInfoChangedEvent] - ‘zigbee:device:191ac2fa:14b457fffef74fbf’ changed from UNKNOWN to OFFLINE (HANDLER_INITIALIZING_ERROR): No supported clusters found
I chaged nothing in my hardware as Zigbee communication.
I use the CC2531EMK since months with 2.4.

How can I connect the Repeater again?

Thank you very much

Try power cycling the Tradfri gateway/repeater.

I tried to power cycle the Tradfri Repeater, but this does not help.
I use not the tradfri gateway, I use the Zigbee binding and the CC2531EMK.

Try uninstalling the zigbee binding, remove the CC2531, stop OH, clean cache, restart OH and after everything is completely back up and running reinstall zigbee binding. Also plug the CC2531 back in.

I tried your suggestion, but no changes.

Still have the following situation:
Status: OFFLINE - HANDLER_INITIALIZING_ERROR No supported clusters found
And same in the Log:

  • 2019-12-27 19:17:32.041 [hingStatusInfoChangedEvent] - ‘zigbee:device:e3c64d09:14b457fffef74fbf’ changed from UNKNOWN to OFFLINE (HANDLER_INITIALIZING_ERROR): No supported clusters found
  • 2019-12-27 19:17:32.574 [WARN ] [ng.zigbee.handler.ZigBeeThingHandler] - 14B457FFFEF74FBF: No supported clusters found

Here the link of the product which is running under OH2.4 but not on OH2.5:

Check addons.cfg and make sure restdocs are not listed in misc. If so, then delete it and restart OH.

You mean the openHab-conf/services/addons.cfg?
In this addons.cfg is : #misc =

Yes there and verify in /var/lib/openhab2/config/org/openhab/addons.config as well.

Also, in this addons.config is misc= “”
Already the same behavior.
Status: OFFLINE - HANDLER_INITIALIZING_ERROR No supported clusters found

same here with a fresh install
Status: OFFLINE - HANDLER_INITIALIZING_ERROR No supported clusters found

Also Noticed that IKEA TRADFRI plugs do not perform well as repeaters. When you First add them to the system they will perform well but after a restart most of the time they will not be able to connect to their zigbee neighbors even if their zigbee neighbors are 50 cm away

The situation becomes bad because sometimes they will connect to devices that are far way

If I replace the plugs with a hue bulb then everything works ok

In my case the IKEA Repeater is approx. 3m distance to the CC2531. My other devices are approx 7m from the IKEA Repeater. I have 3 Tradfri LED transformer devices and one Aquara temperature sensor.
I tried several solutions on OH2.5 but without success.
Without this repeater I can bind the devices but the connection is not reliable.
In the past I worked with this IKEA Repeater which is working very well on OH2.4. Since OH2.5 I am sitting in the dark.:grinning:

Did you find a solution?
I have the exact same issue.

I tried now to kick the tradfri repeater a couple times out and have it rejoin.
I never get it to get past this “no supported clusters found” state
probably only @chris could help and we provide all logs he needs for that

2020-07-12 10:49:41.971 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 680AE2FFFE98C079: Initializing ZigBee thing handler zigbee:device:01382869:680ae2fffe98c079
2020-07-12 10:49:41.972 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 680AE2FFFE98C079: Coordinator status changed to ONLINE.
2020-07-12 10:49:41.973 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 680AE2FFFE98C079: Coordinator is ONLINE. Starting device initialisation.
2020-07-12 10:49:41.974 [DEBUG] [pp.discovery.ZigBeeNetworkDiscoverer] - 680AE2FFFE98C079: NWK Discovery starting node rediscovery
2020-07-12 10:49:41.976 [DEBUG] [e.transaction.ZigBeeTransactionQueue] - Broadcast: Added transaction to queue, len=1, transaction=ZigBeeTransaction [ieeeAddress=null queueTime=0, state=WAITING, sendCnt=0, command=NetworkAddressRequest [0000/0 -> FFFD/0, cluster=0000, TID=--, ieeeAddr=680AE2FFFE98C079, requestType=0, startIndex=0]]
2020-07-12 10:49:41.978 [DEBUG] [transaction.ZigBeeTransactionManager] - FFFD/0: Sending ZigBeeTransaction [ieeeAddress=null queueTime=2, state=WAITING, sendCnt=0, command=NetworkAddressRequest [0000/0 -> FFFD/0, cluster=0000, TID=94, ieeeAddr=680AE2FFFE98C079, requestType=0, startIndex=0]]
2020-07-12 10:49:41.979 [DEBUG] [transaction.ZigBeeTransactionManager] - transactionListenerAdded: 2 outstanding
2020-07-12 10:49:41.980 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX CMD: NetworkAddressRequest [0000/0 -> FFFD/0, cluster=0000, TID=94, ieeeAddr=680AE2FFFE98C079, requestType=0, startIndex=0]
2020-07-12 10:49:41.981 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - TX APS: ZigBeeApsFrame [sourceAddress=0000/0, destinationAddress=FFFD/0, profile=0000, cluster=0000, addressMode=DEVICE, radius=31, apsSecurity=false, ackRequest=true, apsCounter=46, rssi=--, lqi=--, payload=94 79 C0 98 FE FF E2 0A 68 00 00]
2020-07-12 10:49:41.992 [DEBUG] [zigbee.dongle.ember.ZigBeeDongleEzsp] - RX EZSP: EzspSendBroadcastResponse [networkId=0, status=EMBER_SUCCESS, sequence=5E]
2020-07-12 10:49:41.993 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 680AE2FFFE98C079: Start initialising ZigBee Thing handler
2020-07-12 10:49:41.994 [DEBUG] [scovery.ZigBeeNodePropertyDiscoverer] - 680AE2FFFE98C079: ZigBee node property discovery start
2020-07-12 10:49:41.995 [DEBUG] [scovery.ZigBeeNodePropertyDiscoverer] - 680AE2FFFE98C079: ZigBee node property discovery using basic cluster on endpoint 846F/1
2020-07-12 10:49:41.996 [DEBUG] [scovery.ZigBeeNodePropertyDiscoverer] - 680AE2FFFE98C079: ZigBee node property discovery using OTA cluster on endpoint 846F/1
2020-07-12 10:49:41.997 [DEBUG] [scovery.ZigBeeNodePropertyDiscoverer] - 680AE2FFFE98C079: ZigBee node property discovery complete: {zigbee_logicaltype=ROUTER, zigbee_powerlevel=FULL, zigbee_manufacturercode=0x117c, modelId=TRADFRI Signal Repeater, zigbee_networkaddress=33903, zigbee_powersource=MAINS, zigbee_stkversion=98, zigbee_datecode=20190311, zigbee_zclversion=3, vendor=IKEA of Sweden, zigbee_powermode=RECEIVER_ON_IDLE, zigbee_powersources=[MAINS], hardwareVersion=1, firmwareVersion=0x22005631, zigbee_applicationVersion=33}
2020-07-12 10:49:41.998 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 680AE2FFFE98C079: Checking endpoint 1 channels
2020-07-12 10:49:42.000 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 680AE2FFFE98C079: Checking endpoint 242 channels
2020-07-12 10:49:42.003 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 680AE2FFFE98C079: Dynamically created 0 channels
2020-07-12 10:49:42.004 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 680AE2FFFE98C079: Initializing device
2020-07-12 10:49:42.004 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 680AE2FFFE98C079: Channel initialisation complete
2020-07-12 10:49:42.005 [WARN ] [ng.zigbee.handler.ZigBeeThingHandler] - 680AE2FFFE98C079: No supported clusters found

What do you want to do with it? It’s a repeater, so probably it doesn’t have any user functions? Or does it also turn on lights, or a plug socket or something?


well Paper UI reports it as.

the 2 other guys up in the thread have screenshot added - it always says “offline” with that error shown

I also get a lot of initialize options in the meanwhile :wink: :wink:

Sure, but about my question -:

As far as I know it doesn’t do anything. It should work as a repeater all the same, but openhab won’t be able to provide you any switches etc unless the device provides these sort of features. Does it? I’m not
familiar with this device so I’m trying to understand what you are expecting to provide so I can understand the “no supported clusters” log you mentioned as being a problem


Sure I only want to act as an repeater. Do you mean the state in the UI is fully ok and that is shown as offline with that error message is “work as intented”?

If it is joined to the network, it will work as a repeater. OH can’t provide you any user functionality.

Probably it shows offline as there is no user functions, so the binding doesn’t poll, and there is no reporting.

well ok then I might be happy already.

the UI does not show any neighbors in the properties for this device … so I interpreted it is not working correctly.
sorry for that … the “offline” state is a little misleading then