Working and not working IP Cameras

After spending hours trying to connect an Instar IN-6014HD camera, which finally showed not compatible with the IP Binding I would like to collect working an not working IP cameras.

API cameras reported as working

If missing, it just means no one has reported back (it probably works just fine if not in this list).



Fosbaby P1
C1 Lite

DS-7208HQHI-F1 / N
DS-7616NI-K2 / 16P

IN-8015 Full HD

ONVIF cameras reported as working

Reolink RLC-410-5MP
Reolink RLC-520

I know the thread, but most of the models are outdated.

How did you determine it was not compatible? Have looked and not seen any posts on this forum asking for help… I have been doing some testing the last few days with an Instar IN- 8015HD and it works fine, but I did find and fix a bug that was causing issues for the Alarm detection features.

[ipcamera] Fixes for Instar and HLS. by Skinah · Pull Request #9766 · openhab/openhab-addons (

I asked for help in the instar forum and got a lot off help there.
I only get the snapshot, but alarm and tilt and pan function are working. Neither with the instar nor with the ONVIF thing. Settings are checked serveral times. ONVIF settings should be correct to, as pan and tilt function work on the ONVIF Device Manager.
I organized a Foscam FI9831W as it is reported working with API and OVIF. Sadly it has the same problems with pan and tilt function. I only get an snapshot an the alarm through the binding.
Is there a known problem with the pan and tilt function or a workaround?
No problems are shown in the log files. The pan and tilt items receive the commands.

Instar cameras work well with either CONTINUOUS or PRESETS. Continuous needs a config turned on in the bindings settings for the camera. Presets are probably easier to use so try to get them working first.
TIP you need to save the preset with a name that is the number of the slot, ie “1”.
The alarms issues is probably the issue I just solved which is waiting to be merged but you can download the jar from here.

If you still have issues, then post the TRACE level logs for when the camera connects.

I have set the PTZ to Continuous. Right now nothing works; No snapshot, no alarm, no movement.
To me the log shows no problems:
2021-01-10 12:09:59.737 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘ipcamera:instar:1921688109’ to inbox.

2021-01-10 12:09:59.741 [home.event.InboxAddedEvent] - Discovery Result with UID ‘ipcamera:instar:1921688109’ has been added.

2021-01-10 12:10:15.445 [me.event.InboxRemovedEvent] - Discovery Result with UID ‘ipcamera:instar:1921688109’ has been removed.

2021-01-10 12:10:15.471 [hingStatusInfoChangedEvent] - ‘ipcamera:instar:1921688109’ changed from UNINITIALIZED to UNINITIALIZED (HANDLER_CONFIGURATION_PENDING)

2021-01-10 12:10:58.269 [me.event.ThingUpdatedEvent] - Thing ‘ipcamera:instar:1921688109’ has been updated.

2021-01-10 12:10:58.279 [hingStatusInfoChangedEvent] - ‘ipcamera:instar:1921688109’ changed from UNINITIALIZED (HANDLER_CONFIGURATION_PENDING) to INITIALIZING

2021-01-10 12:10:58.305 [vent.ItemStateChangedEvent] - InstarCamera1921688109_ImageURL changed from NULL to

2021-01-10 12:11:02.321 [hingStatusInfoChangedEvent] - ‘ipcamera:instar:1921688109’ changed from INITIALIZING to ONLINE

2021-01-10 12:11:02.340 [vent.ItemStateChangedEvent] - InstarCamera_Tilt changed from NULL to 0

2021-01-10 12:11:02.341 [vent.ItemStateChangedEvent] - InstarCamera_Pan changed from NULL to 0

2021-01-10 12:11:02.343 [vent.ItemStateChangedEvent] - InstarCamera_PollImage changed from NULL to OFF

2021-01-10 12:11:03.321 [vent.ItemStateChangedEvent] - InstarCamera1921688109_MotionAlarm changed from NULL to OFF

2021-01-10 12:11:03.338 [vent.ItemStateChangedEvent] - InstarCamera_AudioAlarmONOFF changed from NULL to ON

2021-01-10 12:11:11.346 [vent.ItemStateChangedEvent] - InstarCamera1921688109_MotionAlarmONOFF changed from NULL to ON

2021-01-10 12:11:16.493 [vent.ItemStateChangedEvent] - InstarCamera_Pan changed from NULL to 0

2021-01-10 12:11:16.499 [vent.ItemStateChangedEvent] - InstarCamera_Tilt changed from NULL to 0

2021-01-10 12:11:19.328 [vent.ItemStateChangedEvent] - InstarCamera1921688109_MotionAlarm changed from NULL to OFF

2021-01-10 12:11:19.346 [vent.ItemStateChangedEvent] - InstarCamera_PollImage changed from NULL to OFF

2021-01-10 12:11:19.354 [vent.ItemStateChangedEvent] - InstarCamera_AutoLEDONOFF changed from NULL to ON

2021-01-10 12:11:19.532 [vent.ItemStateChangedEvent] - InstarCamera1921688109_ImageURL changed from NULL to

2021-01-10 12:11:19.549 [me.event.ThingUpdatedEvent] - Thing ‘ipcamera:instar:1921688109’ has been updated.

I need the trace level log to look into it, the command to use trace level is found in the ipcamera binding documentation under the heading what to do if you have problems.

You mean this command: log:set TRACE org.openhab.binding.ipcamera ?
I entered it at the openhabian console (putty), but the command is not known!

from the openhaibian console/putty you need to login to the karaf console to enter the command.

Thank you for your help! It’s hard at the beginning.
Attached the TRACE logTrace.txt (22.8 KB)
Why is it asking for a snapshot on port 8083 ?!?!?
Also the logs are showing the camera is not giving any replies back to ONVIF requests, is it behind a firewall or NVR that may be blocking comms? The binding by default will try to contact INSTAR on port 8080 for ONVIF, has the camera been changed to use ONVIF on port 8083?

What have you changed from the default settings for the camera in the bindings settings? Do not change anything from their defaults, just give the binding your user/pass and also enter in a Server Port that is different for each camera you have. Then what does the log show?

The http port is set to 8083. I reset the ONVIF Port to 8080 (before 9093). In the settings I only added the user and password and the http port (8083). The PTZ movement is set to continuous. I am using windows defender. The attached TRACE log is made with turned off firewall.Trace.txt (18.2 KB)

At least now your getting some kind of cut short ONVIF replies. The reply should contain a lot more than this…

Onvif reply is:<?xml version="1.0" encoding="UTF-8"?>

I need to see when the camera connects, you can trigger that by changing the Server Port setting which will trigger it to reconnect.

port 8083 sounds wrong, the default is 80 so try that as if that is wrong you wont get any snapshots or streams working.

You should try entering the URLS into a web browser to see if they work as that will quickly tell you if the port is wrong.

I just tried the URL and got a snapshot.
Attached the TRACE with http port set to 80 an server port changed.Trace.txt (30.8 KB)

What happens if you use ? does that give a snapshot as well?

The logs are confusing me as they look to be cut short, however the binding is reporting that it is finding valid preset locations which indicates the reply is longer, the logs just dont show the full output… Any idea why that is happening? are you cutting them short? can you see longer replies if you look at the log?

A Server Port of 500 is not a good idea as some Linux versions require admin rights to use ports under 1024 so try a higher number. This is another confusing thing as the binding should be giving you a warning about this, yet it is not seen in the log you provided. Something wierd is going on and I cant fault find if the logs are messed up. gives me a snapshot.
I changed the server port to 5000.
The logs are from: tail -f /var/log/openhab2/openhab.log /var/log/openhab2/events.log
The are not truncated. I attached a selection of ipcamera.Trace.txt (19.0 KB)
I entered tail -f /var/log/openhab2/openhab.log /var/log/openhab2/events.log in the Karaf console and the result looks the same.

The camera is giving a 404 not found error so port 80 may be wrong. Until I can see proper ONVIF replies I can not help further. The ONVIF will be reporting back what urls to use and the ports but the logs have cut everything short. Never seen or heard of that before.

So your using openHAB 2.x? Did you happen to download the binding I linked to above which is a 3.X version? If so that may explain it…
Under 2.5.x this one is the latest build.

You should clean the cache and tmp after placing that into the addons folder, reboot openHAB a few times and then delete and re-add the camera.

I recommend you move to V3

openhab - Kopie.log (294.4 KB) I made a clean OH 2.5.10 installation on my notebook.
There the snapshot works. The Pan and Tilt functions and the alarms are still dead.
I also tried the ODM. There the camera is found and the PTZ control works.
I am adding the openhab.log from my notebook. There are ONVIF logs inside.

I made an OH 3.0 test installation and added the camera.
Snapshot is shown, but PTZ and alarms are not working.
The TRACE log: Trace.txt (49.2 KB)