Worx Landroid Binding

Yes! Same here since yesterday evening.

Same here :sob:

At least I’m not the only one with that block message. :grinning: Binding worked without problems for months now. Problems also started yesterday evening at around 19:40.

Hi together, I am receiving this “blocked by worx” error for about 2 days now, so even after 24h I cannot connect any more. Any ideas? :cry:

EDIT: Or is the 24h-timer starting again on each try? During the last 2 days I tried to disable and enable the bridge Thing several times to see, if my 24 hours are over. Is this maybe the reason, why my 24h are not ending? :wink:

EDIT 2: I now tried to create a completely new Worx Account with a new Email-Adress and registered my Landroid there. I also removed the Binding, all Things and Items from OpenHab. After that I started again from scratch, but when I added the Landroid Bridge as a new Thing and enter my (new) account data, I receive “Error: Error calling Worx Landroid WebApi! HTTP Status = 404”. Full Details from log:

2022-10-20 13:22:08.444 [INFO ] [d.internal.WorxLandroidBridgeHandler] - Start retrieving AWS certificate
2022-10-20 13:22:08.505 [ERROR] [d.internal.WorxLandroidBridgeHandler] - Iniialization error - class: org.openhab.binding.worxlandroid.internal.webapi.WebApiException
2022-10-20 13:22:08.507 [ERROR] [d.internal.WorxLandroidBridgeHandler] - Iniialization error - message: Error calling Worx Landroid WebApi! HTTP Status = 404
2022-10-20 13:22:08.508 [ERROR] [d.internal.WorxLandroidBridgeHandler] - Iniialization error - stacktrace: [Ljava.lang.StackTraceElement;@1b2d392
2022-10-20 13:22:08.510 [ERROR] [d.internal.WorxLandroidBridgeHandler] - Iniialization error - toString: org.openhab.binding.worxlandroid.internal.webapi.WebApiException: Error calling Worx Landroid WebApi! HTTP Status = 404

What is happening here? Any help would be appreciated… :confused:

Same here, no solution found yet.

Seems like this time only openHAB is affected :frowning:
DeskApp ist working without issues.

Interesting: not for me. openHAB and DeskApp are down.

2022-10-27 08_46_57-Einstellungen

That’s strange…


OpenHAB and DeskApp stopped for me too!
The DeskApp stopped only after I removed the mower from the account and then added it to the account again.

I can confirm same issue without any changes on OpenHAB (3.3.0).

The Android app works for me, but the Desktop App and OpenHAB (3.3.0) has stopped!
Previously (when OpenHAB Binding had already stopped), the Desktop APP continued to work, but after I reconnected the mower to the account, the DeskApp kept reporting an MQTT communication error.

the Landroid-Binding v3.2-beta works fine for me. No problems !
Refresh Status Intervall: 1200; Polling Intervall: 599 (max. Value by UI)

OpenHAB 3.3 (stable)

Is the problem solved?
It still doesn’t work for me…
Unable to unblock.
Previously it was set to:
refreshStatusInterval=60, pollingInterval=300
I also tried with this setting:
refreshStatusInterval=1200, pollingInterval=599
The end result is the same!
What values are set for you?

MyWorx Bridge
Connection blocked from Worx, please try again in 24h!

Maybe they changed the max. Polling Intervall on the API. I’ll give it a try…


Same here.

Unfortunately, the maintainer of the binding did not find a fix yet:

Thanks for the reply!
I’ll wait for it to be resolved then.

Why is it that the error occurs only in certain cases and does not cause an error in everyone? Strange.

same problem at the moment with oh3

same problem at the moment with oh3
d.internal.WorxLandroidBridgeHandler] - AWS connection failure

As a workaround I installed ioBroker, who are using a different technique to connect to the mower, on a virtual machine, installed the MQTT client and the Worx adapter and configured the datapoints to be sent to my openHAB instance via MQTT.
Even the new torque settings introduced by newer firmwares can be adjusted via openHAB now …

But I hope this is only a temporary workaround.

1 Like

Sounds interesting, sihui. :+1:
My mower is powered off now until March and I still hope that there will be native solution, but if not, I will maybe try your workaround then.
Would it be possible that you provide some more detailed step-by-step instructions for your configuration?
Is it possible to install ioBroker, the MQTT client and the Worx adapter on a Raspberry PI in parallel to an existing OpenHab installation or will this have any negative impacts related to stability, performance or whatever?