Worx Landroid Binding

Sure, install ioBroker, it is just a curl one liner (pretty impressive),

install the MQTT client adapter (=Binding in openHAB), point it to your MQTT broker.

install the Worx adapter

configure a MQTT instance =(Thing in openHAB), configure a Worx instance, all datapoints (=Channels in openHAB) will be available right away.

Go to each Worx datapoint you intend to use and click the gear sign on the far right, activate MQTT for that datapoint and activate subscription and or publishing.

Create a generic MQTT Thing in openHAB and add channels for each ioBroker datapoint you intend to use.

That’s it.

I have no idea as I used a separate lxc container on my Proxmox installation. I would suggest to use not the openHAB server as this is hopefully only a workaround until the binding gets fixed in openHAB.

1 Like

Thank you so much for your explanation!
I am still not sure, whether I really want to install ioBroker in parallel to OpenHAB on the same Raspberry. If there is no sustainable solution with the Binding itself until March next year, I could give it a try - let’s wait and see… :wink:

Any update @nibi79? I think a fix of the openhab binding itself would be highly appreciated from many people!

1 Like

hi all,

please take a look at my post here:

and if possible, you can test this new version:

Currently, it looks like OH versions >= 3.3.0 are supported.

As always, your feedback is appreciated

4 Likes

Great! Seems to work, the bridge is online again! I did not yet start the mower due to snow, but all values are already successfully received from the mower and shown in the sitemap!
Thank you so much for your efforts, nibi79! :wink::+1:

1 Like

Today I upgraded OH to 3.4.2 and installed the binding.
It seems to be loaded, openhab-cli shows it’s active:

290 │ Active │  80 │ 3.4.1                  │ openHAB Add-ons :: Bundles :: worxlandroid Binding

But the items can’t find the reference to the channel. It’s always unknown / invalid link.

My things definition:

Bridge worxlandroid:worxlandroidBridge:MyWorxBridge "MyWorx Bridge" [ webapiUsername="aa@aa.com", webapiPassword="aaa" ] {
    Thing mower xyz "MyLandroid Shaun" [ refreshStatusInterval=3600, pollingInterval=3600 ]
}

My items:

Number LandroidBatteryLevel       "Battery Level [%d %%]"  <battery>  (persistGroup, MowerBat, MowerBatStatus_Chart)    {channel="worxlandroid:mower:MyWorxBridge:xyz:datBattery#batteryLevel"}

The webgui of OH tells me the Bridge & Thing are online. But when I look into the mower thing, there are no channels detected.

I had this running on OH 3.1 before without any issues. I didn’t change the config files…
Any help appreciated!

Maximum for pollingIntervall is 599.
It is way better to use autodetected Things, you would have seen the max right away:

worx

Thanks a lot for the quick reply.
That indeed helped.

About autodetection: I have all things defined in a config file. I would expect some error message when the thing file is loaded. Because I didn’t change the file migrating from OH 3.1 to OH3.4.2 and using the new binding.

may i ask where i could find this widget you’re using here?[quote=“cypresss, post:231, topic:95246, full:true”]
That’s strange…

image
[/quote]

It is a desktop application from the German Worx forum, but that deskapp is broken at the moment:

Ahh ok :slight_smile: and i thought it would be a openhab 3 widget. :smile:

I started my Landroid for a new season yesterday, switching to the landroid-Binding 3.4.1, because the Version 3.2. didnt work on my OH 3.4.2.
But I cant connect to the worx-Server. The bridge hangs in initialising-mode.
Errormessage is :
[worxlandroid.internal.mqtt.AWSClient] - Exception: software.amazon.awssdk.crt.mqtt.MqttException: The connection was closed unexpectedly.
Any Ideas are welcomed !

Follow this issue on github. For some users the binding just does not work …

Edit: It works!!!

Lastly, I uninstalled the Bridge/Mower Things that I had previously added via Things Discovery.
Then just add the textual Things file without any further actions.

The binding immediately updated the associated elements. The sitemap is updated every 10 minutes and everything works fine.

Thanks again Nibi for your great work ! :clap: :+1:


Happy too soon…

2023-04-04 08:10:51.322 [ERROR] [worxlandroid.internal.mqtt.AWSClient] - Exception: software.amazon.awssdk.crt.mqtt.MqttException: The connection was closed unexpectedly.

Hi! Worked with Version 3.4.1 beta 24hours without problems. now the bridge is in state initalizing…
Log shows:
2023-04-07 14:27:05.353 [DEBUG] [d.internal.WorxLandroidBridgeHandler] - API connected: true
2023-04-07 14:27:05.360 [DEBUG] [nternal.webapi.request.WebApiRequest] - URI: https://api.worxlandroid.com/api/v2/users/me
2023-04-07 14:27:05.851 [DEBUG] [nternal.webapi.request.WebApiRequest] - URI: https://api.worxlandroid.com/api/v2/product-items?status=1
2023-04-07 14:27:06.060 [DEBUG] [worxlandroid.internal.mqtt.AWSClient] - AWSClient create connection: IP → 34.251.99.68
2023-04-07 14:27:06.720 [DEBUG] [d.internal.WorxLandroidBridgeHandler] - try to connect to AWS…
2023-04-07 14:27:07.168 [DEBUG] [d.internal.WorxLandroidBridgeHandler] - AWS connected: false

any suggestions?

1 Like

Hi,

I’m facing exactly the same issue… Any ideas?

Thanks a lot!

BR
Michael

I took 24hours offline. Now it works . Hopefully after 24h again.

Did it work after the 24 hours?
I have same issue. Just got my mower, and after around a day after setting it up in OH, the bridge just cannot connect. Stays in status Initializing. If I change the username or password in the binding, I get another error, so the connection must be valid somehow. I’m not that familiar with cloud services on a technical level, but it could seem like the amazon service has a limit on some kind - perhaps regarding number of connections, hours of use or something else?? Could that be the case?
Furthermore my app cannot connect to the mower. But I think that is a local issue with the range of my wi-fi. App only updates when I open it. After that I just get a connection error.
/feldt

at the moment i am above 24hours. hopefully this holds on. I must tell you that the last 24hours the worx was standby because of heavy rain. But it was constant conntected via WIFI

Again… please follow the issue regarding the current problem here:

Please make sure to use the latest beta version of the binding, which you can find here:

1 Like