Worx Landroid Binding

I confirm. I have progressed revamping and clarifying many things. I think I’ll be able to propose something next week - but I also need to see it working one two days.


Hi, thanks everybody.

Just as an information. As I’ve stated today OH 4.0.3 i got this message:
And for sure i cannot Control the robot anymore

2023-09-11 17:59:21.648 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/openhab/addons/org.openhab.binding.worxlandroid-4.1.0-SNAPSHOT.jar

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.worxlandroid [37]

  Unresolved requirement: Import-Package: org.openhab.core.auth.client.oauth2

	at org.eclipse.osgi.container.Module.start(Module.java:463) ~[org.eclipse.osgi-3.18.0.jar:?]

	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:445) ~[org.eclipse.osgi-3.18.0.jar:?]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) ~[?:?]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) ~[?:?]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:520) ~[?:?]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) ~[?:?]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) ~[?:?]

Any news on the fix? I‘d be happy to test in case you‘d like to provide a jar :slightly_smiling_face:

Thanks for all your work!

Here it is : org.openhab.binding.worxlandroid-4.1.0-SNAPSHOT.jar - Google Drive

The AWS section has been reviewed. The mower thing status is no more linked to it (there is a new channel aws#connected that tracks connection availability).


Awesome, thank you so much!

Will test right away!

Thank you so much.

Just downloaded, I’ll test it right now!


Great, does it also work with OH 3.x?

Hi and thanks again for the update. With this latest version I’m unable to set party mode:

2023-09-17 16:57:41.555 [ERROR] [nal.common.AbstractInvocationHandler] - An error occurred while calling method 'ThingHandler.handleCommand()' on 'org.openhab.binding.worxlandroid.internal.handler.WorxLandroidMowerHandler@1b4b14e': For input string: "PARTY"
	at org.openhab.binding.worxlandroid.internal.handler.WorxLandroidMowerHandler.lambda$9(WorxLandroidMowerHandler.java:231) ~[?:?]
	at org.openhab.binding.worxlandroid.internal.handler.WorxLandroidMowerHandler.internalHandleCommand(WorxLandroidMowerHandler.java:225) ~[?:?]
	at org.openhab.binding.worxlandroid.internal.handler.AWSClientThingHandler.handleCommand(AWSClientThingHandler.java:196) ~[?:?]

Is the channel expecting a different command now?

Thank you so much!

1=Normal mode, 2=Party mode.

It is still a String Itemtype, not a Number Itemtype, though.

1 Like

Thanks, somehow either I had set the command options manually or it was mapped in the binding before!

Connection stable at the moment. But still the problem that I can’t change the zone definitions (starting point in meters)… Hopefully this will be solved soon. Currently I’m carrying the robot by hand to each zone, which makes my wife laugh a lot…

I will take care of this as soon as I’m sure I’ve solved the connection stability issue. Happy to be funny to your wife :slight_smile:

No issues on my side so far! Thank you a lot for your time and work that went into this!

Same here.
Also big thx from my side.


it seems that the connection on my side dropped again yesterday morning about 4 o’clock.

Now i disabled and enabled the bridge again and the bridge is online again.

Edit: Could you pls. tell me how to enable the proper logging? I would be very happy to support with more useful details…


Issue seems to be fixed also for me. Online since around 3 days without interruption.
THANK YOU VERY MUCH! :+1::+1::+1:

log:set DEBUG org.openhab.binding.worxlandroid

Good job! It’s been stable since the update. Thank you very much!

1 Like

The connection dropped again…

2023-09-21 20:53:05.629 [DEBUG] [worxlandroid.internal.mqtt.AWSClient] - connection interrupted errorcode: 5134 : The connection was closed unexpectedly.
2023-09-21 20:53:10.630 [DEBUG] [worxlandroid.internal.mqtt.AWSClient] - lastResumed: 2023-09-21T20:38:05.353863685  interrupted: 2023-09-21T20:53:05.629393945 in: false
2023-09-21 20:53:10.631 [DEBUG] [ternal.handler.AWSClientThingHandler] - AWS connection closed -> refreshing token to reconnectToWorx
2023-09-21 20:53:36.132 [DEBUG] [landroid.internal.api.WorxApiHandler] - URI: https://api.worxlandroid.com/api/v2/product-items/2021XXXXXXXXXXXXXXXXX?status=1
2023-09-21 20:53:36.533 [DEBUG] [nal.handler.WorxLandroidMowerHandler] - Refreshing Thing 2021XXXXXXXXXXXXXXXX failed, handler might be OFFLINE```