Zwave - Aeotec Gen5 will not Stay Online

I have been using the zwave binding for a few years now. I have been using the Aeotec Gen5 zstick (ZW090) for a couple of years as well without any issues. Recently I cannot get the zstick controller to stay online.

If I close openHAB and use the Z-Wave PC Controller 5 software, I am able to control my zwave light switches. This seems to tell me that my zwave controller is working properly, but I could be missing something.

I am hoping someone can take a look at my configuration and logs and point me in the right direction. I have tried a soft reset of my controller. I have also tried a fresh install of openHAB 2.5.2. I also tried a fresh install of Windows.

I commented out a bunch of my nodes to try to simplify the problem. I have tried installing the zstick controller through PaperUI and through configuration files without success either way.

Any advice would be much appreciated. Maybe I just need a new zstick controller.

Here is my zwave.things file:

Bridge	zwave:serial_zstick:myzstick	"Z-Wave Serial Controller" [port="COM5",controller_master="true",controller_softreset="false",heal_enable="true",security_networkkey=""]
    Thing	zooz_zen23_00_000		node29		"Master_Bedside: ZEN23 Z-Wave Plus On/Off Toggle Switch V1" 		[ node_id=29 ]

Here is my zwave.items file:

Switch		Master_Bedside		"Master Bedside Lights"						(Inside,All,Master)		["Switchable"]{channel="zwave:zooz_zen23_00_000:myzstick:node29:switch_binary"}

Here is my log:

full log file shared from dropbox

Thank you!

I know we are. What version of openHAB, Java version, and platform? Upgrade or fresh install?

Thanks for the reply @Bruce_Osborne. Sorry for those missing details.

  • openHAB 2.5.1 Stable runtime (I have tried a fresh install of 2.5.2, but the attached log file is from 2.5.1)
  • Java from zulu
  • Windows 10, 64bit
  • Fresh install, I was running 2.3.0 for quite some time and my zstick started going offline occasionally. A restart usually fixed it. This prompted me to download 2.5.1 (early February) and move my configurations over slowly.

Did you import any configuration? Invalid addons can cause all addons to be reloaded once a minute, trying to load the invalid one.

A common culprit is restdocs because it moved in 2,5. Check the addons.config file down in the userdata tree.

Three issues like this
1)2020-02-24 21:33:41.144 [WARN ] [ing.zwave.handler.ZWaveSerialHandler]
2) 2020-02-24 21:34:05.941 [WARN ] [ing.zwave.handler.ZWaveSerialHandler]
3) 2020-02-24 21:35:31.063 [WARN ]

This is one of them with last zwave debug lines before there is an issue with the serial connection.

2020-02-24 21:33:39.781 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 255: Added 48 to queue - size 25
2020-02-24 21:33:39.781 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 1 out at start. Holdoff false.
2020-02-24 21:33:40.939 [DEBUG] [sactionManager$ZWaveTransactionTimer] - NODE 255: TID 22: Timeout at state WAIT_RESPONSE. 3 retries remaining.
2020-02-24 21:33:40.940 [DEBUG] [sactionManager$ZWaveTransactionTimer] - TID 22: Transaction is current transaction, so clearing!!!
2020-02-24 21:33:40.940 [DEBUG] [e.internal.protocol.ZWaveTransaction] - TID 22: Transaction CANCELLED
2020-02-24 21:33:40.940 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 255: notifyTransactionResponse TID:22 CANCELLED
2020-02-24 21:33:40.940 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.
2020-02-24 21:33:40.941 [DEBUG] [wave.internal.protocol.SerialMessage] - Assembled message buffer = 01 04 00 41 0B B1
2020-02-24 21:33:40.941 [DEBUG] [nal.protocol.ZWaveTransactionManager] - TID 22: Transaction event listener: DONE: CANCELLED ->
2020-02-24 21:33:40.941 [DEBUG] [ing.zwave.handler.ZWaveSerialHandler] - NODE 255: Sending REQUEST Message = 01 04 00 41 0B B1
2020-02-24 21:33:40.942 [DEBUG] [alization.ZWaveNodeInitStageAdvancer] - NODE 26: Node Init response (0) org.openhab.binding.zwave.internal.protocol.ZWaveTransactionResponse@72ce198
> 2020-02-24 21:33:41.144 [WARN ] [ing.zwave.handler.ZWaveSerialHandler] - Got I/O exception Input/output error in writeArray during sending. exiting thread.
2020-02-24 21:33:41.144 [DEBUG] [zwave.handler.ZWaveControllerHandler] - Stopping ZWave network
2020-02-24 21:33:41.144 [DEBUG] [ve.internal.protocol.ZWaveController] - Shutting down ZWave controller
2020-02-24 21:33:41.145 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Shutting down transaction manager
2020-02-24 21:33:41.146 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Exiting ZWave Receive Thread
2020-02-24 21:33:41.146 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction manager shutdown

Half way down Chris suggests an issue with the serial driver or device.

When you are testing with PC Controller are you on same machine so same driver?

Possibly it will fail in this also if left long enough with enough traffic. Possibly try the test program in PC controller to give it some traffic and see if serial fails also.

Something like Z-Wave - Give it time to work but paced to similar to start of openHAB

1 Like

Here are the contents of the addons.config file. While reading the forums I saw others with the restdocs issue and some commas in the wrong places, but I don’t think anything is wrong here. Please let me know if I am mistaken:


I am on the same machine when I test with PC Controller.

It didn’t take too much to reproduce the error state with PC Controller. I added many nodes to the ERTT test, as you suggested, and my zstick has stopped responding. It seems frozen because the LED ring light has stopped changing colors. I left the delay at 100 ms between commands.

I tried many different test sequences and I noticed that if I include node 28 in the test sequence, it causes my failure. In fact, if I test node 28 by itself the zstick stops communicating. I think I will try testing each node one at a time and then exclude all the nodes that are causing my failure.

I wonder if this means I have a bad zwave light switch?

Thank you,

The log from openHab failed during a send to a different node but that does not say that node 28 did not send an unsolicited report that froze the stick.

These sort of things can be very odd. I have heard people claim all sorts of witches brew fixed them but I think often it is just within the brew they removed and re-added the node that happened to be the issue.

If you have a backup of the NVM from a while back I would suggest that rather than witches brew. If not if 28 is an issue remove it before testing as it may be transmitting something in the background and confuse your further tests. A zniffer always helps as you would see what node 28 is doing.

If you cannot fix, there is a way to move your network without having to re add everything but it involves having two further sticks. If you were to buy two then one could become a zniffer after you transfer. If you buy standard sticks like the silicon labs UZB-3 then you can use PC Controller to backup NVM and also they flash to zniffer with no issue. Other recent sticks will also work.

1 Like

Thanks for your suggestions. I ended up factory resetting the zstick, removing all nodes and re-adding everything except node 28. Once this is working stably, I will back up the zstick and go from there.

EDIT: It turns out that the PC Controller software reports that the Aeotect Gen5 zstick does not support NVM backups.

As a followup, my node that went bad was a ZEN23 V2 toggle switch that was controlling a fluorescent light fixture. I contacted The Smartest House and they replaced it under warranty and asked me to not use the switches with fluorescent fixtures.

Thanks again!