Zwave association to a multi-endpoint node


I am migrating from domoticz to openHAB2 with my zwave devices.
It works great so far. But one thing I cannot figure out…

I would like to make an association from a aeotec multisensor 6 (node 11) to a fibaro double relay switch (node 10).
In habmin2 I can set the association to “Node 10” under Configuration->Things->my_motion_sensor->Association Groups. This seems to work.
When I look at the association config in the paper UI I see a association to “node_10_0”.

But I need an association to “node_10_1”, which is the endpoint for the first (of two) relay switches of the fibaro double relay switch.

How can I set this association?

In habmin2 I can only choose “Node 10” (which results in node_10_0).
In the paper UI I can choose “node_10_1”, but I can’t save it. The save pencil icon is inactive.

Any hints for me?


This isn’t supported at the moment. Can you raise an issue on the issue tracker and I’ll look at adding this soon.

I’d like to associate switch 1 of a fibaro double relay switch with switch 2 of another fibaro double relay switch. I guess what I would need is this exact same missing feature.

Until this feature is availabe. Is there a known workaround?
For example, could I use some other tool beside openhab2 to configure such an association?


I will take a look at this over the coming days - it’s not too hard and I could probably add it very quickly into the development branch.

This is already implemented in the development binding - I’m not sure what version you’re using?

root@raspberrypi:~# dpkg -l | grep openhab2
ii  openhab2                       2.1.0~20170501000831-1     all          openhab2
ii  openhab2-addons                2.1.0~20170501000831-1     all          openhab2-addons
ii  openhab2-addons-legacy         2.1.0~20170501000831-1     all          openhab2-addons-legacy

I just upgraded to:

ii  openhab2                       2.1.0~20170519040644-1           all          openhab2
ii  openhab2-addons                2.1.0~20170519040644-1           all          openhab2-addons
ii  openhab2-addons-legacy         2.1.0~20170519040644-1           all          openhab2-addons-legacy

But there is no difference. I cannot choose the endpoint in habmin.


I don’t know exactly is it similar problem, but I notice same behaviour with Fibaro Door sensor FGK 101.

In habMIN at zwave map I see this sensor as not connected. When I check the properties in associating groups, I see the openhab controller at first group.

But in PaperUI when I want to check it associating group is empty. When I choose the openhab controller, I cannot save. Parameter 70 - Scene activation functionality - is underline at red, and suggestion is to change form 0.
But in Fibaro manuals there is 0 assign as no scene activation.

In logs I can see some WARN lines regarding this node:

[class.ZWaveMultiInstanceCommandClass] - NODE 11: Originating Command Class ALARM (0x71) was on the root node.<

Is it something known? What should I do to include fully this sensor.

I use last snapshot for openhab and addons.

1 Like

I’m not sure I understand exactly what you are doing but if you are trying to set associations through PaperUI then this doesn’t work and you should use Habmin.

The network map does not provide a reliable view of the network in the current version- it’s only really working on the development version so don’t worry about that.

This is only working in the development version at the moment. I’ll see if I can add it to master.

Ah. I thought the snapshot version is development :wink: I must have mixed up the terminology there.

If you could add this feature to master then, that would be great.
Thanks a lot!

Thanks Chirs

That’s give a bit more light on it :smile:

Openhab works at latest development (Snapshot release) version.
I add via habMIN all devices, but only one in PaperUI shows that one parameter (Fibaro door sensor no. 70) is wrongly set up.

The only open point which interesting me a bit is why this one sensor gives warn log “on the root node”. I thought that this is due to fact that it seems like this sensor, when looking for zwave map, is not connected.

I have few of Fibaro device and this one is only one which report strangely

[WARN ] [class.ZWaveMultiInstanceCommandClass] - NODE 11: Originating Command Class SENSOR_MULTILEVEL (0x31) was on the root node.

But it works more or less correct :slight_smile:


I have nearly the same scenario.
I am using 2 multisensors and have a double relay switch. I want to associate both sensors to each relay of the switch. How is this possible?


Hello Chris,

is it still in development?
Updated to 2.2 and still can´t choose the second endpoint of a node.

Thanks in advance…

The development version should have this - it should provide a list of all known endpoints. This will hopefully be merged into master soon.

Hello Chris,

thanks for your fast reply…hope it will come soon.


Hi there it´s me again… :grin:

Today i switched to the unstable version and i am now on openHAB 2.3.0 Build #1219.
I can´t see more nodes as before. Nothing really changed for me. One thing i recognized is, that
i now can set the association directly through the Paper UI and saving will work.

But no new endpoints in Paper UI or HABmin. Any ideas?

Thx in advance…

I’d suggest to try the development version which is available in the marketplace.

Hi Chris,

do you have update about it?

To use multi-channel feature is very important.

Thanks in advanced.

No - there is no further update. If you are having problems, please can you describe what the issue is?