ZWave binding updates

Tags: #<Tag:0x00007fc8f2388520>

I got that one too a while ago (have been running the dev version), I just ignored it and continued using the old controller Thing. So for anyone else reading, you don’t really need to switch controller Thing :wink:

2 Likes

This is correct - the new controller will likely appear on Linux systems as there is an auto detection of USB devices available under Linux now. When upgrading, it’s probably best to ignore this to avoid issues with names of channels etc.

2 Likes

People on 2.3 and the latest binding have reported 500 errors when configuring zwave devices.

Ah, okay, thx. I saw those posts but did not catch the root cause behind it.

Me either… I spent some time searching and couldn’t locate a definitive cause, but the solution seemed to always be an upgrade to an OH snaphot build.

1 Like

Now that dev is merged into master, I wanted to revisit how I upgrade to the latest version of the zwave binding without updating the rest of openHAB.

Simply using bundle:update org.openhab.binding.zwave from the karaf console is not working for me.

The only thing I found to work is to explicitly provide the exact location of the jar in the bundle:update command. Like this.

openhab> list -s | grep zwave
227 │ Active   │  80 │ 2.x.0.old-date     │ org.openhab.binding.zwave

openhab> bundle:update org.openhab.binding.zwave https://ci.openhab.org/job/openHAB2-Bundles/lastSuccessfulBuild/artifact/bindings/org.openhab.binding.zwave/target/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar     

openhab> list -s | grep zwave
227 │ Active   │  80 │ 2.5.0.new-date     │ org.openhab.binding.zwave
1 Like

TMK, bundle:update should pull down the latest. Do you get the latest if you uninstall and reinstall? I’d test, but I’m still using manual installs.

I tried that earlier today and it didn’t work either.

@sihui I see this issue you opened a while back is still open. To your knowledge, is using uninstall/install to update the version of a binding still broken?

I tested again and realized a whole mess:

Let’s start with the current state:

openhab> bundle:list|grep -i zwave
256 │ Active   │  80 │ 2.4.0.201809091339     │ ZWave Binding

Then I executed

openhab> bundle:update org.openhab.binding.zwave

and got

openhab> bundle:list|grep -i zwave
256 │ Active   │  80 │ 2.4.0.201809091339     │ ZWave Binding

So this did not work.

Then I tried

bundle:update "ZWave Binding"

and got the same version again.

openhab> bundle:uninstall org.openhab.binding.zwave

gives an empty karaf screen, but the binding is still showing as installed in PaperUI. Although it does not work anymore :sunglasses:

I did not try to restart openHAB, maybe that solves the PaperUI problem.

Next try:

openhab> bundle:install org.openhab.binding.zwave
Bundle IDs:
Error executing command: Error installing bundles:
        Unable to install bundle org.openhab.binding.zwave: org.osgi.framework.BundleException: Error reading bundle content.

No luck.

So I hit the uninstall button again in PaperUI and the blue mark is gone. Then I installed the zwave binding through PaperUI and it shows:

openhab> bundle:list|grep -i zwave
264 │ Active   │  80 │ 2.4.0.201809091339     │ ZWave Binding

So actually NOTHING works :rofl:

Nothing at all in the logs, btw.

Edit: ahh, damn, it looks like there is no newer zwave snapshot than 2.4.0.201809091339

But isn’t this the most current version? I just updated to build 1357 about an hour ago, and that’s the zwave version I got with that build.

Oops. Nm. I just saw your edit.

1 Like

Just done the update, but no longer see any neighbors in the individual things, and don’t see the network map in Habmin. Is this expected?

No.

Did you

To the letter!

Ups. Are your devices online?
Did you check via karaf that the correct binding version is active?

Everything is back online, but I’ve also noticed that there are no references in the log re discovering network neighbors.

bundle version: 2.4.0.201809091339

I think this is fine - just wait for the nightly heal.

Thanks Chris, will do :slight_smile:

Just to clarify - I removed all of this from the initialisation to keep the initialisation traffic to a minimum to try and speed up the initialisation. On large networks, this can take a long time, so first time around, you’ve got to wait for the heal…

(if it’s not working again tomorrow, then let me know :slight_smile: )

New snapshot build available, I tried again:

264 │ Active   │  80 │ 2.4.0.201809091339     │ ZWave Binding
openhab> bundle:update org.openhab.binding.zwave
openhab> bundle:list|grep -i zwave
264 │ Active   │  80 │ 2.4.0.201809091339     │ ZWave Binding

Then I tried PaperUI, uninstalled zwave, installed zwave:

openhab> bundle:list|grep -i zwave
272 │ Active   │  80 │ 2.4.0.201809091339     │ ZWave Binding

So it is correct that the issue is still open :rofl: