ZWave binding updates

zwave
Tags: #<Tag:0x00007f014b22fc60>

(Cernon) #238

But why Security inclusion don‘t work?


(Scott Rushworth) #239

Just a thought, but the device may need to be in close proximity to the controller to be securely included.


(Chris Jackson) #240

What does the log file show? It should log what is happening, and if security fails, it will log some information as to why it failed. Maybe this will help to answer your question?


(Mr. Wiseman) #241

Looking for recommendations . . .

I have a bunch of WeMo devices controlling lights; 3 of them are for the outside lights.

I’d like to replace my time based rules when to turn lights on/off with actual light levels outside. I have a bunch of the Aeotec Multisensor 6, Z-Wave Plus 6-in1 motion devices
which I do use the Luminance function of them to control my HUE Lights inside. The negative side of this device is it only polls hourly.

Does anybody have a better suggestion for a zWave device that “just” does Luminance that I could mount in a window pointing outside which intern would drive my WeMo light activation?

Best, Jay


(Mark) #242

I’m not aware of anything.

Note that the ZW100 is supposed to support luminance reports based on the luminance value exceeding a threshold (config parameters 40-45). However, I just saw a post from someone else who is having trouble making that work.


(Jim) #243

Greetings, did you include the Multi-sensor 6 on line power, or is it on battery? I have one on line power that I use the luminance for in many rules such as what you are talking about. It seems to update quite often.

I see your topic says on battery. Do you have any line power option for it? I don’t think a battery device will have the update frequency you are looking for.

Jim


(Lorenzo Thurman) #244

It was included and runs on battery. I don’t have an outlet close enough to it, or I would have set it that. Shame it won’t update quickly enough without main power.


(Mr. Wiseman) #245

Battery for all them . . . are you saying try power to it and it will update more often? How often? 15 mins or so?

Best, Jay


(Angelos) #246

If USB Powered: with parameter 111 you can set it as low as 30 seconds (I think that minimum is 5 seconds)
If it was included using Battery: you may have to exclude it because it keeps the Battery “profile” (default 3600 seconds = 1 hour)

https://aeotec.freshdesk.com/support/solutions/articles/6000156717-troubleshoot-multisensor-6-sensors-light-humidity-temperature-uv-

https://aeotec.freshdesk.com/support/solutions/articles/6000115071-difference-between-usb-and-battery-power-and-recommendations-multisensor-6-zw100-


(Nico) #247

Hello Dominic!
I’ve got the same problem like you with the WallC-S Switch. Can you tell me how you’d solved it? How did you change the configuration to “central scene”?
Thank you in advance for your help!
Best regards, Nico


(Rolf Vermeer) #248

I manager to get it to work by setting parameter 11 and 12 to 8, Central scene to gateway.
Bare in mind that you have to wake up the device and send NIFs several times in general to get the settings into the WallC-S. (Done by holding all 4 buttons for 5 seconds and then pressing button 2)

After that, button 1 wil send a 1.0 when clicking once, button 2 wil send a 2.0 and so on. Button 1 will send a 1.1 repeatedly when being held and a 1.2 when being released, and so on.
When double clicking a button, button 1 wil send a 5.0, button 2 a 6.0 and so on. For click and hold (so pressing once, releasing and then press and hold), button 1 will send a 5.1 repeatedly while being held and a 5.2 when being released, and so on for the subsequent buttons.

For all this, bare in mind that the manual states that it needs a z-wave plus controller for this to work.

I have two WallC-S devices now and to be honest they were quite a challenge to set up right, more than any other device I own.


(Ulrich) #249

I updated OH from 2.3 to 2.4 M6.
Now I’m experiencing a strange issue with my rollershutters (Fibaro FGR222).

Rollershutter rol_WoZi_RolladenWest "Rolladen Wohnzimmer West %" <rollershutter> (gWohnzimmer,gRolladen,gLog) { channel="zwave:device:gehirn:node4:blinds_control", config_invert_percent="true", config_invert_control="false" }

The channel parameter config_invert_percent="true" seems to be ignored.
It doesn’t matter if I set it to true or false, the shutter moves to the wrong direction when sending a percentage value to it.


(Angelos) #250

was this config_invert_percent working fine in 2.3.0 Stable?

Check this (note: this is old): Z-Wave Binding invert_state=false and invert_percent=true


(Ulrich) #251

Thanks, that was it… I could delete the parameters from the the item definition it still works well.
In my previous stable version 2.3.0 it was working without any problem.


(Angelos) #252

I don’t get it… you had the config_invert_percent in the Item config while on OH2.3.0 and it was working?
Are you sure? because from what I understand, this parameter was always supposed to be defined on the Channel settings of your Things file.

You didn’t have any warnings in your openhab.log about this setting in your *.items file?

Do you use *.things for Z-Wave?

And… now you removed it from the Item definition, did not add it to a Thing’s Channel and all works fine?


(SiHui) #253

Correct.
In snapshot #1433, which should be identical to M6, it is still working that way.


(Ulrich) #254

I used that binding version:
2018-10-07 19:30:31.565 [INFO ] [internal.service.FeaturesServiceImpl] - mvn:org.openhab.binding/org.openhab.binding.zwave/2.3.0
I had not complains about my items.

The controller is defined via file. This is since a long time, I do not remember when I did it.

// ZWave
Bridge	zwave:serial_zstick:gehirn	"Z-Wave Controller auf Gehirn" @ "Flur EG"
[
port="/dev/ttyAMA0", security_inclusionmode=0, 
security_networkkey="xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx", 
controller_master=true, controller_suc=false, controller_wakeupperiod=3600, 
controller_softreset=0, controller_hardreset=0, controller_sync=0, 
controller_exclude=0, controller_inclusiontimeout=30, heal_time=2, inclusion_mode=2
]

The devices are defined via habmin / paperui. There I changed it now for the device channel.
Now the item definition looks like:

Rollershutter	rol_WoZi_RolladenWest	"Rolladen Wohnzimmer West %" <rollershutter>	(gWohnzimmer,gRolladen,gLog) { channel="zwave:device:gehirn:node4:blinds_control" }

My tests were positive, but if really everything is fine, I’ll see in the evening.


(SiHui) #255

From all I’ve read in the past three years that is not possible :sunglasses:

I guess you had success by pure chance because of this:

The proper way to configure the invert percent option is:

Also note that with flat config files you cannot set any parameters:


(Ulrich) #256

I had a look in my backup and I found, that these parameters were defined within the thing.
I don’t know when it came at this place. But obviously I removed it while the upgrade.
That’s an argument for me to declare also the zwave things via files and not via UI.

  "zwave:device:gehirn:node4": {
    "class": "org.eclipse.smarthome.core.thing.internal.ThingImpl",
    "value": {
      "label": "Rolladen WoZi West",
      "bridgeUID": {
        "segments": [
          "zwave",
          "serial_zstick",
          "gehirn"
        ]
      },
      "channels": [
        {
          "acceptedItemType": "Switch",
          "kind": "STATE",
          "uid": {
            "segments": [
              "zwave",
              "device",
              "gehirn",
              "node4",
              "switch_binary"
            ]
          },
          "channelTypeUID": {
            "segments": [
              "zwave",
              "switch_binary"
            ]
          },
          "label": "Switch",
          "configuration": {
            "properties": {}
          },
          "properties": {
            "binding:*:OnOffType": "SWITCH_BINARY"
          },
          "defaultTags": []
        },
        {
          "acceptedItemType": "Rollershutter",
          "kind": "STATE",
          "uid": {
            "segments": [
              "zwave",
              "device",
              "gehirn",
              "node4",
              "blinds_control"
            ]
          },
          "channelTypeUID": {
            "segments": [
              "zwave",
              "blinds_control"
            ]
          },
          "label": "Blinds Control",
          "configuration": {
            "properties": {
              "config_invert_control": false,
              "config_invert_percent": true,
              "config_duration": 255.0
            }
          },


(Ulrich) #257

There is another topic I have after the upgrade. Adding the the device Z-Wave Node 013: ZD2102-5 Door Window Sensor as thing via PaperUI throws these errors:

2018-11-25 18:01:28.963 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zwave:device:gehirn:node13' to inbox.
2018-11-25 18:01:58.181 [ERROR] [nal.common.AbstractInvocationHandler] - An error occurred while calling method 'ThingHandler.initialize()' on 'org.openhab.binding.zwave.handler.ZWaveThingHandler@bad62': 1
java.lang.ArrayIndexOutOfBoundsException: 1
	at org.openhab.binding.zwave.handler.ZWaveThingHandler.initialiseNode(ZWaveThingHandler.java:226) ~[?:?]
	at org.openhab.binding.zwave.handler.ZWaveThingHandler.bridgeStatusChanged(ZWaveThingHandler.java:512) ~[?:?]
	at org.openhab.binding.zwave.handler.ZWaveThingHandler.initialize(ZWaveThingHandler.java:164) ~[?:?]
	at sun.reflect.GeneratedMethodAccessor95.invoke(Unknown Source) ~[?:?]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]
	at java.lang.reflect.Method.invoke(Method.java:498) ~[?:?]
	at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect(AbstractInvocationHandler.java:153) [101:org.eclipse.smarthome.core:0.10.0.oh240M6]
	at org.eclipse.smarthome.core.internal.common.Invocation.call(Invocation.java:53) [101:org.eclipse.smarthome.core:0.10.0.oh240M6]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
	at java.lang.Thread.run(Thread.java:748) [?:?]
2018-11-25 18:01:58.257 [ERROR] [core.thing.internal.ThingManagerImpl] - Exception occurred while initializing handler of thing 'zwave:device:gehirn:node13': 1
java.lang.ArrayIndexOutOfBoundsException: 1
	at org.openhab.binding.zwave.handler.ZWaveThingHandler.initialiseNode(ZWaveThingHandler.java:226) ~[?:?]
	at org.openhab.binding.zwave.handler.ZWaveThingHandler.bridgeStatusChanged(ZWaveThingHandler.java:512) ~[?:?]
	at org.openhab.binding.zwave.handler.ZWaveThingHandler.initialize(ZWaveThingHandler.java:164) ~[?:?]
	at sun.reflect.GeneratedMethodAccessor95.invoke(Unknown Source) ~[?:?]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]
	at java.lang.reflect.Method.invoke(Method.java:498) ~[?:?]
	at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect(AbstractInvocationHandler.java:153) [101:org.eclipse.smarthome.core:0.10.0.oh240M6]
	at org.eclipse.smarthome.core.internal.common.Invocation.call(Invocation.java:53) [101:org.eclipse.smarthome.core:0.10.0.oh240M6]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
	at java.lang.Thread.run(Thread.java:748) [?:?]