Zwave problem on new OH4 install

Hello all,
I just installed openhab 4 M4 fresh form the download page on a Raspi 4 / 4Gb of RAM
with the initial installation openhab was starting correctly.
But when disabling the serial line via the config tool to have access to the razberry z-wave board, openhab is not running anymore after the reboot.
follwing messages I do get:

2023-07-16 12:26:50.332 [INFO ] [org.openhab.core.Activator ] - Starting openHAB 4.0.0.M4 (build Milestone Build)

2023-07-16 12:26:51.415 [WARN ] [.transport.servlet.ServletController] - Can’t find the request for’s Observer

2023-07-16 12:26:52.458 [WARN ] [.transport.servlet.ServletController] - Can’t find the request for’s Observer

2023-07-16 12:26:55.668 [WARN ] [.transport.servlet.ServletController] - Can’t find the request for’s Observer

2023-07-16 12:26:58.609 [WARN ] [.transport.servlet.ServletController] - Can’t find the request for’s Observer

2023-07-16 12:27:21.536 [INFO ] [.core.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007

2023-07-16 12:27:22.491 [WARN ] [.transport.servlet.ServletController] - Can’t find the request for’s Observer

2023-07-16 12:27:22.852 [WARN ] [.transport.servlet.ServletController] - Can’t find the request for’s Observer

2023-07-16 12:27:23.287 [INFO ] [nal.ScriptEngineFactoryBundleTracker] - All automation bundles ready.

2023-07-16 12:27:27.760 [INFO ] [e.automation.internal.RuleEngineImpl] - Rule engine started.

it is restarting again and again.
anyone an idea what I have done wrong?

not milestone or OH4 specific so I moved your post

Ok thanks. Sorry I did not post too much things in the past.
Short Update: after some reboots openHAB is running
But the the razberry module as a z-wave controller is not recognized at all

sorry I have to draw back, after a new reboot openHAB is restarting again and again…

following log:
2023-07-16 13:15:29.611 [WARN ] [org.jline ] - Unable to create a system terminal, creating a dumb terminal (enable debug logging for more information)

2023-07-16 13:15:32.218 [INFO ] [org.openhab.core.Activator ] - Starting openHAB 4.0.0.M4 (build Milestone Build)

2023-07-16 13:15:32.887 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Time zone set to ‘Europe/Berlin’.

2023-07-16 13:15:32.900 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Location set to ‘48.57692596695807,8.916645169083496’.

2023-07-16 13:15:32.902 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Locale set to ‘de_DE’.

2023-07-16 13:15:35.732 [WARN ] [.transport.servlet.ServletController] - Can’t find the request for's Observer

2023-07-16 13:15:46.086 [INFO ] [.core.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007

2023-07-16 13:15:52.147 [INFO ] [nal.ScriptEngineFactoryBundleTracker] - All automation bundles ready.

2023-07-16 13:15:52.877 [WARN ] [ty.util.ssl.SslContextFactory.config] - Trusting all certificates configured for Client@1058664[provider=null,keyStore=null,trustStore=null]

2023-07-16 13:15:52.879 [WARN ] [ty.util.ssl.SslContextFactory.config] - No Client EndPointIdentificationAlgorithm configured for Client@1058664[provider=null,keyStore=null,trustStore=null]

2023-07-16 13:15:53.547 [INFO ] [basic.internal.servlet.WebAppServlet] - Stopped Basic UI

2023-07-16 13:16:06.811 [WARN ] [service.spi.util.WebContainerManager] - Can’t get a WebContainer service from {org.osgi.service.http.HttpService, org.ops4j.pax.web.service.WebContainer}={org.ops4j.pax.web.log.ncsa.extended=true, org.ops4j.pax.web.ssl.keystore.password=, service.scope=bundle, org.ops4j.pax.web.ssl.key.password=,,, org.ops4j.pax.web.enc.iterationcount=1000, org.ops4j.pax.web.log.ncsa.file=yyyy_mm_dd.request.log, org.ops4j.pax.web.server.eventDispatcherThreadCount=1, org.osgi.service.http.checkForwardedHeaders=false, org.ops4j.pax.web.enc.suffix=), org.ops4j.pax.web.digestAuth.maxNonceAge=60000, org.ops4j.pax.web.ssl.ciphersuites.included=, org.ops4j.pax.web.session.url=jsessionid, org.ops4j.pax.web.formAuth.errorRedirect=false, org.ops4j.pax.web.ssl.ciphersuites.excluded=^.(MD5|SHA|SHA1)$,^TLS_RSA.$,^SSL_.$,^.NULL.$,^.anon.*, org.ops4j.pax.web.enc.prefix=ENC(, org.ops4j.pax.web.server.maxThreads=50, org.ops4j.pax.web.validatePeerCerts=false,, org.ops4j.pax.web.session.cookie.maxAge=-1, org.ops4j.pax.web.ssl.truststore.password=, org.ops4j.pax.web.ssl.session.cacheSize=-1, org.ops4j.pax.web.ssl.truststore.type=JKS, org.ops4j.pax.web.ssl.keystore.type=JKS, org.ops4j.pax.web.ssl.session.enabled=true, org.ops4j.pax.web.ssl.protocol=TLSv1.3, org.osgi.service.http.port=8081,, org.ops4j.pax.web.ssl.renegotiationLimit=-1,, org.osgi.service.http.enabled=true, org.ops4j.pax.web.server.idleTimeout=300000, org.ops4j.pax.web.log.ncsa.retaindays=90, org.ops4j.pax.web.log.ncsa.logtimezone=GMT, org.ops4j.pax.web.enc.algorithm=PBEWithHmacSHA256AndAES_128, org.ops4j.pax.web.validateCerts=false, org.ops4j.pax.web.config.files=/usr/share/openhab/runtime/etc/jetty.xml, org.ops4j.pax.web.ssl.renegotiationAllowed=true, org.ops4j.pax.web.digestAuth.maxNonceCount=1024, org.ops4j.pax.web.enableOCSP=false, org.ops4j.pax.web.ssl.clientauth.needed=false, org.ops4j.pax.web.enc.enabled=false,, javax.servlet.context.tempdir=/var/lib/openhab/tmp, org.ops4j.pax.web.enableCRLDP=false, org.ops4j.pax.web.server.connector.idleTimeout=30000, org.ops4j.pax.web.session.timeout=10, org.ops4j.pax.web.ssl.clientauth.wanted=false, org.ops4j.pax.web.ssl.protocols.excluded=SSL,SSLv2,SSLv2Hello,SSLv3, service.bundleid=222, org.ops4j.pax.web.server.minThreads=2,, org.ops4j.pax.web.enc.masterpassword=, org.ops4j.pax.web.log.ncsa.append=true,, org.ops4j.pax.web.ssl.session.timeout=-1, org.ops4j.pax.web.listening.addresses=, org.ops4j.pax.web.log.ncsa.buffered=true, org.ops4j.pax.web.session.cookie.sameSite=unset, org.ops4j.pax.web.log.ncsa.enabled=false, org.ops4j.pax.web.ssl.protocols.included=, org.ops4j.pax.web.session.cookie.httpOnly=true, org.ops4j.pax.web.server.showStacks=false}

If I recall correctly, there was a recent thread or two about openHAB going into a start up loop. Search a little, and you may find the culprit.

Thanks for the hint.
I was searching around and could not find anything about OH4, I only found OH3 related topics

one other question: where can I still can get the OH4 M3 build ?
I had this running on my raspi with buster as basis.
Just would like to try this out.
The new OH4 M4 installation comes with bullseye as basis.

Bernd, sorry for probably dumb question but…

What ‘config tool’ are you speaking about? (again, sorry if dumb question)
and also maybe why this is needed (I’m guessing because razberry z-wave board) so folks without knowledge of that hardware can lend a hand tracking down your issue

Well, one of the things I almost mentioned was to change the ‘search by’ criterion to ‘most recent’ instead of the default which is ‘relevance’. I have suggested several time that changing the default search criteria to most recent instead of relevance makes more sense, but I digress.
Anyhow… I entered ‘loop’ into the search and sorted by ‘most recent’ and in the three minutes I spent looking, one was OH3 but the other was OH4. Both seemed to center around not having a valid network connection. Although your issue seems unrelated, I wonder if not having a serial connection triggers a similar problem causing the startup loop.
And of course, if it involves serial, I immediately wonder if it is the old serial lock file bug which also has recently reared it’s ugly head.
You probably have no idea about this bug so do another quick search for serial lock file or something similar. Just guessing here, feel free to ignore my rant

Hello Andrew,

I am using the openhabian-config to setup openHAB. no other special tool.
As you mentioned, I really do not know the serial lock file bug

Hopefully some can help sorting out this strange behavior.

This post was not marked as solved, but there was no further activity after the last suggestion by @anon71759204 . New to OpenHab, trying to get Z Wave to work - Setup, Configuration and Use / Beginners - openHAB Community. Might want to try.

start here
grab a nice beverage, you’ll be reading for a bit :slightly_smiling_face:

Hello all,
I have now OH4 running up again.
What was the problem:
I have installed the new image directly to the external drive connected to the raspi. Basically it worked since I have moved the system to the external drive with the last installation.
But it somehow did not wok.
So I installed the system again on a SD-Card and made the setup here.
Then moved the system again back to the external USB drive.
Now everything is working again also with the Z-Wave configuration.
No idea why only the Z-Wave had an issue. Maybe in this procedure the disable of the serial line did not work correctly so the Z-Wave controller was not recognized.

1 Like