#1534 --- Failed installing 'openhab-misc-restdocs'

Tags: #<Tag:0x00007f6173c4f1b8>

Yesterday I installed 2.5.0-Snapshot with openhabian.config

Since then a have several problem one of them is, that I geht this message several times per minute:

2019-04-01 09:49:28.805 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007

2019-04-01 09:49:28.831 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-misc-restdocs'

This two messages rise everytime together! How can I solve it?

Hello,
I have solved, as managed a few posts above.
Go to the directory: /var/lib/openhab2/config/org/openhab
Edit file : addons.config
look for the misc= line and delete param restdocs
reboot

4 Likes

I have the same error, but my addons.config has the following in MISC?
misc=“ruleengine”

Any Ideas.

Thanks

I have no text file at all referencing rest docs but get this error constantly through all the versions since over a month (since I took notice of it).

Can that be any relic from an old version? I am using OpenHAB on this instance since 2.1.

I have the same problem, although with openhab-action-mail.

This is different from the original issue. You probably didn‘t notice that the mail-Action has Been moved to the legacy addons and is replaced by a new mail binding. You need to enable „legacy addons“ to use it.

Yes, I know. Is there a way to remove ‘mail-Action’? I have not found a way yet, neither in Paper UI nor in the carafe console. I cannot find ‘mail-Action’ in bundle:list.

How did you install it originally? Probably in addons.cfg?

Nope, neither 'services\addons.cfg nor ‘addons.config’ was not used.

I had the same problem with 2.5.0.M2 and Mail-Action.
I got the problem solved after enabling Legacy v1.x Binding Support.
Then I could UNINSTALL the old Mail-Action Bindings.

1 Like

I have this same issue. Can’t find a 1.X version to install to remove, it was never in my addons.cfg. On 2.4M4.

You meen 2.5M4? I just did as described above with great success, remove the line misc=“restdocs” from addons.conf:

solved it! Thx

Worked for me - much appreciated!

Same situation here. addons.cfg is fully commented. Can’t find the Legacy version to remove the old openhab-misc-restdocs. On 2.5_M5

@dbadia

I bet you have addons.config in folder

/var/lib/openhab2/config/org/openhab/

or

/userdata/config/org/openhab/

Please check the misc and legacy entries inside this file.

And it does not exist a legacy version of restdocs. In above mentioned post the author said, that he could not install or uninstall a legacy binding or action, because it was set legacy=false in addons.config.

1 Like

Thanks for the suggestions @Celaeno1
I got this fixed.

The only copy is under conf/services:

openhab@pi-openhab> find . -name “addons.cfg”
./conf/services/addons.cfg

The file is essentially empty, as every line is commented:

# See https://www.openhab.org/docs/configuration/packages.html for a detailed    explanation of these packages.
#
#package = minimal

# Access Remote Add-on Repository
# Defines whether the remote openHAB add-on repository should be used for browsing and installing add-ons.
# This not only makes latest snapshots of add-ons available, it is also required for the installation of
# any legacy 1.x add-on. (default is true)
#
#remote = true

# Include legacy 1.x bindings. If set to true, it also allows the installation of 1.x bindings for which there is
# already a 2.x version available (requires remote repo access, see above). (default is false)
#
#legacy = true

# A comma-separated list of bindings to install (e.g. "binding = sonos,knx,zwave")
#binding =

# A comma-separated list of UIs to install (e.g. "ui = basic,paper")
#ui =

# A comma-separated list of persistence services to install (e.g. "persistence = rrd4j,jpa")
#persistence =

# A comma-separated list of actions to install (e.g. "action = mail,pushover")
#action =

# A comma-separated list of transformation services to install (e.g. "transformation = map,jsonpath")
#transformation =

# A comma-separated list of voice services to install (e.g. "voice = marytts,freetts")
#voice =

# A comma-separated list of miscellaneous services to install (e.g. "misc = myopenhab")
#misc =

The solution was to uncomment the misc line and add the misc bindings I want to keep (I only use openhabcloud), like this:

misc = openhabcloud 

Then restart. No more openhab-misc-restdoc errors after that

Perhaps this is what was being suggested all along and I just didn’t interpret it correctly.

Thanks for the help!
Dave

1 Like

Thank you! I spent hours on this annoyance.

BUT it’s kludgey. I too added a redundant binding to misc= to “solve” the problem. I think it’s only a matter of time before this “fix” comes back to bite me.

You probably shouldn’t add any add-ons to services/addons.cfg if you’ve installed them all using the UI. If you do it will probably uninstall all add-ons that were previously installed using the UI.

The best way to prevent this for users that install add-ons using the UI is to uninstall the REST docs before updating. See Breaking Changes in the 2.5.0 release notes.

Thanks.

I followed a tutorial that recommended specifying bindings within addons.cfg rather than using paper UI, with a caveat about paper UI-installed bindings being removed.

I added misc = market to addons.cfg and haven’t seen any adverse effects in Paper UI.

Remembering to uninstall the REST docs before updating is something I would certainly forget to do. I’d guess that most people would not uninstall the docs either.