Aeotec Nano Shutter configuration problems

zwave
items
Tags: #<Tag:0x00007f1e58883da8> #<Tag:0x00007f1e58883c68>
(Frank) #1

Just got my first Aeotec Nano Shutter.
The Openhab documentation looks strange - a mix of Shutter and Dimmer language. There also is no Shutter Channel, but only a Dimmer channel.
I tried to define an item as a Rollershutter but without luck, did not get it to work.
Is this device correctly defined in the database?

0 Likes

(Angelos) #2

which doc?

There is no such thing as a Shutter Channel. A dimmer channel is used to control shutters (from 0% to 100%)

and we are supposed to guess your Item configuration?

Of course it is: https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/912

#1, #9, #11

0 Likes

(Frank) #3

Sorry for not being precise - Please forgive me, I am a Newbee here.

I am on Openhab 2.4 using the new zWave binding.

The device got added to the zWave network via PaperUI. The physical wallswitch works correctly.

Item definition - initial try:

Rollershutter               GF_Toilet_Shutter                
    { channel="zwave:device:512:node15:switch_dimmer"}

With this item-definition, the device does not react to “Up - Stop - Down” Openhab commands (e.g. via PaperUI / Control)

Item definition - second try:

Dimmer         GF_Toilet_Shutter
    { channel="zwave:device:512:node15:switch_dimmer"}

enables interaction with the device.
In PaperUI / Controls, the item is displayed as:

grafik

Moving the slider to 0% shuts the blinds completely. Moving the slider to any other position will open the blinds completely.

I also tested out a simple rule to check, if I could open the blinds partially:

rule "test 3"
when
    Item Test_2 changed to OFF
then
    GF_Toilet_Shutter.sendCommand(50)
    
end

When the Test_2 switch is set to OFF, the blinds move up completely - the slider on the UI shows exactly 50%.

grafik

Can anyone please give me a clue - what am I doing wrong?

0 Likes

(Frank) #4

I like to come back to my problem: has anyone been able to get the slider to work with the Aeotec Nano Shutter yet? If so, what is your Thing and your Item definition?
I am only able to fully close and fully open the blinds at this time.
Thank you.

0 Likes

(Gabor Boros) #5

Hello Frank,
the situation is known for me as well, and i know the source of the problem, but i cant solve it.
The issue is, that there is a parameter: 35: Moving time left to right, and this is set to 30, and not possible to change it, its gray.
If you are changing the parameter 252: Enable/disable config parameters to be locked, the value is jumping to -106, but to change to moving time is not possible.

Your problem is, that the time 30 is too long for you. try to set 10% or 5% to test your build-up.

Hopefully there is an expert, who can help you/us to solve the issue.
regards,
Gabor

0 Likes

(SiHui) #6

That parameter was set to “read only” in the database. I have changed this so after upgrading to the latest zwave 2.5 snapshot binding (in a few days when the changes got merged into the binding) you should be able to set it to values between 0-100.

1 Like

(Gabor Boros) #7

i really like this community, you are top!

0 Likes

(Frank) #8

thanks for opening up this parameter.
unfortunately, changing this parameter does not fix my issue. I changed to down to 10, then 5 and 1, but the dimmer function does still not work for the shutter. The blinds do only move fully up or fully down. Moving the slider to >0 always closes the blinds completely, i.e. jumps to 100%.
Same when changing the parameter up, to e.g. 50.
any other ideas?

0 Likes

(SiHui) #9

Yes, use a Rollershutter itemtype in your items file and a Switch item in your sitemap:

grafik

0 Likes

(Frank) #10

mmm… I did what you suggested:

here is my item file:

Rollershutter GF_Toilet_Shutter                
    { channel="zwave:device:512:node15:switch_dimmer"}

and my sitemap:

Switch item=GF_Toilet_Shutter label="Rolladen"   icon="blinds"

this is how it looks like in Basic UI:
grafik

The item on the sitemap does not trigger any function, i.e. the blinds do not move.
Would it be possible to see your item and sitemap config for the rollershutter?
Do you also use an AEOTEC Nano Shutter?

again, thanks for your support.

0 Likes

(SiHui) #11

You need to use the same item name in your items file and sitemap file.

Edit: okay, you already edited your post :sunglasses:

0 Likes

(Frank) #12

yep.
still not working

0 Likes

(SiHui) #13

My item is linked to a blinds_control channel (Fibaro), maybe my solution does not work for a switch_dimmer channel.

0 Likes

(Frank) #14

that may very well be the case.
so I need someone, who got it to work with the AEOTEC Nano Shutter.
Strange, that the AEOTEC shutter only supports a Dimmer channel …

0 Likes

(.) #15

Any update on this? I have one Aeotec Shutter running currently here in combination with a Feller switch. So far so good, but the intermediate positions also don’t work…

0 Likes

(Marco) #16

Hi there

I’m interested in this topic as well. I do have the exactly same installation as wolkenjaeger: an Aeotec Nano Shutter in combination with a Feller EDIZIOdue switch. UP, DOWN and STOP work with the Feller switch but no luck with the software…

Btw: Is there a solution to represent the Aeotec Nano Shutter as a rollershutter on the sitemap? I wasn’t able getting this to work. All I have is a dimmer. This part of the question isn’t for the function, it’s only for aesthetic reasons though.

Thanks for any input on this!

0 Likes

(Chris Jackson) #17

The channel probably should not be switch_dimmer, but blinds_control instead.

@sihui - feel free to update. Since I don’t have any blinds, I’m a bit hesitant to change as I’m not completely sure of the impact in the UI etc, but you probably know? Changing it to the blinds channel will give you the up/down controls though.

0 Likes

(SiHui) #18

The switch_dimmer channel on a rollershutter device always causes trouble in the UI because there is no chance to get a STOP command and no UP/DOWN either.

Wouldn’t this be a usecase for the “deprecated” flag on the switch_dimmer channel, @chris ? This way users using the old channel have a chance to switch to the new channel without needing to ask in the forum why their device is not working anymore :grinning:

0 Likes

(Chris Jackson) #19

Good question… I’m not sure if it will cause problems with the exporter with channel naming - possibly it’s ok I think, but if you want to add the new channel, and mark the old one as deprecated, then I’ll have a quick look at the XML before we export it.

I agree though - if it works without too much trouble, then yes, it’s exactly the use case :slight_smile:

0 Likes

(SiHui) #20

Done

0 Likes