Help with Zigbee LIDL Smart Colour-Change LED Light Bulb channel (HG07834C)

openHAB 3.2.0 - Release Build running on openhabian RPI 3B with zigbee binding.

I’ve recently set up a hacked LIDL Zigbee gateway, and socat, using some tutorials and posts from the community here, many thanks for that.

I have successfully set up an Ember EM35x Coordinator. I’ve used the zigbee scan to add in 2 Lidl plugs and a light bulb. The bulb is a HG07834C, the binding has picked it up as a TS0505B, which I believe is correct. The channel type is Color, and has some of the functions, on off, dimmer, color.
However the bulb is RGBW, and I cant get the full brightness and color temperature, even though the RGB color is working.

Is there anything else I need to do?

Even if your problem seems to be related to the W (and not the RGB) part of your device, you could try to reconfigure the Thing:

Settings → Things → [your device] → Channels → Color → Channel Details - XY Commands:

This is for a Lidl TS505A RGBW bulb, so YMMV.

1 Like

I think it would be good to see logs - so we can see what is going on. The binding always sends the full range where 0-100% = 0-254, so it should always be full brightness range (assuming the bulb conforms to the standards).

Here the binding reads back the minimum and maximum from the bulb, and uses this to scale the slider value since there is no control in OH for color temperature. Again it would be good to see the debug logs to understand what is happening.

Hi AP15e and thanks for the reply. Yes I’ve tried auto, hue and XY, but this didn’t seem to make a difference.

So I think that when the Gateway and bulb were initially set up using the Lidl (Tuya) Smartapp, the bulb had on/off, white light (cool/warm etc) and dimmer. The colour part had hue and dimmer. Once I changed the gateway and set it up with Openhab and paired the bulb, I seem to have lost the white light.

When I put the bulb into pairing mode it defaults back to bright white. Once it pairs, the channel is Color, as you’ve posted. If I only use the on/off switch and dimmer control then the buld works fine, and 100% brightness seems fine. Once I go the the color slider or wheel, the bulb dims, and I’m assuming thats because the white led turns off and the rgb leds stay on. But I’m only guessing.

Chris, thanks for the reply, I’m a relative newcomer here, so if someone can let me know how to turn on logging I can get the logs, I assume that in openhab-cli console.

I did try looking at some zigbee commands, and also looked at the configs and found this /var/lib/openhab/zigbee/zigbee_coordinator_ember_fcdea088fa/0C4314FFFE8D92E2.xml . The output from zigbee nodes is

Total known nodes in network: 4
Network  Addr  IEEE Address      Logical Type  State      EP   Profile                    Device Type                Manufacturer     Model          
      0  0000  847127FFFE7EB732  COORDINATOR   ONLINE   
  14825  39E9  BC33ACFFFE516592  ROUTER        ONLINE     11  ZIGBEE_HOME_AUTOMATION     ON_OFF_PLUG_IN_UNIT        _TZ3000_00mk2xzy  TS011F         
                                                         242  ZIGBEE_GREEN_POWER         0061                                                       
  32457  7EC9  84FD27FFFED78305  ROUTER        ONLINE     11  ZIGBEE_HOME_AUTOMATION     ON_OFF_PLUG_IN_UNIT        _TZ3000_00mk2xzy  TS011F         
                                                         242  ZIGBEE_GREEN_POWER         0061                                                       
  39851  9BAB  0C4314FFFE8D92E2  ROUTER        ONLINE      1  ZIGBEE_HOME_AUTOMATION     EXTENDED_COLOR_LIGHT       _TZ3000_qd7hej8u  TS0505B        

The luminous flux in color mode is significantly lower than in white mode - AFAIK there is nothing OH/the ZigBee Binding can do about it - it’s a physical limitation of the device.

But I’m not sure whether this addresses your problem. Could you please describe your expectation and your observation once more?

Edit:
See LIVARNO LUX® Leuchtmittel RGB, dimmbar, »Zigbee Smart …

LIVARNO LUX® Leuchtmittel RGB, dimmbar, »Zigbee Smart Home« (Kugel)

Von Lidl-Shop Kunde am 04.06.2021

Hat alles gut geklappt
Indie weißtöne sind sehr gut und hell
Leider sind Farben recht dunkel was sehr schade ist
Da fehlt echt die Leuchtkraft

Machine translation:

LIVARNO LUX® illuminant RGB, dimmable, “Zigbee Smart Home” (ball)

From Lidl store customer on 04.06.2021

Has everything worked well
Indie white shades are very good and bright
Unfortunately, colors are quite dark which is a pity
There is really missing the luminosity

Welcome.

Please take a look at the zigbee binding docs - toward the bottom there is a section called something like “what to do when things don’t go to plan” and in there is how to enable logging.

Just paste/attach the logs here and I’ll try and take a look.

My expectation was that I would be able to switch on white mode, I only seem to have color mode. But maybe I’m not understanding the binding?

Chris, thanks, and sorry I did read the zigbee binding docs, I’d just forgotten! Its also possible that everything is working as designed and I’ve just misunderstood how the binding is working. And again, thanks for the assistance.

it will be the weekend before I get to the logs…

zigbee-herdsman-converters/lidl.js at 53a365d1daa4760a9740599264e5c259fb092661 · Koenkk/zigbee-herdsman-converters · GitHub defines a specific colour temperature range ([153, 500]) for TS0505B (in contrast to TS0505A):

{
        fingerprint: [{modelID: 'TS0505A', manufacturerName: '_TZ3000_dbou1ap4'}],
        model: 'HG06106C',
        vendor: 'Lidl',
        description: 'Livarno Lux E27 bulb RGB',
        ...extend.light_onoff_brightness_colortemp_color({disableColorTempStartup: true}),
        meta: {applyRedFix: true, enhancedHue: false},
        configure: async (device, coordinatorEndpoint, logger) => {
            device.getEndpoint(1).saveClusterAttributeKeyValue('lightingColorCtrl', {colorCapabilities: 29});
        },
    },
    {
        fingerprint: [{modelID: 'TS0505B', manufacturerName: '_TZ3000_qd7hej8u'}],
        model: 'HG07834C',
        vendor: 'Lidl',
        description: 'Livarno Lux E27 bulb RGB',
        ...extend.light_onoff_brightness_colortemp_color({disableColorTempStartup: true, colorTempRange: [153, 500]}),
        meta: {applyRedFix: true, enhancedHue: false},
        configure: async (device, coordinatorEndpoint, logger) => {
            device.getEndpoint(1).saveClusterAttributeKeyValue('lightingColorCtrl', {colorCapabilities: 29});
        },
    },

It might be that the TS0505B returns wrong min and max values for the colour temperature range.

I’m not sure that I understand the issue here. Is it that there is no color temperature channel, or that the color temperature channel doesn’t work?

This statement seems to make me believe that the channel doesn’t exist, which probably means that the device doesn’t report some attributes or color types properly.

I would also suggest to ensure you use the latest binding - ie the SNAPSHOT version - just so we know it’s current.

Chris, yes sorry, I didn’t really know what i was asking. The color channel and item work fine. The bulb also has a white led, I assumed that would appear, and I would be able to use it.

Sorry - but I’m still not sure I understand :slight_smile: .

Do you have two channels showing for this device - ie a color “channel”, and another one for the color temperature? I’m assuming there is only this single color channel, and no color temperature channel?

Can you use the console and try the zigbee fingerprint <node> command to see what that shows please?

Just for reference:

and

1 Like

Chris, this is what I get…

I put the bulb into pairing mode. its flashes, so I do a zigbee scan I get a thing and a color channel. The bulb stops flashing and it illuminated bright white.

I then link and create an item …

If I turn the light on/off or use the brightness dimmer, the light varies between off and bright white. Once I move the hue or saturation, it seems like the bulb visibly dims, as it looks like the white led turns off, and only the red, green and blue leds are on.

If I pair the bulb to a normal Lidl zigbee hub, I get a on/off, dimmer, cool to warm light, and rgb colour also dim-able.

So maybe I’ve not understood the limitations of using the hacked Lidl gateway, or possibly its a limitation of the bulb, gateway and zigbee implementation,

The gateway won’t impact this - it will come down to how the device implements the color control. The binding expects to see certain features in the device, and if it sees them, it creates the color control channel. It does this using standard zigbee functionality, so it should work with all devices conforming to the standards, but sometimes there is more than one way to do something (or possibly the device is doing something non-standard).

@Ap15e I assume this is a different bulb than @Ferg is trying to get working?

My bulb identifies itself as _TZ3000_dbou1ap4 / TS0505A (not as TS0505B).

Fingerprint:

|>| Node Descriptor
| |> Logical Type               ROUTER
| |> MAC Capabilities           [FULL_FUNCTION_DEVICE, MAINS_POWER, RECEIVER_ON_WHEN_IDLE]
| |> Stack Compliance           22
| |> Server Capabilities        []
| |> Buffer Size                82
| |> Incoming Transfer Size     82
| |> Outgoing Transfer Size     82
|
|>| Power Descriptor
| |> Available Power Sources    [MAINS]
| |> Current Power Source       MAINS
| |> Current Power Mode         RECEIVER_ON_IDLE
| |> Power Level                FULL
|
|>| ZDO
| |> ManagementBindRequest      SUCCESS
| |> IeeeAddressRequest         SUCCESS
| |> ManagementLqiRequest       SUCCESS
| |> ManagementRoutingRequest   SUCCESS
|
|>| Basic Information
| |> Generic Device Class
| |> Generic Device Type
| |> Manufacturer Name          _TZ3000_dbou1ap4
| |> Model Indentifier          TS0505A
| |> Product Code
| |> Product URL
| |> Date Code
| |> Application Version        80
| |> Software Build ID
| |> Hardware Version           1
| |> Zcl Version                3
| |> Stack Version              0
| |
| |>| Endpoint 1
| | |> Profile                  0104  ZIGBEE_HOME_AUTOMATION
| | |> Device Type              010D  EXTENDED_COLOR_LIGHT
| | |> Device Version           1
| | |
| | |>| Input Clusters
| | | |
| | | |>| Cluster 0000 Basic
| | | | |> Type                 Server [Input]
| | | | |> Manufacturer Spec.   No
| | | | |
| | | | |>| Commands Generated
| | | | | |> FAILURE
| | | | |
| | | | |>| Commands Received
| | | | |> FAILURE
| | | | |
| | | | |>| Attributes Supported
| | | | | |> 0000 ZCL Version
| | | | | |> 0001 Application Version
| | | | | |> 0002 Stack Version
| | | | | |> 0003 HW Version
| | | | | |> 0004 Manufacturer Name
| | | | | |> 0005 Model Identifier
| | | | | |> 0006 Date Code
| | | | | |> 0007 Power Source
| | | | | |> FFDE Unknown
| | | | | |> FFFD Unknown
| | | | | |> FFFE Unknown
| | | |
| | | |>| Cluster 0003 Identify
| | | | |> Type                 Server [Input]
| | | | |> Manufacturer Spec.   No
| | | | |> Unsupported locally
| | | |
| | | |>| Cluster 0004 Groups
| | | | |> Type                 Server [Input]
| | | | |> Manufacturer Spec.   No
| | | | |> Unsupported locally
| | | |
| | | |>| Cluster 0005 Scenes
| | | | |> Type                 Server [Input]
| | | | |> Manufacturer Spec.   No
| | | | |
| | | | |>| Commands Generated
| | | | | |> FAILURE
| | | | |
| | | | |>| Commands Received
| | | | |> FAILURE
| | | | |
| | | | |>| Attributes Supported
| | | | | |> 0000 Scene Count
| | | | | |> 0001 Current Scene
| | | | | |> 0002 Current Group
| | | | | |> 0003 Scene Valid
| | | | | |> 0004 Name Support
| | | | | |> FFFD Unknown
| | | |
| | | |>| Cluster 0006 On/Off
| | | | |> Type                 Server [Input]
| | | | |> Manufacturer Spec.   No
| | | | |
| | | | |>| Commands Generated
| | | | | |> FAILURE
| | | | |
| | | | |>| Commands Received
| | | | |> FAILURE
| | | | |
| | | | |>| Attributes Supported
| | | | | |> 0000 On Off
| | | | | |> FFFD Unknown
| | | |
| | | |>| Cluster 0008 Level Control
| | | | |> Type                 Server [Input]
| | | | |> Manufacturer Spec.   No
| | | | |
| | | | |>| Commands Generated
| | | | | |> FAILURE
| | | | |
| | | | |>| Commands Received
| | | | |> FAILURE
| | | | |
| | | | |>| Attributes Supported
| | | | | |> 0000 Current Level
| | | | | |> 000F Options
| | | | | |> FFFD Unknown
| | | |
| | | |>| Cluster 0300 Color Control
| | | | |> Type                 Server [Input]
| | | | |> Manufacturer Spec.   No
| | | | |> Unsupported locally
| | | |
| | | |>| Cluster 1000
| | | | |> Type                 Server [Input]
| | | | |> Manufacturer Spec.   No
| | | | |> Unsupported locally
| | |
| | |>| Output Clusters
| | | |
| | | |>| Cluster 000A Time
| | | | |> Type                 Client [Output]
| | | | |> Manufacturer Spec.   No
| | | | |> Unsupported locally
| | | |
| | | |>| Cluster 0019 Ota Upgrade
| | | | |> Type                 Client [Output]
| | | | |> Manufacturer Spec.   No
| | | | |
| | | | |>| Commands Generated
| | | | | |> FAILURE
| | | | |
| | | | |>| Commands Received
| | | | |> FAILURE
| | | | |
| | | | |>| Attributes Supported
| | | | | |> 0000 Upgrade Server ID
| | | | | |> 0001 File Offset
| | | | | |> 0006 Image Upgrade Status
| | | | | |> FFFD Unknown
| |
| |>| Endpoint 242
| | |> Profile                  A1E0  ZIGBEE_GREEN_POWER
| | |> Device Type              0061
| | |> Device Version           0

I might be wrong (once again :slight_smile: ), but I’d say OPs problem is related to the fact that OPs bulb seems to have a specific colour temperature range (see Help with Zigbee LIDL Smart Colour-Change LED Light Bulb channel (HG07834C) - #10 by Ap15e). The colour temperature channel is missing from OPs screenshot.

I don’t think so. This is not one of the criteria for creating the channel - the binding is only checking to see if certain capabilities are supported. I’m not saying that this might not also be an issue at some point, but it is definitely not the reason that there is no channel being detected.

Let’s ensure the latest version is being run, then get the logs and see what’s happening…

@chris @Ap15e I’ve got most of my OpenHab set up with MQTT binding and Tasmota devices. I’ve only just got the Lidl Zigbee gateway with some plugs and bulbs and followed the guides to “freeing the gateway” and tried connecting it to my setup. Before posting here, I’d used openhabian-config upgrade the system to the latest release and have been having some issues with the iPhone App.

I’ve decided this was rushed, so I’m setting up a test server at the weekend. and will install the zigbee binding and test and generate the logs. This will eliminate any other issues, and ensure that I don’t break my existing setup. Thanks for your help so far.

1 Like