Homematic IP device status updates stop being received by openHAB (but controlling these devices still works)

Platform information:

  • Homematic IP Hardware: CCU2 (2.59.7), multiple Homematic IP devices
  • openHAB Hardware: Raspi 3 (Raspian OS 10)
  • openHAB Software: 3.1.0 Release Build, running on Docker 2.6.2
  • openHAB Bindings: Homematic Binding (logging the heating, controlling lights and blinds), Gardena Binding for Gardena Gateway / smart irrigation control (logging soil humidity), Alexa Binding (controlling the Homematic lights)

I observed a rather odd behavior with my Homematic binding. While I could fix it easily with a reboot of openHAB, I’d like to know whether this is either a (known) bug or a configuration issue on my side.

Observation:
(log entries illustrative, so log times do not match my observation)
Until around 4:12 pm today, things worked perfectly: I was able to control Homematic items perfectly via openHAB…

22:49:24.360 [INFO ] [openhab.event.ItemCommandEvent       ] - Item 'Stehlampe' received command ON
22:49:24.368 [INFO ] [openhab.event.ItemStatePredictedEvent] - Item 'Stehlampe' predicted to become ON
22:49:24.379 [INFO ] [openhab.event.ItemStateChangedEvent  ] - Item 'Stehlampe' changed from 14 to 100

… and sensors and devices (if switched on the device itself / not via openHAB) regularly sent their status updates to openHAB…

23:16:08.637 [INFO ] [openhab.event.ItemStateChangedEvent  ] - Item 'Lichtsensor_Garten_HighestIllumination' changed from 1.08 lx to 1.09 lx
23:16:50.843 [INFO ] [openhab.event.ItemStateChangedEvent  ] - Item 'Thermostat_Garten_ActualTemperature' changed from 23.3 °C to 23.2 °C
23:30:52.802 [INFO ] [openhab.event.ItemStateChangedEvent  ] - Item 'Stehlampe' changed from 0 to 100
23:30:55.839 [INFO ] [openhab.event.ItemStateChangedEvent  ] - Item 'Stehlampe' changed from 100 to 0

At 4:12 something odd happened: While I could continue to control my Homematic devices via openHAB, the status updates of the sensors and devices stopped reaching openHAB.

Example:
While the CCU2 continued to monitor my light sensor with a time resolution of 1 - 3 minutes…


… it did not reach openHAB anymore (refer to the straight line at the end of the graph)…

… even though the communication between openHAB and the CCU was still in place (I could still control devices).

What’s even more odd: The communication between the CCU and Openhab did not stop completely at 4:12. After a short break there was one more update at 4:32, and then after a loooong break another update only at 10:15 (~ 6 hours later).

After doing an openHAB reboot, everything went back to normal (devices and sensors sending their status updates regularly again).

My interpretation: Since…

  • …everything was still logged correctly at the CCU…
  • … a reboot of the openHAB binding fixed the problem…
  • … and, during the time of the odd behavior, devices could still be controlled via openHAB…
  • … the problem can’t be on the CCU-side…
  • … and I suspect maybe a bug in the openHAB Homematic binding?

Or is it a configuration issue?

Problem is that, if this happens unnoticed, it prevents logging altogether for as long as you reboot openHAB.

Looking forward to your thoughts.

Update: What I experienced sounds similar to what has been described here After network outage Homematic items are visible and receiving updates on the device, but not updating values in Openhab - #10 by Cplant and here Debugging Homematic IP: no updates on some HmIP devices after some time

The IP devices are a bit “stubborn”. I have tried to find a solution and you can download a test version of the binding here: https://github.com/MHerbst/openhab-addons-test

I am not sure whether it will work with 3.1. Maybe you have to use a Milestone release of 3.2. Because you are using the binding in a Docker container you also have to configure the correct callback address.